Visite: BR-Linux ·  VivaOLinux ·  Dicas-L


  • Atualizações no phpMyAdmin Corrigem Vulnerabilidades

    O phpMyAdmin Team anunciou o lançamento das versões 3.3.5.1 e 2.11.10.1 para a sua ferramenta de administração de banco de dados, apresentando importantes atualizações de segurança que corrigem uma vulnerabilidade considerada crítica e diversas vulnerabilidades consideradas relevantes. Segundo os desenvolvedores, uma falha crítica no ramo 2.11.x do phpMyAdmin pode ser usada para "enganar" o set-up script utilizado para gerar configurações a partir de uma solicitação POST, criada para incluir código PHP arbitrário em um arquivo de configuração gerado. Quando combinado com a capacidade de salvar arquivos no servidor, isso poderia permitir que usuários não autenticados executassem o referido código PHP. Os desenvolvedores disseram que é bastante provável que o ramo de 3.x do phpMyAdmin tenha sido afetado.




    Além disso, a correção atualiza várias ocorrências de vulnerabilidades Cross-Site Scripting (XSS) nos ramos 2.11.x e 3.x que poderia ser utilizado para lançar um ataque XSS utilizando URLs especialmente criadas para esta finalidade maliciosa. Há suspeitas de que todas as versões anteriotes tenham sido afetadas e dessa forma, os programadores aconselham que todos os usuários façam as devidas atualizações o mais rapidamente possível. As versões 3.3.5.1 e 2.11.10.1 do phpMyAdmin estão disponíveis para download a partir do site do projeto. phpMyAdmin é licenciado sob a segunda versão da GNU General Public License (GPLv2).


    Saiba Mais:

    [1] phpMyAdmin: http://sourceforge.net/news/?group_id=23067&id=290746
    [2] Download do phpMyAdmin 3.3.5.1 e 2.11.10.1: http://www.phpmyadmin.net/home_page/downloads.php

    Sobre o Autor: Camilla Lemke

    Redatora do Portal Under-Linux.Org, com ênfase em Distribuições Linux, Análise Forense Computacional, Testes de Invasão, Auditoria de Redes e Sistemas. Atuante como Analista e Gerente de Finanças.