• Wireshark: Atualizações para Corrigir Vulnerabilidade

    O Wireshark lançou nesta quinta-feira (13) a versão 1.2.14 e a 1.4.3 do seu analisador de protocolo de rede open source e multiplataforma. Segundo os desenvolvedores, as atualizações de segurança corrigem uma vulnerabilidade de alto risco (CVE-2010-4538) que pode permitir a um atacante remoto iniciar um ataque Denial-of-Service (DoS) ou possivelmente executar código arbitrário no sistema da vítima.

    Afetando tanto o ramo 1.2.x quanto o 1.4.x do Wireshark, o problema seria supostamente causado por um buffer overflow no ENTTEC (epan/dissectors/packet-enttec.c). Segundo informações, a vulnerabilidade em questão é desencadeada pela injeção de um pacote ENTTEC DMX especialmente criado com compressão Run Length Encoding (RLE). Um problema de estouro de buffer no MAC-LTE também foi resolvido nas duas versões; na versão 1.4.3, uma vulnerabilidade no dissector ASN.1 BER foi corrigida.

    Todos os usuários devem fazer as atualizações necessárias com as últimas versões. Alternativamente, os usuários que não conseguem fazer a atualização para as versões mais recentes podem desativar o dissectors afetados pela seleção "Analyze" e depois em "Enabled Protocols" a partir do menu e un-checking "ENTTEC" e "MAC-LTE". Mais detalhes sobre as atualizações, incluindo uma lista completa de mudanças, pode ser encontrados nas notas de lançamento para as versões 1.2.14 e 1.4.3. Os binários do Wireshark para Windows e Mac OS X, bem como o código-fonte, estão disponíveis para download.


    Saiba Mais:

    [1] Wireshark 1.4.3 and 1.2.14 Released: http://www.wireshark.org/news/20110111.html
    [2] CVE-2010-4538: http://cve.mitre.org/cgi-bin/cvename...=CVE-2010-4538

    Sobre o Autor: Camilla Lemke


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L