• Nova Vulnerabilidade Crítica no VLC Media Player

    Update 1.1.6, lançado na semana passada, corrige uma vulnerabilidade crítica no VLC Media Player. Agora, o projeto relatou uma nova vulnerabilidade que pode ser explorada utilizando filmes MKV (Matroska Vídeo e WebM) especialmente criados para injetar códigos maliciosos em um sistema e executar esse código com os privilégios do usuário. Todas as versões, anteriores à 1.1.6 são afetadas pela falha.

    A raiz do problema encontra-se com a validação da entrada insuficiente no MKV demuxer plugin ( libmkv_plugin .* ). A atualização consiste na troca de uma única linha dentro de uma macro. Uma atualização oficial, que será a versão 1.1.7, está prevista para ser lançada em breve. Alternativamente, os desenvolvedores recomendam excluir manualmente o plugin em questão, a partir do diretório de instalação. Como MKV é um formato de vídeo HD muito comum, uma atualização pode ser uma solução melhor.


    Saiba Mais:

    [1] Security Advisory 1102:
    http://www.videolan.org/security/sa1102.html
    [2] Heise On-line: http://www.h-online.com/open/news/it...r-1180905.html

    Sobre o Autor: Camilla Lemke


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L