• Foxit Reader 5.4 Corrige Vulnerabilidade DLL Hijacking

    O lançamento recente do Foxit Software 5.4, foi disponibilizado para corrigir uma vulnerabilidade DLL hijacking, que poderia ser explorada por um atacante com a intenção de comprometer o sistema da vítima. Segundo a empresa, as versões anteriores do seu software continham uma falha de segurança que permitia a execução de código malicioso, armazenado em uma biblioteca de vínculo dinâmico (DLL) que estivesse infectada. Para que um ataque fosse bem sucedido, a vítima deveria primeiro abrir um arquivo PDF no mesmo diretório, como uma versão especialmente criada de um arquivo DLL.



    Foxit Reader laçou atualização para corrigir falha de alta relevância


    Isso poderia ocorrer, por exemplo, quando um atacante publicasse um arquivo PDF em um compartilhamento de WebDAV ou SMB, e colocasse a DLL trabalhada na mesma pasta de compartilhamento. Quando o arquivo fosse aberto, o Foxit seria carregado e começaria a carregar bibliotecas do sistema. Assim, um DLL malicioso com o mesmo nome de uma biblioteca de sistema, poderia injetar-se na aplicação e ter seu código executado. Em decorrência disso, versões incluindo o Foxit Reader 5.3.1.0606 foram afetadas.


    Saiba Mais:

    [1] Heise On-line http://www.h-online.com/security/new...y-1703878.html


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L