• Vulnerabilidades Críticas na Plataforma OpenX Expõe Milhões de Pessoas a Riscos

    A High-Tech Bridge Security Research Lab, através de um trabalho realizado pelos seus pesquisadores, descobriu múltiplas vulnerabilidades na plataforma OpenX, onde pode ser explorada a execução de código PHP arbitrário e realizar ataques Cross-Site Scripting (XSS), causando comprometimento no sistema vulnerável.




    Local File Inclusion em OpenX: CVE-2013-3514. Há um input através de "group" HTTP GET parameter para scripts "/www/admin/plugin-preferences.php" e "/www/admin/plugin-settings.php", não estando devidamente verificados antes de serem utilizados em funções PHP include (); assim, eles podem ser explorados também para incluir arquivos locais arbitrários. Isso se dá através de seqüências transversais de diretório e técnicas URL-encoded NULL byte.

    O PoC seguinte (Proof-of-Concept) mostra o conteúdo de código do arquivo "/etc/passwd" no sistema vulnerável, explorando a vulnerabilidade no primeiro script. O segundo PoC exibe o conteúdo do arquivo "/etc / passwd" no sistema vulnerável, usando a vulnerabilidade constante no segundo script. A exploração bem sucedida destas vulnerabilidades requer privilégios administrativos. No entanto, também pode ser explorada por um atacante remoto não autenticado via CSRF, uma vez que o aplicativo é propenso a ataques Cross-Site Request Forgery (CSRF).


    Saiba Mais:

    [1] Net Security http://www.net-security.org/secworld.php?id=15179


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L