Página 5 de 5 PrimeiroPrimeiro 12345
+ Responder ao Tópico



  1. #81

    Padrão

    Citação Postado originalmente por netosdr Ver Post
    O script está executando sim, veja nesta tela que vc postou o RUN COUNT, já rodou e muito, talvez ele não esteja funcionando mas rodando está...

    Um dica, usa o nome do script sem espaços...
    he como vc disse esta rodando porem sem efeito .
    vou fazer como vc disse colocando o nome sem espaços e ver se funciona
    e posto o resultado.
    grato.

  2. #82

    Padrão

    Mais uma pergunta,fazendo a script funcionar,ela faz somente o cliente que entrou alto desconectar ou todos?
    Na versão 3.13 da mk.



  3. #83

    Padrão

    Citação Postado originalmente por gulinhaster Ver Post
    Mais uma pergunta,fazendo a script funcionar,ela faz somente o cliente que entrou alto desconectar ou todos?
    Na versão 3.13 da mk.
    Todos com ack alto conectados na wan que vc selecionar...

  4. #84

    Padrão

    Citação Postado originalmente por netosdr Ver Post
    Todos com ack alto conectados na wan que vc selecionar...

    Então não derruba todos não somente os que estiverem altos.



  5. #85

    Padrão

    Citação Postado originalmente por gulinhaster Ver Post
    Então não derruba todos não somente os que estiverem altos.
    Somente os que tiverem o ACK maior que o valor que vc configurar no script.

    Ex:
    :global ack 50;

    Desconecta todos com ack acima de 50.

  6. #86

    Padrão

    Citação Postado originalmente por netosdr Ver Post
    Somente os que tiverem o ACK maior que o valor que vc configurar no script.

    Ex:
    :global ack 50;

    Desconecta todos com ack acima de 50.

    Aqui esta funcionando legal agora,valeu ai pessoal.



  7. #87

    Padrão

    Vou fazer uma pergunta "besta".
    Teria como adaptar essa script ai para derrubar quem ebtrar com o sinal muito ruim na RB,ou tem alguma outra forma de fazer isso?

  8. #88

    Padrão

    Citação Postado originalmente por gulinhaster Ver Post
    Vou fazer uma pergunta "besta".
    Teria como adaptar essa script ai para derrubar quem ebtrar com o sinal muito ruim na RB,ou tem alguma outra forma de fazer isso?
    esse script faz isso se o ack time out ta muito ruim provavelmente o sinal tbm esteja
    agora so bloquear quem estiver com sinal ruim he para os colegas que fez o script
    mais vc pode coloca os clientes em Access List ai so conecta quem estiver na lista blz..



  9. #89

    Padrão

    Citação Postado originalmente por netosdr Ver Post
    O script está executando sim, veja nesta tela que vc postou o RUN COUNT, já rodou e muito, talvez ele não esteja funcionando mas rodando está...

    Um dica, usa o nome do script sem espaços...
    vc tinha razão amigo tirei os espaços e pimba hehehe
    vlw pela dica.

  10. #90

    Padrão

    Citação Postado originalmente por 14735 Ver Post
    esse script faz isso se o ack time out ta muito ruim provavelmente o sinal tbm esteja
    agora so bloquear quem estiver com sinal ruim he para os colegas que fez o script
    mais vc pode coloca os clientes em Access List ai so conecta quem estiver na lista blz..
    Cheguei a fazer isso,mas aqui eu uso hotspot dai quando eu vou na casa do cliente e coloco o kit pra ele na hora já faço ele navegar sem eu precisar ir lá na mk e liberar nada.
    Mas se não tiver outra alternativa terei que fazer isso,pq eu largo tbm um tempinho trial para testarem a internet,já consegui bastante clientes com isso tbm.



  11. #91

    Padrão

    o do sinal.. basta cadastrar o mac "FF:FF:FF:FF:FF:FF" na access list.. e colocar o range do sinal..

  12. #92

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    o do sinal.. basta cadastrar o mac "FF:FF:FF:FF:FF:FF" na access list.. e colocar o range do sinal..
    Seria uma solucao mas o cliente com sinal ruim vai ficar totalmente sem acesso, talvez se tivesse (deve ter) de pesquisar o sinal na registration sem desativar ele por completo, sendo assim, poderia até colocar ele em uma lista em que exibe um aviso do hotspot indicando que o sinal dele está ruim, ou até mesmo mandar um e-mail pro administrador com o ip e mac de quem está com sinal ruim pra que seja verificado....



  13. #93

    Padrão

    Bom dia, aonde eu encontro material sobre como escrever scripts para mikrotik? esse script do ack timeout fincionou a contento mas eu queria um que escrevesse no log apenas quando encontrasse ack timeout acima do definido, este fica enchendo o log de besteiras como parabéns ...
    EDIT:

    Editando o script para só escrever no log se encontrar alguem com ack acima do estipulado basta deletar o que esta marcado em vermelho?

    # Defina abaixo o valor mínimo de ACK
    :global ack 30;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo 1 para dropar e 0 para não dropar o cliente que estiver acima do valor mínimo
    :global drop 1;

    # Defina abaixo a Interface
    :global interf "wlan1";
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    };
    :if ($drop = 1) do={
    /interface wireless registration-table remove $i;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info "Parabéns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };


    Agradecido.
    Última edição por numlock; 04-12-2008 às 23:46.

  14. #94

    Padrão boa tarde a tdos!

    Nao consegui fazer funcionar na versao 3.17. Tem alguma modificacao pra fazer no script??



  15. #95

    Padrão

    Citação Postado originalmente por SSiNET Ver Post
    Nao consegui fazer funcionar na versao 3.17. Tem alguma modificacao pra fazer no script??
    Não. Eu uso na 3.17.