Página 19 de 19 PrimeiroPrimeiro ... 141516171819
+ Responder ao Tópico



  1. o do sinal.. basta cadastrar o mac "FF:FF:FF:FF:FF:FF" na access list.. e colocar o range do sinal..

  2. Citação Postado originalmente por alexandrecorrea Ver Post
    o do sinal.. basta cadastrar o mac "FF:FF:FF:FF:FF:FF" na access list.. e colocar o range do sinal..
    Seria uma solucao mas o cliente com sinal ruim vai ficar totalmente sem acesso, talvez se tivesse (deve ter) de pesquisar o sinal na registration sem desativar ele por completo, sendo assim, poderia até colocar ele em uma lista em que exibe um aviso do hotspot indicando que o sinal dele está ruim, ou até mesmo mandar um e-mail pro administrador com o ip e mac de quem está com sinal ruim pra que seja verificado....



  3. Bom dia, aonde eu encontro material sobre como escrever scripts para mikrotik? esse script do ack timeout fincionou a contento mas eu queria um que escrevesse no log apenas quando encontrasse ack timeout acima do definido, este fica enchendo o log de besteiras como parabéns ...
    EDIT:

    Editando o script para só escrever no log se encontrar alguem com ack acima do estipulado basta deletar o que esta marcado em vermelho?

    # Defina abaixo o valor mínimo de ACK
    :global ack 30;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo 1 para dropar e 0 para não dropar o cliente que estiver acima do valor mínimo
    :global drop 1;

    # Defina abaixo a Interface
    :global interf "wlan1";
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    };
    :if ($drop = 1) do={
    /interface wireless registration-table remove $i;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info "Parabéns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };


    Agradecido.
    Última edição por numlock; 04-12-2008 às 22:46.

  4. Nao consegui fazer funcionar na versao 3.17. Tem alguma modificacao pra fazer no script??



  5. Citação Postado originalmente por SSiNET Ver Post
    Nao consegui fazer funcionar na versao 3.17. Tem alguma modificacao pra fazer no script??
    Não. Eu uso na 3.17.






Tópicos Similares

  1. regra para ack timeout
    Por thenet no fórum Redes
    Respostas: 15
    Último Post: 22-11-2007, 21:58
  2. Ack timeout
    Por EDUipiranga no fórum Redes
    Respostas: 5
    Último Post: 10-09-2007, 11:09
  3. ACK TimeOut fixo ou dinâmico?
    Por marcelomg no fórum Redes
    Respostas: 9
    Último Post: 24-02-2007, 00:38
  4. O que interfere no ACK TimeOut (cartão como AP)
    Por liandrocarniel no fórum Redes
    Respostas: 16
    Último Post: 22-02-2007, 08:41
  5. Ack Timeout
    Por alexsk no fórum Redes
    Respostas: 0
    Último Post: 29-08-2006, 14:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L