Página 8 de 16 PrimeiroPrimeiro ... 345678910111213 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #43

    Padrão

    nos scripts do mikrotik

    system > scripts

  2. #44

    Padrão

    Tem como fazer parte do processo manualmente?

    Digo, apenas derrubar o cliente sabendo o mac dele?


    Talvez algo assim:

    /interface wireless registration-table remove ___________

    Agora o que iria após esse REMOVE..
    Prevendo-se a versão 2.9.xxx

    Atualmente fizemos manualmente copiando o cliente para o AccessList, e editando ele (Desmarcando e marcando) o Autentication em 2 processos manuais.

    é a unica maneira encontrada.



  3. #45

    Padrão

    primeiramente gostaria de agradecer a colaboração dos amigos..
    o script ficou realmente muito bom!

    eu utilizo a versão 2.9.27 aqui, e pelo que vi a função de DROPAR, nao funciona nela, estou correto?

    se é isso mesmo, qual alteração no script poderia fazer pra ele 'liberar' os macs 'bloqueados' quando rodou o script?!


    novamente vcs estao de parabens...otimo script que ajudará muitos aqui!

    abraços!

  4. #46

    Padrão

    bom, respondendo a minha propria pergunta...eu fiz e funcionou aqui!!

    ele da um 'disable' no cliente e logo ja da um 'enable' em seguida...
    suficiente pra pessoa reconectar e abaixar o ack!

    novamente, agradeço o desenvolvimento desse script e eta ai a minha pequena mudança:

    Código :
    # Defina abaixo o valor mínimo de ACK
    :global ack 39;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 1;
    # Defina abaixo 1 para reiniciar a Interface quando um cliente estiver acima do valor mínimo e 0 para não fazer nada
    # Obs.: Ative apenas no último dos casos, pois derruba todos clientes enlaçados na Interface
    :global intdis 0;
    # Defina abaixo a Interface
    :global interf "wlan1";
     
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info ("Listando Clientes com ACK acima de " . $ack . " ms:");
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
      :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
        :set mac [/interface wireless registration-table get $i mac-address];
        :set cliente [/interface wireless access-list find mac-address=$mac];
        :log info ("COMENTARIO: " . [/interface wireless access-list get $cliente comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
        :if ($block = 1) do={
          /interface wireless access-list disable $cliente;
      /interface wireless access-list enable $cliente;
        };
        :set total total+1;
      };
    };
    :if ($total = 0) do={
      :log info ("Nenhum Cliente com ACK acima de " . $ack . " ms encontrado.");
    } else {
      :if ($intdis = 1) do={
        /interface wireless disable $interf;
        /interface wireless enable $interf;
      };
    };



  5. #47

    Padrão

    Como ficaria um script para desconectar um cliente com ip "0.0.0.0"

    Estou com este problema aqui, o cliente conecta mas nao fica com o ip (nao uso dhcp), quando desconecto o cliente, ele volta com ip correto.

  6. #48

    Padrão

    Citação Postado originalmente por netosdr Ver Post
    Como ficaria um script para desconectar um cliente com ip "0.0.0.0"

    Estou com este problema aqui, o cliente conecta mas nao fica com o ip (nao uso dhcp), quando desconecto o cliente, ele volta com ip correto.

    essa pergunta ja eh pros grandes...mas nao foge dessa regra ai nao...

    tem que ver como que captura o LAST IP do Registration e se for igual a 0.0.0.0 ele faz os comandos que precisa.