Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    VAMOS LA, DEVE SER O PROBLEMA DE TODOS:

    entrar no mikrotik...
    criar, editar, localizar e desativar um cliente

    ppp/secrect, apenas ae que eu preciso utilizar...

    sabe pq usar o delphi, primeiro meu sistema e totalmente custumizavel, e vou interagir com os meus outros servidores, se der certo, em cada torre vou gerar o pppoe diretamente para o cartao de onde o clientes se encontra...

  2. #22

    Padrão

    Citação Postado originalmente por harrypotheard Ver Post
    VAMOS LA, DEVE SER O PROBLEMA DE TODOS:

    entrar no mikrotik...
    criar, editar, localizar e desativar um cliente

    ppp/secrect, apenas ae que eu preciso utilizar...

    sabe pq usar o delphi, primeiro meu sistema e totalmente custumizavel, e vou interagir com os meus outros servidores, se der certo, em cada torre vou gerar o pppoe diretamente para o cartao de onde o clientes se encontra...
    kra seguinte, hoje estou sem tempo, mas depois de amanha 31/01 eu monto essa parte do sistema que vc quer e anexo o codigo fonte para ficar mais facil o compreendimento!

    abraços!



  3. #23

    Padrão Delphi

    harrypotheard,

    Não sei se é o que vc está querendo, mas fiz um pequeno exemplo de como conectar no mikrotik, e cadastrar um cliente no PPPoE Secret o codigo fonte para vc entender melhor segue em anexo!


    obs.: cadastre o cliente por completo pois não tive tempo de criar rotinas para validação dos dados, e nem para a confirmação da gravação dos dados.

    mas com esse exemplo vc já conseguirá da um passo nesse sistema!


    Abraços!
    Arquivos Anexos Arquivos Anexos

  4. #24

    Padrão

    so mais uma observação!

    testado apenas na versão 2.9.27



  5. #25

    Padrão

    blz se realmente funcionar.. vai me ajudar mt no sistema.

  6. #26

    Padrão

    Citação Postado originalmente por daniloacr Ver Post
    harrypotheard,

    Não sei se é o que vc está querendo, mas fiz um pequeno exemplo de como conectar no mikrotik, e cadastrar um cliente no PPPoE Secret o codigo fonte para vc entender melhor segue em anexo!


    obs.: cadastre o cliente por completo pois não tive tempo de criar rotinas para validação dos dados, e nem para a confirmação da gravação dos dados.

    mas com esse exemplo vc já conseguirá da um passo nesse sistema!


    Abraços!
    Parabéns daniloacr, parece ser este o caminho.



  7. #27

    Padrão meu problema esta sendo o dump

    fiz uma funcao para ve quais os meus clientes estao ativos
    /ip arp print
    mas a lista eh meia grandinha
    dai ele mostra alguns clientes e fica esperando dar um dump ou page down e tal
    tem como gerar uma lista completa???
    ou pegar esses valores de outra forma???

  8. #28

    Padrão

    Citação Postado originalmente por gzanatta00 Ver Post
    fiz uma funcao para ve quais os meus clientes estao ativos
    /ip arp print
    mas a lista eh meia grandinha
    dai ele mostra alguns clientes e fica esperando dar um dump ou page down e tal
    tem como gerar uma lista completa???
    ou pegar esses valores de outra forma???
    Ao inves de usar /ip arp print use /ip arp print without-paging

    qualquer coisa estamos ai!



  9. #29

    Padrão

    Citação Postado originalmente por daniloacr Ver Post
    Ao inves de usar /ip arp print use /ip arp print without-paging

    qualquer coisa estamos ai!



    iiuuppiiiiiiiii

    valew amigo
    tava correndo atras dessa a meses


    mas uma coisinha
    pq o meu idtelnet cada vez q disconnecta da uma mensagem de erro
    dai to fazendo uma sincronizacao com dois sevidores, da quando vai desconectar pra ir para o outro da essa merda de erro e para tudo

    alguem passou por isso q conseguiu resolver???

  10. #30

    Padrão

    eu ainda nao consegui fazer a m* do delphi conectar no mk... to ficando frustrado...



  11. #31

    Padrão

    Citação Postado originalmente por harrypotheard Ver Post
    eu ainda nao consegui fazer a m* do delphi conectar no mk... to ficando frustrado...


    bem facil , volte alguma paginas atraz e tem um exemplo
    nao se esqueca de liberar a porta do telnet , a padrao eh a 23
    va em /ip services e ative
    nao tem erro

  12. #32

    Padrão

    Citação Postado originalmente por gzanatta00 Ver Post
    bem facil , volte alguma paginas atraz e tem um exemplo
    nao se esqueca de liberar a porta do telnet , a padrao eh a 23
    va em /ip services e ative
    nao tem erro
    vc só precisa liberar a porta 23 do mikrotik, fazer com que o delphi antes de cada comando faça o log-on no MK, ou fazer com que na hora de abrir o soft administrativo ele já faça o log-on no mikrotik, o restante é só estudar os comandos do MK e ir criando as regras... como por exemplo..


    depois do delphi conectado ao MK via telnet, os comandos são os seguintes...
    para adicionar um ip...

    /ip address
    add address=192.168.0.1 interface=ether1 comment="comentario do ip adicionado"

    para adicionar um MAC

    /ip arp
    add address=192.168.0.1 mac-address=00:00:00:00:00:00 interface=ether2 comment="comentario do mac cadastrado" disabled=no

    para fazer ele conectar sozinho vc pode fazer o delphi chamar um script em .vbs ou .bat ok...
    para todos com esta dúvida, espero ter ajudado.
    vou preparar um vbs para abrir a telnet já autenticada e posto aki depois.



  13. #33

    Padrão

    Citação Postado originalmente por harrypotheard Ver Post
    eu ainda nao consegui fazer a m* do delphi conectar no mk... to ficando frustrado...
    amigo olhe o exemplo que postei que funcionará sem duvidas,

    abraços!

  14. #34

    Padrão

    bagunça
    vamos fazer uma coisa certa, cadastrar procurar apagar, poxa...



  15. #35

    Padrão

    https://under-linux.org/forums/mikro...phi-7-0-a.html

    Veja amigo, que tal agora, acho que vai conseguir continuar seu projeto em breve.

  16. #36

    Padrão

    Citação Postado originalmente por harrypotheard Ver Post
    Amigos, tem alguma maneira do meu software financeiro feito em delphi alterar / cadastrar banda e mac dos clientes no mikrotik?

    Agora tem, você pode pegar o exemplo do Mikrontrol - Gerenciador para Servidores Mikrotik, aproveito pra sugerir, já pensou em compartilhar o seu trabalho com a comunidade ?

    Grato

    M4D3



  17. #37

  18. #38

    Padrão

    Bem pessoal, comecei com o delphi ontém, fiz a interface gráfica e tals, só que estou com uma dúvida de iniciante,
    Quero pegar os clientes bloqueados e desbloqueados em locais diferentes, tipo queria pegar o print do /ip arp print without-paging e debugar no delphi. Gostaria de saber, no delphi, como devo fazer isto, qual componente usar para mostrar a lista..

    Deêm uma olhada na imagem para um melhor entendimento.

    Agradeço.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         tela.JPG
Visualizações:	304
Tamanho: 	50,5 KB
ID:      	2140