Página 7 de 8 PrimeiroPrimeiro ... 2345678 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por harrypotheard Ver Post
    eu ainda nao consegui fazer a m* do delphi conectar no mk... to ficando frustrado...


    bem facil , volte alguma paginas atraz e tem um exemplo
    nao se esqueca de liberar a porta do telnet , a padrao eh a 23
    va em /ip services e ative
    nao tem erro

  2. Citação Postado originalmente por gzanatta00 Ver Post
    bem facil , volte alguma paginas atraz e tem um exemplo
    nao se esqueca de liberar a porta do telnet , a padrao eh a 23
    va em /ip services e ative
    nao tem erro
    vc só precisa liberar a porta 23 do mikrotik, fazer com que o delphi antes de cada comando faça o log-on no MK, ou fazer com que na hora de abrir o soft administrativo ele já faça o log-on no mikrotik, o restante é só estudar os comandos do MK e ir criando as regras... como por exemplo..


    depois do delphi conectado ao MK via telnet, os comandos são os seguintes...
    para adicionar um ip...

    /ip address
    add address=192.168.0.1 interface=ether1 comment="comentario do ip adicionado"

    para adicionar um MAC

    /ip arp
    add address=192.168.0.1 mac-address=00:00:00:00:00:00 interface=ether2 comment="comentario do mac cadastrado" disabled=no

    para fazer ele conectar sozinho vc pode fazer o delphi chamar um script em .vbs ou .bat ok...
    para todos com esta dúvida, espero ter ajudado.
    vou preparar um vbs para abrir a telnet já autenticada e posto aki depois.



  3. Citação Postado originalmente por harrypotheard Ver Post
    eu ainda nao consegui fazer a m* do delphi conectar no mk... to ficando frustrado...
    amigo olhe o exemplo que postei que funcionará sem duvidas,

    abraços!

  4. bagunça
    vamos fazer uma coisa certa, cadastrar procurar apagar, poxa...



  5. https://under-linux.org/forums/mikro...phi-7-0-a.html

    Veja amigo, que tal agora, acho que vai conseguir continuar seu projeto em breve.






Tópicos Similares

  1. como usar api do mikrotik no delphi
    Por notgle no fórum Redes
    Respostas: 1
    Último Post: 12-11-2009, 23:31
  2. Respostas: 102
    Último Post: 14-02-2009, 09:25
  3. Mikrotik e Delphi 2007
    Por Rhadsclei no fórum Redes
    Respostas: 10
    Último Post: 05-04-2008, 18:12
  4. Mikrotik + Radius + Delphi 7
    Por netxtreme no fórum Redes
    Respostas: 7
    Último Post: 27-02-2008, 13:04
  5. Sistema Administrativo para Mikrotik ( mysql/delphi/ssh )
    Por AndersonMachado no fórum Redes
    Respostas: 22
    Último Post: 26-10-2007, 18:09

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L