+ Responder ao Tópico



  1. #1

    Padrão deixar o cliente super feliz!!! heheh

    pessoal
    tava pensando aqui com meus pauzinhos...
    a cache funciona da seguinte forma
    a porta http eh a 80 e a da cache 3128, os clientes possuem comtrole de banda no meu caso de 256k,


    a ideia qme surguiu eh a seguinte, os arquivos da cache estao dentro do meu server(nao ira utilizar o link), e o que nao estiver ira buscar fora ou seja passa pelo link, sera q teria como deixar estes arquivos da cache sem o controle de banda , fazendo com q quando o cliente abrir uma pagina ele pegasse os arquivos rapidamente, e q controlasse somente a velocidade dos arquivos q iria pegar fora, pense o cliente pouco feliz abrindo uma pagina , dar um clique e mais da metade da pagina jah ficaria aberto no momento do Enter...
    teria a possibilidade de fazer este tipo de controle?


    sao ideias sou meio leigo nesta area de proxy, vai saber se isso jah nao acontece, mas estou satisfeito com minha cache, mas se puder melhor
    hehehe
    melhor ainda
    obrigado

  2. #2

    Padrão

    claro que tem como fazer isso
    sabe como isso se chama?
    cache full
    uahuahuahauhau
    legal né agora teu cliente vai fica felizao



  3. #3

    Padrão

    Citação Postado originalmente por gzanatta00 Ver Post
    pessoal
    tava pensando aqui com meus pauzinhos...
    a cache funciona da seguinte forma
    a porta http eh a 80 e a da cache 3128, os clientes possuem comtrole de banda no meu caso de 256k,


    a ideia qme surguiu eh a seguinte, os arquivos da cache estao dentro do meu server(nao ira utilizar o link), e o que nao estiver ira buscar fora ou seja passa pelo link, sera q teria como deixar estes arquivos da cache sem o controle de banda , fazendo com q quando o cliente abrir uma pagina ele pegasse os arquivos rapidamente, e q controlasse somente a velocidade dos arquivos q iria pegar fora, pense o cliente pouco feliz abrindo uma pagina , dar um clique e mais da metade da pagina jah ficaria aberto no momento do Enter...
    teria a possibilidade de fazer este tipo de controle?


    sao ideias sou meio leigo nesta area de proxy, vai saber se isso jah nao acontece, mas estou satisfeito com minha cache, mas se puder melhor
    hehehe
    melhor ainda
    obrigado
    Boa noite;
    Caro amigo se link do proprio forum ensinando a fazer oque vc quer!
    https://under-linux.org/forums/mikro...-exemplos.html caso não consiga procure na busca por "cache full"
    tem bastante artigo....

    Qualquer coisa me add no msn.... [email protected]

  4. #4

    Padrão fis a cache full

    fiz a cache full ,mas encontrei um problema
    o cliente fica fugindo do meu controle na simple queue
    se fizer um download ele fica marcado a potencia q falta no link


    eh melhor colocar no queue tree ou no simple



  5. #5

    Padrão

    Citação Postado originalmente por gzanatta00 Ver Post
    fiz a cache full ,mas encontrei um problema
    o cliente fica fugindo do meu controle na simple queue
    se fizer um download ele fica marcado a potencia q falta no link


    eh melhor colocar no queue tree ou no simple
    Num era justamente oque vc queria... o que ta no cache ele faz o down liberado..

  6. #6

    Padrão

    Num era justamente oque vc queria... o que ta no cache ele faz o down liberado..



    nao os arquivos q estao no cache tem q fica liberado e o os arquivos q ele pega fora do servidor tem q controlar a banda

    por exemplo
    entro no baixaki , pesso pra fazer um down do linux kurumin 7, eh obvio q ele nao esta na minha cache, e inves de controlar no 256k ta dando 800-1000k, quero somente liberado os arquivos q estao na cache

    veja o q eu tenho aqui
    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 action=mark-connection \
    new-connection-mark=PROXY passthrough=yes comment="Cache - Full" \
    disabled=no
    add chain=output connection-mark=PROXY action=mark-packet \
    new-packet-mark=Cache passthrough=yes comment="" disabled=no


    / ip firewall nat
    add chain=dstnat in-interface=Clientes src-address=10.2.2.0/24 protocol=tcp \
    dst-port=80 action=redirect to-ports=3128 comment="" disabled=no

    / ip firewall filter
    add chain=input in-interface=Link1 protocol=tcp dst-port=3128 action=drop \
    comment="Bloqueando Cache Vinda do Link" disabled=no


    / queue tree
    add name="Cache" parent=global-out packet-mark=Cache limit-at=0 queue=default \
    priority=7 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s \
    disabled=no



  7. #7

    Padrão

    Citação Postado originalmente por gzanatta00 Ver Post
    Num era justamente oque vc queria... o que ta no cache ele faz o down liberado..



    nao os arquivos q estao no cache tem q fica liberado e o os arquivos q ele pega fora do servidor tem q controlar a banda

    por exemplo
    entro no baixaki , pesso pra fazer um down do linux kurumin 7, eh obvio q ele nao esta na minha cache, e inves de controlar no 256k ta dando 800-1000k, quero somente liberado os arquivos q estao na cache

    veja o q eu tenho aqui
    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 action=mark-connection \
    new-connection-mark=PROXY passthrough=yes comment="Cache - Full" \
    disabled=no
    add chain=output connection-mark=PROXY action=mark-packet \
    new-packet-mark=Cache passthrough=yes comment="" disabled=no


    / ip firewall nat
    add chain=dstnat in-interface=Clientes src-address=10.2.2.0/24 protocol=tcp \
    dst-port=80 action=redirect to-ports=3128 comment="" disabled=no

    / ip firewall filter
    add chain=input in-interface=Link1 protocol=tcp dst-port=3128 action=drop \
    comment="Bloqueando Cache Vinda do Link" disabled=no


    / queue tree
    add name="Cache" parent=global-out packet-mark=Cache limit-at=0 queue=default \
    priority=7 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s \
    disabled=no
    Sim eu entedi.. mais o cache era pra fazer down livre apenas do cache... suas regras ainda estão inacabadas.... procure direito no forum...

  8. #8

    Padrão

    faltou eu colocar a regra do return
    chain: output
    Conetion-mark: !Proxy
    action: return

    mas nao funcionou



  9. #9

    Padrão cache full

    Aeee cumpadi, vou te dar uma dicona... Acho q vc tá fazendo o cache errado, encotre aeee o vídeo do Alexandre Correa que funciona blz.
    Esse aí eu nunca fiz, mas deu muito pano pra manga...

    [ ]´s,

  10. #10

    Padrão

    Citação Postado originalmente por gzanatta00 Ver Post
    faltou eu colocar a regra do return
    chain: output
    Conetion-mark: !Proxy
    action: return

    mas nao funcionou

    O CATV publicou a dica completa sobre o CACHE FULL e funciona perfeito, tá faltando é pesquisar um pouco sobre o assunto, não tem nada mais fácil que copiar e colar então eu não vou postar o link porque isso seria palhaçada. Se fez errado apague tudo e faça conforme publicado no artigo citado, vai funcionar com toda certeza.

    Sucesso nas próximas tentativas amigo.

    M4D3

    Aproveita pra conhecer o Mikrontrol - Gerenciador para Servidor Mikrotik, incluindo o código fonte em Delphi 7.



  11. #11

    Padrão

    Esqueci de dizer e não tenho certeza que fosse ler todo o artigo, mas então vou dizer agora, LEIA TODO O ARTIGO se não quer que seu CACHE FULL se transforme num tiro no pé.

    Sucesso..

    M4D3

  12. #12

    Padrão

    Ola gzanatta00....





    referente as suas regras... analisemos para sua compreensao e de todos que aqui lêem:


    • 1) /ip firewall nat:
    o que a regra faz é redirecionar todo trafego com tcp_dst_port:80 para tcp_dst_port:3128 (e demais criterios inclusos)

    nesse caso alguem deverá responder na porta tcp:3128... e coincidentemente e desejavel... voce configurou web_proxy para trabalhar nessa porta tcp (3128).... **LEGAL!!!!***
    • 2) /ip firewall mangle:
    Para capturar todas as **respostas** do web_proxy... o filtro deverá ser... chain=output, tcp_src_port=3128... essa é a dica maior. E até ai tudo bem...
    Voce marca marca conexao e pacotes originadas do web_proxy como sendo "PROXY" e "Cache" respectivamente... e vai usar mais tarde na **QUEUE**.
    • 3) /queue tree:
    Todos os pacotes chamados **Cache** voce faz permissão total... independente se teve HIT ou MISS na web_proxy.

    -----------------------------

    Pergunta: Voce entendeu **ONDE** está o seu erro?


    Solução:

    Voce deve marcar com algum nome tipo "tanacache" aos pacotes originados do web_proxy (tcp_src_port:3128) somente aqueles pacotes cujo conteudo for igual a ****X-Cache:HIT**** e... somente a esses pacotes com marcacao "tanacache" aplicar a liberacao total de vazao. E... para marcar os pacotes com tarja "tanacache".... voce deverá **AINDA** analisar o conteudo como sendo igual a ***X-Cache:HIT***

    • VOLTE... e refaça a regra /ip firewall mangle...





    Abraços a TODOS que estão lendo essa mensagem!!!