+ Responder ao Tópico



  1. #1

    Padrão PPPOE no MK

    Bom dia galera,
    Estou com uma duvida sobre o PPPOE....

    Criei o server PPPOE - OK
    Me conectei no Server - OK

    So que ao me conectar eu não recebo o gateway que deveria, fica assim:

    IP. 192.168.0.30 (Esse eu setei em remote address)
    Mascara 255.255.255.255 (foi automatico)
    Gateway 192.168.0.30 (foi automatico)
    DNS - (O que eu setei no profile)
    DNS2 - (O que eu setei no profile)


    Agora pergunto:
    Existe algum lugar para setar a mascara?
    Existe algum lugar para setar o gateway?

    obrigado galera.

  2. #2

    Padrão

    Você disse eu não recebo o gateway.
    Você ta usando dhcp ?
    Senão tiver isso ae é manual, vc que tem que colocar no PC.



  3. #3

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    Você disse eu não recebo o gateway.
    Você ta usando dhcp ?
    Senão tiver isso ae é manual, vc que tem que colocar no PC.
    Não estou usando dhcp, mas achei estranha a sua afirmação.

    Case:
    Configuro pppoe-client em um pc, ao me conectar no server eu tenho que receber todos os endereços certo?

    Tenho que receber IP, Mascara, Gateway e DNS.

    A grande questão é essa, onde eu configuro no MK para ele enviar o meu gateway?

  4. #4

    Padrão

    Citação Postado originalmente por iceblue Ver Post
    Bom dia galera,
    Estou com uma duvida sobre o PPPOE....

    Criei o server PPPOE - OK
    Me conectei no Server - OK

    So que ao me conectar eu não recebo o gateway que deveria, fica assim:

    IP. 192.168.0.30 (Esse eu setei em remote address)
    Mascara 255.255.255.255 (foi automatico)
    Gateway 192.168.0.30 (foi automatico)
    DNS - (O que eu setei no profile)
    DNS2 - (O que eu setei no profile)


    Agora pergunto:
    Existe algum lugar para setar a mascara?
    Existe algum lugar para setar o gateway?

    obrigado galera.
    PPPoE é um protocolo desenvolvido para permitir acesso autenticado e transmissão de pacotes de diversos protocolos, originalmente em conexões de ponto a ponto, é como se so existisse a sua maquina na rede, por isso a mascara 255.255.255.255.

    No Windows XP realmente o gateway que ele mostra é o mesmo que o IP, assim como as velhas conexões discadas, já no Windows Vista eu percebi que ele mostra o gateway certinho, agora isso eu não sei porque.

    Agora mudar o gateway e a mascará creio que não tem como não. pois se trata de uma conexão ponto-a-ponto.



  5. #5

    Padrão

    Citação Postado originalmente por iceblue Ver Post
    Bom dia galera,
    Estou com uma duvida sobre o PPPOE....

    Criei o server PPPOE - OK
    Me conectei no Server - OK

    So que ao me conectar eu não recebo o gateway que deveria, fica assim:

    IP. 192.168.0.30 (Esse eu setei em remote address)
    Mascara 255.255.255.255 (foi automatico)
    Gateway 192.168.0.30 (foi automatico)
    DNS - (O que eu setei no profile)
    DNS2 - (O que eu setei no profile)


    Agora pergunto:
    Existe algum lugar para setar a mascara?
    Existe algum lugar para setar o gateway?

    obrigado galera.
    Brow é o seguinte;
    Vc tem que cadastraseu gatway em local adress em cima de remote adress ou vc pode criar um dhcp so para as conexão pppoe ai vc cria um profile com as velocidade e ja ibutindo o dhcp ai vc não precisa fica setando ip em cada client que vc cadastra.. não esqueça que para navega vc deve cria uma rega nat no fire...
    Abraços

  6. #6

    Padrão

    vc pode monta um pool, com duas faixas de ips, uma interna outra para cliente, a do cliente tem que estar fazendo nat tb, dae o pppoe vai conecta autenticar pegar um ip no servidor e outro para o cliente, nao sera fixo nem valido, vc pode tb optar por fixo e ou valido.

    posta ae sua real necessidade



  7. #7

    Padrão

    Citação Postado originalmente por harrypotheard Ver Post
    vc pode monta um pool, com duas faixas de ips, uma interna outra para cliente, a do cliente tem que estar fazendo nat tb, dae o pppoe vai conecta autenticar pegar um ip no servidor e outro para o cliente, nao sera fixo nem valido, vc pode tb optar por fixo e ou valido.

    posta ae sua real necessidade

    Minha estrutura é a seguinte:

    Servidor Linux ( Squid para proxy, Sarg para relatorio, iptables, iproute para loadbalance e compartilhamento e apache para publicação do relatorio)

    Servidor MK (Bridge com o Linux para QoS e PPPoE Server)

    Então a sacada é essa, o cliente que se conecta no PPPoE teria que receber um Gateway especifico para navegação pois o MK não tem acesso a Net.

    Quando eu coloco o IP do server em Local Addres ele envia para o cliente como servidor PPPoE + o gateway continua sendo o IP do kra...


    Alguem tem alguma dica?

    estou lendo manuais do rp-pppoe que é um server pppoe para linux, se eu encontrar a solução posto aqui para voces, obrigado.

  8. #8

    Padrão

    Citação Postado originalmente por iceblue Ver Post
    Minha estrutura é a seguinte:

    Servidor Linux ( Squid para proxy, Sarg para relatorio, iptables, iproute para loadbalance e compartilhamento e apache para publicação do relatorio)

    Servidor MK (Bridge com o Linux para QoS e PPPoE Server)

    Então a sacada é essa, o cliente que se conecta no PPPoE teria que receber um Gateway especifico para navegação pois o MK não tem acesso a Net.

    Quando eu coloco o IP do server em Local Addres ele envia para o cliente como servidor PPPoE + o gateway continua sendo o IP do kra...


    Alguem tem alguma dica?

    estou lendo manuais do rp-pppoe que é um server pppoe para linux, se eu encontrar a solução posto aqui para voces, obrigado.
    poque vc não instala entao o PPPoE server no seu servidor linux?

    segue esse tutorial ai que não tem erro!

    Tutoriais/Pppoe - UnderLinux Wiki
    Última edição por daniloacr; 05-02-2008 às 17:31. Razão: erro de ortogafria



  9. #9

    Padrão

    Citação Postado originalmente por daniloacr Ver Post
    poque vc não instala entao o PPPoE server no seu servidor linux?

    segue esse tutorial ai que não tem erro!

    Tutoriais/Pppoe - UnderLinux Wiki

    Nunca trabalhei com pppoe-server tanto é que não conheço seu funcionamento. Estou lendo algumas materias sobre o pppoe e em seguida vou testar o link que voce me passou, obrigado.

  10. #10

    Padrão

    Citação Postado originalmente por iceblue Ver Post
    Bom dia galera,
    Estou com uma duvida sobre o PPPOE....

    Criei o server PPPOE - OK
    Me conectei no Server - OK

    So que ao me conectar eu não recebo o gateway que deveria, fica assim:

    IP. 192.168.0.30 (Esse eu setei em remote address)
    Mascara 255.255.255.255 (foi automatico)
    Gateway 192.168.0.30 (foi automatico)
    DNS - (O que eu setei no profile)
    DNS2 - (O que eu setei no profile)


    Agora pergunto:
    Existe algum lugar para setar a mascara?
    Existe algum lugar para setar o gateway?

    obrigado galera.

    Seu problema é simples de resolver, no secret do seu cliente PPPOE você deve setar o LOCAL address com o IP do gateway, em alguns sistemas MK percebi que ao conectar via PPPOE mesmo com todas as informações necessárias o gateway não é detectado automáticamente, provavelmente o seu caso é um desses.
    No profile do cliente você colocar também o gateway no Local Address e em Remote Address você deve selecionar uma POOL previamente criada que será de onde o seu cliente recebera o IP, também não esqueça de ainda na profile digitar no mínimo 2 servidores DNS.

    Espero que resolva o seu problema dessa forma. Qualquer coisa estamos ae pra ajudar.

    Grato
    M4D3

    Aproveita pra conhecer o Mikrontrol - Gerenciador para Servidor Mikrotik, incluindo o código fonte em Delphi 7.
    Última edição por m4d3; 10-02-2008 às 03:12.



  11. #11

    Padrão

    Não sei se entendi correto, mas se voce quer determinar um Gatway, voce pode fazer de 2 formas: 1 no pront de comando voce digita setup e segue o assistente(pode tambem ser pelo new terminal); 2 - Voce pode determinar uma gatway em: IP>>>Router, clica no + e determina o Gatway.