Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão

    Citação Postado originalmente por Shturbo Internet Ver Post
    Brow.. essa é a ideia.. so vai para a tela de login quem não conseguir discar, seja por estar bloqueado ou não cadastrador.. entendeu.. quem estiver discando normalmente acessar a internet normal...
    A vantegem de se usar dessa for e o bloq simples e rapido.. apenas desmarcando o login do inadiplemente ele não efetua a discagem com isso ele so consegue abrir a tela de bloq.... nem msn, nem http, nem nada...
    deixa ver se eu entendi, pelo o que vc fala aqui o cliente nao conseguira discar pelo ppoe? ele vai ter que abrir o browser para ler a msg, sem discar?

    irei testar hoje a noite, mais se funionar desta forma nao tem serventia, pq um cliente abriria o browser se nao conseguiu conectar?
    valeu amanah posto resultados

  2. #22

    Smile

    Citação Postado originalmente por zipfile Ver Post
    deixa ver se eu entendi, pelo o que vc fala aqui o cliente nao conseguira discar pelo ppoe? ele vai ter que abrir o browser para ler a msg, sem discar?

    irei testar hoje a noite, mais se funionar desta forma nao tem serventia, pq um cliente abriria o browser se nao conseguiu conectar?
    valeu amanah posto resultados

    cara o que ele falou é o seguinte: todos os clientes que nao autenticarem a conexão primeiro, vão digitar qualquer site ex: Google e vai parar na sua pagina de bloqueio... só acessa a internet normalmente depois que autenticar com o ppoe e re-abrir o browser.

    e se voce quiser bloquear o cliente para ele nao navegar é so desabilitar o PPoE do cliente! sendo assim ele nao autenticará conexão e nao terá acesso!

    melhor que isso impossivel!



  3. #23

    Padrão

    Citação Postado originalmente por Tyallysson Ver Post
    cara o que ele falou é o seguinte: todos os clientes que nao autenticarem a conexão primeiro, vão digitar qualquer site ex: Google e vai parar na sua pagina de bloqueio... só acessa a internet normalmente depois que autenticar com o ppoe e re-abrir o browser.

    e se voce quiser bloquear o cliente para ele nao navegar é so desabilitar o PPoE do cliente! sendo assim ele nao autenticará conexão e nao terá acesso!

    melhor que isso impossivel!
    Bom... obrigado pela ajuda.. é isso mesmo...

  4. #24

    Padrão

    Quando selecionar no campo type a opção: blocked. O cliente será direcionado para qual das paginas do hotspot?



  5. #25

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Bom vamos lá...

    Esta regra é para quem usa autenticação por PPPOE, DHCP ou mesmo IP Fixo.

    Mãos a obra:

    IP > HOTSPOT

    Com seu Mikrotik configurado, vá em HOTSPOT e ative-o através do SETUP dele (siga os passos até o final)... Será criado um servidor HOTSPOT.

    Vá na aba IP BINDIND e adicione as regras, conforme abaixo:



    / ip hotspot ip-binding
    add address=192.168.100.28 type=bypassed comment="" disabled=no
    add address=100.0.0.0/24 type=bypassed comment="" disabled=no
    add address=192.168.100.32 type=bypassed comment="" disabled=yes
    add address=0.0.0.0/0 type=regular comment="" disabled=no


    O que isso significa... Você irá criar uma regra para cada ip (address) com o tipo em "BYPASSED"... E no final, uma regra para o 0.0.0.0/0 (todos os ips), com o tipo em "REGULAR".

    Bom, o que isso irá fazer?

    A princípio, todos os ips que estiverem cadastrado com o BY-PASSED, irão navegar normalmente... Todos os ips que NÃO estiverem cadastrados no BYPASSED, irão cair na tela de login do HOTSPOT.

    Mas para que vou querer meus clientes caindo na tela de HOTSPOT??

    Oras, é só editar o arquivo LOGIN.HTM com uma mensagem de débito, que toda a vez que seu cliente entrar, será direcionado a tela inicial do HOTSPOT, que na verdade será a tela de mensagem...

    Para bloquear um cliente, desabilite o ip dele ou pegue o ip dele (no ip binding) e mude de "by-passed" para "regular"... Para desbloquear, faça o reverso (mude de "regular" para "by-passed").


    TÁ RESOLVIDO O PROBLEMA DA PÁGINA DE AVISO NO MESMO SERVIDOR... SIMPLES E FUNCIONAL!!!

    Bom, antes de mais nada... Esta solução, desenvolvi a meses ESTUDANDO... e está implantado em vários clientes....
    Grande CA, realmente a lógica da coisa parece funcionar perfeitamente, me tira uma dúvida, o cliente vê a página mesmo depois de conectado via PPPOE caso seu ip esteja na lista do BINDINGS como regular ou apenas antes de se conectar pelo PPPOE?

    Porque para mim isso é o que faria mais sentido e nos testes que fiz apenas a pagina é exibida antes da discagem, suspeita de onde posso estar errando caso a pagina seja exibida após a autenticação pppoe e não antes.
    Respondido em off:
    Então, a pagina de aviso é mesmo antes de conectar ao pppoe, o bloqueio é desativando a secret do cliente pppoe e adicionando seu ip na lista acima mencionada.

    Grato

    M4D3
    Última edição por m4d3; 12-02-2008 às 00:21.

  6. #26

    Padrão

    Citação Postado originalmente por m4d3 Ver Post
    Grande CA, realmente a lógica da coisa parece funcionar perfeitamente, me tira uma dúvida, o cliente vê a página mesmo depois de conectado via PPPOE caso seu ip esteja na lista do BINDINGS como regular ou apenas antes de se conectar pelo PPPOE?

    Porque para mim isso é o que faria mais sentido e nos testes que fiz apenas a pagina é exibida antes da discagem, suspeita de onde posso estar errando caso a pagina seja exibida após a autenticação pppoe e não antes.

    Grato

    M4D3
    faço das suas minhas palavras, fui exatamente isto que perguntei acima, mais nao obtive resposta.



  7. #27

    Padrão

    Todos estao supondo que os clientes estao conectados ha um pppoe que esteja rodando DHCP server ou que na casa dos clientes estejam marcado um ip fixo, e para o caso de quem deixa o Protocolo TCP/IP dos clientes desmarcado?

    Quem pensou nessa hipotese? pois testei aqui e sem protocolo tcp/ip marcado nao cai na tela de login do hotspot

  8. #28

    Padrão

    alguem pode esclarecer ai melhor sobre o lance do ppoe? se tem que autenticar ou nao? como funciona?



  9. #29

    Padrão redirecionamento

    bom como faria essa regra pra rodar o adversite pois nao posso perder a segurança do ip arp, meu interesse e apenas rodar uma propaganda quando o cleinrte abrir um navegador seja s=direcionado pra um site de propaganda pelo menos uma vez, se possivel queria tada vez que eel abrisse um novo navegador...

  10. #30

    Padrão

    Segundo testes que fiz aqui depois de discar o cliente não cai na pagina de login isto porque o pppoe faz nat na interface que ele cria quando o cliente se conecta ignorando as regras de redirecionamento do hotspot, acho que unica maneira de fazer isto´é usando a pagina de login do webbox mas ainda não tive oportunidade de fazer teste na edição da pagina do webbox, mas nofirewall tem como redirecionar cliente diretamente pra la, mesmo depois de conectado.



  11. #31

    Padrão REDIRECIONANDO CLIENTES PARA PÁGINA DE DÉBITO, SEM USAR SERVER EXT (para pppoe, dhcp

    Boa noite pessoal.

    Estou aki para agradecer o CATV pela iniciativa de ajudar os outros nao tem gesto melhor no mundo.
    Coloquei aki para rodar as regras funncionou perfeitamente sem comentarios, minha rede e DHCP funciona muito bem.
    Espero que os amigos do forum tenham conseguido fazer funcionar tb.

    Sou iniciante mas se alguem precisar de ajuda nesse assunto estou a disposicao.

    e-mail [email protected]

  12. #32

    Padrão

    Citação Postado originalmente por binhorp Ver Post
    Segundo testes que fiz aqui depois de discar o cliente não cai na pagina de login isto porque o pppoe faz nat na interface que ele cria quando o cliente se conecta ignorando as regras de redirecionamento do hotspot, acho que unica maneira de fazer isto´é usando a pagina de login do webbox mas ainda não tive oportunidade de fazer teste na edição da pagina do webbox, mas nofirewall tem como redirecionar cliente diretamente pra la, mesmo depois de conectado.
    mais como e que edita a pagina do webbox??
    alguem sabe o caminho?



  13. #33

    Padrão

    Hoje finalmente consegui resolver o problema do redirecionamento depois de autenticado no pppoe
    segue os passos.
    1-Altere a porta do webbox para uma diferente da porta 80 e do webproxy caso esteja ativo, no meu caso coloquei a 1881
    /ip service set www port=1881 address=0.0.0.0/0 disabled=no
    2-Dê o boot na maquina com um cd de alguma distribuição linux no meu caso usei cd do slackware monte a unidade onde encontram-se os arquivos no meu caso /dev/hda2
    3-Copie o arquivo index2.htm.orig para um dispositivo removivel para posterior edição no meu caso editei no word caminho /home/web
    4-Edite o arquivo conforme a sua nescessidade e depois copie de volta para o local de origem
    5-Coloque no firewall a regra que faz o redirecionamento
    add chain=dstnat src-address=10.0.3.0/24 dst-address=0.0.0.0/0 action=dst-nat to-addresses=200.xxx.xx.93 to-ports=1881 \
    comment="Bloqueio_de_Cliente" disabled=no
    Pronto basta fazer o teste
    Ps. Caso ainda deseje usar o webbox basta renomear o arquivo
    home/web/index2.html.orig
    para outro nome qunado for acessar faz assim htt://ip_webboxorta_usada/nome_do_arquivo

    Espero que isto ajude a quem tem esta nescedidade como eu!
    Última edição por binhorp; 13-02-2008 às 20:00.

  14. #34

    Padrão

    Citação Postado originalmente por binhorp Ver Post
    Hoje finalmente consegui resolver o problema do redirecionamento depois de autenticado no pppoe
    segue os passos.
    1-Altere a porta do webbox para uma diferente da porta 80 e do webproxy caso esteja ativo, no meu caso coloquei a 1881
    /ip service set www port=1881 address=0.0.0.0/0 disabled=no
    2-Dê o boot na maquina com um cd de alguma distribuição linux no meu caso usei cd do slackware monte a unidade onde encontram-se os arquivos no meu caso /dev/hda2
    3-Copie o arquivo index2.htm.orig para um dispositivo removivel para posterior edição no meu caso editei no word caminho /home/web
    4-Edite o arquivo conforme a sua nescessidade e depois copie de volta para o local de origem
    5-Coloque no firewall a regra que faz o redirecionamento
    add chain=dstnat src-address=10.0.3.0/24 dst-address=0.0.0.0/0 action=dst-nat to-addresses=200.xxx.xx.93 to-ports=1881 \
    comment="Bloqueio_de_Cliente" disabled=no
    Pronto basta fazer o teste
    Ps. Caso ainda deseje usar o webbox basta renomear o arquivo
    home/web/index2.html.orig
    para outro nome qunado for acessar faz assim htt://ip_webboxorta_usada/nome_do_arquivo

    Espero que isto ajude a quem tem esta nescedidade como eu!
    vc so alterou a index2.htm.orig , nao alterou a index2.htm???
    outra coisa tem como mandar a pagina editada ai?
    eu editei as duas aqui so que a pagina ficou muitoo louca espaços gigantes entre as linhas.



  15. #35

    Padrão

    Citação Postado originalmente por zipfile Ver Post
    vc so alterou a index2.htm.orig , nao alterou a index2.htm???
    outra coisa tem como mandar a pagina editada ai?
    eu editei as duas aqui so que a pagina ficou muitoo louca espaços gigantes entre as linhas.
    o arquivo index2.html e subistituido pelo index2.html.orig quando o mk inicia por isso tem que ser ele o arquivo que coloquei é um html normal conforme anexo!
    Arquivos Anexos Arquivos Anexos

  16. #36

    Padrão

    Citação Postado originalmente por binhorp Ver Post
    o arquivo index2.html e subistituido pelo index2.html.orig quando o mk inicia por isso tem que ser ele o arquivo que coloquei é um html normal conforme anexo!
    valeu chefe, obr pelos escrarecimentos, irei colocar sua pagina so de teste para ver se funcionara normal.
    aqui eu criei uma pagina no word e outra no frontpage, mais quando jogo ela para o Mk, e acesso de outro lugar ela fica louca.
    irei tentar mais uma vez, agora com a sua.
    valeu ai.



  17. #37

    Padrão

    Citação Postado originalmente por zipfile Ver Post
    valeu chefe, obr pelos escrarecimentos, irei colocar sua pagina so de teste para ver se funcionara normal.
    aqui eu criei uma pagina no word e outra no frontpage, mais quando jogo ela para o Mk, e acesso de outro lugar ela fica louca.
    irei tentar mais uma vez, agora com a sua.
    valeu ai.
    Provavelmente isto ta acontecendo pq quando vc cria as paginas e criado uma pasta com os arquivos de imagens efeitos etc... e vc ta copiando so a pagina html por isso ta acontecendo isto.

  18. #38

    Padrão

    Eu não estou conseguindo.
    Ja estou a 2 dias quebrando a cabeça e não roda, simplesmente não aparece tela de login.
    Uso ip fixo nos clientes, eu ja tentei colocar um ip de teste como bloqueado, regular, passed, mas nada roda.

    Essa dica funciona mesmo para ips fixos?
    Outra coisa, o hotpost cria uma queue, como eu controlo todos os clientes será que da merda?

    Abraços.



  19. #39

    Padrão

    Esse Redirecionamento de clintes e uma coisa muito boa, tentei varias vezes so que nao consegui acessar a net, quando abro o navegador vai para a pagina de login mas dali não passa. Editei a pagina como eu quero aparece normalmente como editei. Catvbrasil eu uso serviço de IP fixo com IP/Mac. Nesse casso a regra e a mesma? vc poderia descrever melhor a ativação do servidor hotspot?

  20. #40

    Padrão

    Citação Postado originalmente por Tyallysson Ver Post
    Como a vida é bela.

    Ja testei e funciona lindinho mesmo

    agora falta alguma alma caridosa aparecer com esse login.html editado ou eu vou ter que ler algumas apostilas de html pra desenvolver algo bizarro pra espantar meus clientes uAHuahuahUhauhuaHhaUH


    PARABÉNS CARA!!
    Ola amigo vc esta precisando de uma ajudinha para editar a sua pagina? entre encontato comigo via msn que eu te ajudo tenho o maior prazer em te ajudar e ate pois foi assim que eu aprendi e quero passar para os demais. [email protected]