+ Responder ao Tópico



  1. #1

    Padrão Roteamento sem fazer NAT, como ?

    Prezados colegas,

    preciso configurar um mk para fazer roteamento de duas interfaces ethernet para uma wireless.

    O fato é que eu necessito que sena feito sem NAT.

    nas ethernet tenho redes 20.101.0.0/16 e 20.102.0.0/16

    na wirelles tenho rede 20.0.0.0/8

    ou seja na wireless fica a rede main e nas ethernet as subredes.

    achei que era só colocar na tabela IP>ROUTES o gateway como sendo 20.0.0.1 interface wireless1.

    Mas se eu não habilitar o NAT, não consigo trafegar pacotes..

    tenho algumas regras no firewall fazendo limite de conexões tcp marcando pacotes no mangle e dropando no filtre rules.

    Não entendo porque não funciona??

    Se alguem puder me dar uma dica!!!
    Abraços

  2. #2

    Padrão

    essa configuração de mascara ai ta tudo errada... uma rede abrangendo a outra.. e uma menor abrangendo um pedaço da outra...

    para nao ahver nat entre as interfaces, basta no gateway adicionar rotas para as redes.. assim:

    eth0: 192.168.0.1 netmask 255.255.255.0
    eth1: 192.168.1.1 netmask 255.255.255.0
    eth2: 192.168.2.1 netmask 255.255.255.0

    route add -net 192.168.0.0 netmask 255.255.255.0 gw 192.168.0.1
    route add -net 192.168.1.0 netmask 255.255.255.0 gw 192.168.1.1
    route add -net 192.168.2.0 netmask 255.255.255.0 gw 192.168.2.1



    ai uma maquina de uma rede consegue achar as outras...



  3. #3

    Padrão

    Prezado AlexandreCorrea,

    apezar de descordar da sua possição com relação as máscaras de rede que eu uso... tentei aplicar o script como mencionastes acima, porém não tive exito.

    ao aplicar o comando route add -net 192.168.0.0 netmask 255.255.255.0 gw 192.168.0.1 dentro do diretorio ip> o mk não reconheceu o arqumento (-net), veja:
    no such argument (-net)

    a versão do mk que estou usando é a 2.9.27.

    Abraço.

  4. #4

    Padrão

    ah sim.. no mikrotik eh diferente mesmo...
    Código :
    /ip route  add comment="" disabled=no distance=1 dst-address=192.168.0.0/24 gateway=192.168.0.1 scope=255 target-scope=10 
    /ip route  add comment="" disabled=no distance=1 dst-address=192.168.1.0/24 gateway=192.168.1.1 scope=255 target-scope=10 
    /ip route  add comment="" disabled=no distance=1 dst-address=192.168.2.0/24 gateway=192.168.2.1 scope=255 target-scope=10

    testae



  5. #5
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Prezado,

    a crítica do colega Alexandre Correa procede. Além disso usar classe de IP válidos em rede interna é problemático. E mais: essa classe IP (20.0.0.0 - de IP's válidos) nem é reservada para uso no Brasil. Conforme relacionou o Alexandre em redes internas use somente IP's inválidos, ou seja (exemplos): 192.168.0.0/24, 172.16.0.0/24, 10.0.0.0/8 (ou /24, /16, /29, etc).

  6. #6

    Padrão

    Prezado, o exemplo acima é hipotético.. a rede que uso é 10.0.0.0/8


    Grato.