Página 7 de 9 PrimeiroPrimeiro ... 23456789 ÚltimoÚltimo
+ Responder ao Tópico



  1. #37

    Padrão

    Calma mson77


    Creio que você também ficou stressado quando apresentei os meus questionamentos sobre o NTH, faz você foi paciente.

    Vamos ser com o Iure. Ele só precisa se organizar melhor.
    Com suas dicas e sugestões de organizar as mensagens, ele vai aprender e isso vai ajudar no futuro dele... Pense assim..


    Mas voltando ao nosso assunto do NTH, após suas explicações, fiz outros testes, e veja que curioso o resultado que obtive.

    Lembra-se que eu trabalho com Adress-list, selecionando os clientes, e negando alguns ip's válidos, e que dessa forma a proporção do balancemanto não fica de 1 para 1?

    Retirei (para testes) essas opções de address-list e realmente funcionou como você afirmava. Valeu a pena você insistir.

    Infelizmente não vou poder usar devido aqueles fatores todos que apresentei (preciso escolher os clientes que podem passar pelo balanceamento).

    Mas a dúvida maior é:
    Por que?
    Qual a lógica de mudar a proporção aos escolher através de um address-list quem iria passar?


    Mas tenha calma e persistência amigo.
    Veja que no meu caso, está funcionando a contento, mas tenho mais interesse em compreender a lógica do problema, do que resolver (já que sabemos a solução).

    Grande abraço

  2. #38

    Padrão

    Citação Postado originalmente por liandrocarniel Ver Post
    Iure

    Tem certeza que esse teu Mangle tá funcionando certo?

    Na segunda linha tem referencia a nth=2,1,2 apontando para uma dst-address-list=list


    e também tem uma referencia parecida (nth ) mais no final, e as demais regras nao apontam para nenhuma dst-addreslist..


    Creio que o ideal seria voce partir do zero esses teus mangles, primeiramente entendendo eles... creio que você copiou as regras, mas nao analisou direitinho... acho que tem regra sobrando (as primeiras linhas)

    Opa amigo, as 2 primeiras regras foram uma tentativa frustadas de fazer os bancos passarem por fora do balanceamento, inclusive onde tinha dst-address list.

    abraços.



  3. #39

    Padrão

    Primeiro, o que seria erro por distranção e conceito?

    Aqui vão as regras atuais

    / ip firewall nat
    add chain=srcnat action=src-nat to-addresses=192.168.27.1 to-ports=0-65535 \
    dst-port=443 protocol=tcp connection-mark=jump dst-address-list=list \
    comment="" disabled=no
    add chain=srcnat action=src-nat to-addresses=192.168.64.18 to-ports=0-65535 \
    connection-mark=odd comment="" disabled=no
    add chain=srcnat action=src-nat to-addresses=10.246.21.6 to-ports=0-65535 \
    connection-mark=even comment="" disabled=no
    add chain=srcnat action=src-nat to-addresses=192.168.27.1 to-ports=0-65535 \
    connection-mark=jump comment="" disabled=no

    / ip firewall mangle
    add chain=prerouting action=mark-connection new-connection-mark=odd \
    passthrough=yes connection-state=new in-interface=Local nth=2,1,0 \
    comment="" disabled=no
    add chain=prerouting action=mark-routing new-routing-mark=even passthrough=no \
    in-interface=Local connection-mark=odd comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=even \
    passthrough=yes connection-state=new in-interface=Local nth=2,1,1 \
    comment="" disabled=no
    add chain=prerouting action=mark-routing new-routing-mark=even passthrough=no \
    in-interface=Local connection-mark=even comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=jump \
    passthrough=yes connection-state=new in-interface=Local nth=2,1,2 \
    comment="" disabled=no
    add chain=prerouting action=mark-routing new-routing-mark=jump passthrough=no \
    in-interface=Local connection-mark=jump comment="" disabled=no
    / ip firewall address-list
    add list=list address=170.66.11.1 comment="" disabled=no
    add list=list address=170.66.2.59 comment="" disabled=no
    add list=list address=65.55.197.126 comment="" disabled=no
    add list=list address=72.5.77.205 comment="" disabled=no
    add list=list address=170.66.11.10 comment="" disabled=no
    add list=list address=170.66.52.28 comment="" disabled=no
    add list=list address=170.66.1.60 comment="" disabled=no
    add list=list address=65.54.179.203 comment="" disabled=no

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.64.17 distance=1 scope=255 \
    target-scope=10 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.64.17 distance=1 scope=255 \
    target-scope=10 routing-mark=odd comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.27.2 distance=1 scope=255 \
    target-scope=10 routing-mark=jump comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.246.21.1 distance=1 scope=255 \
    target-scope=10 routing-mark=even comment="" disabled=no

    e agora sera que está tudo certinho? eu adicionei a primeira regra no NAT conforme o amigo pediu, gostaria de saber se fiz corretamente.

    na aba address-list estão alguns ips do BB, que estou usando para testes.

    qualquer ajuda eu agradeço
    Última edição por iuredaluz; 05-03-2008 às 19:51.

  4. #40

    Padrão

    Ola...




    Minha mensagem do dia [03-03-2008, 20:48] **APONTA** para o erro de distração. Por favor, confira se eu não apontei o erro de DISTRAÇÃO.


    Mas vou dar "colher de chá" e apontar NOVAMENTE.

    Voce pode me explicar essa regra mangle que eu copiei do seu ultimo post e colei aqui:

    Código :
     add chain=prerouting action=mark-routing new-routing-mark=even passthrough=no \
        in-interface=Local connection-mark=odd comment="" disabled=no
    Voce parece um pouco **arrisco** nas minhas mensagens. Sua opção.
    • MAS as minhas mensagens SEMPRE foram para te ajudar, com regras lógicas e claras.

    ==============================
    Com relação as conexoes tcp:443:

    Sua regra:
    Código :
    add chain=srcnat action=src-nat to-addresses=192.168.27.1 to-ports=0-65535 \
    dst-port=443 protocol=tcp connection-mark=jump dst-address-list=list \
    comment="" disabled=no
    Minha regra:
    Código :
    add chain=srcnat action=src-nat to-addresses=192.168.27.1 to-ports=0-65535 \
    dst-port=443 protocol=tcp comment="" disabled=no
    Se desejar pode filtrar colocando dst_addresses.




    Abracos,
    Última edição por mson77; 05-03-2008 às 21:49.



  5. #41

    Padrão

    Citação Postado originalmente por mson77 Ver Post
    Ola...




    Minha mensagem do dia [03-03-2008, 20:48] **APONTA** para o erro de distração. Por favor, confira se eu não apontei o erro de DISTRAÇÃO.


    Mas vou dar "colher de chá" e apontar NOVAMENTE.

    Voce pode me explicar essa regra mangle que eu copiei do seu ultimo post e colei aqui:

    Código :
     add chain=prerouting action=mark-routing new-routing-mark=even passthrough=no \
        in-interface=Local connection-mark=odd comment="" disabled=no
    Voce parece um pouco **arrisco** nas minhas mensagens. Sua opção.
    • MAS as minhas mensagens SEMPRE foram para te ajudar, com regras lógicas e claras.
    Abracos,
    Grande amigo, eu consegui enxergar o erro, no ODD e EVEN pelos os codigos, porem pelo WINBOX eu ja conferi e reconferi e esta tudo ODD. Acho que eu ja havia concertado isso, desculpe-me por ter postado mensagem errada. ja esta tudo ODD.

    perdão pela insistencia


    Ahhh,
    ja esquecendo eu botei suas regras, e apontei para o ip do MEUIP.com.br

    eu notei que esta tendo um demora de +- 1 minuto para abrir o site.

    ele abre sempre com 1 ip, porem lento. Quando tiro a regra do nat ele abre rapido, porem usando os 3 ips, em todos os ips ele abre rapido.

    PS: botei a regra na frente das outras 3 NATs.
    Última edição por iuredaluz; 05-03-2008 às 22:01.

  6. #42

    Padrão

    Ola...



    pelo jeito... voce diz uma coisa e faz outra.

    A frase sua que eu li foi:

    Aqui vão as regras atuais
    Entao eu vou acreditar no que voce escreveu. Agora se no WinBOX, ou no TELNET, ou no SSH... ou .... (sem conclusão).

    Esse é o motivo de eu pedir: **POSTE SUAS REGRAS**

    Regras é como o RouterOS vai funcionar... e nenhuma descrição literária é melhor que **REGRAS POSTADAS**.


    Eu fiz uma edicao e coloquei informacao sobre tcp:443.
    Volte lá e veja... por favor.

    ================

    Pedi para voce postar /ip route
    para eu ver como estão as regras **DAS INTERFACES**, regras que voce EXCLUI.... mas que pode haver erro... se não examinar para garantir (e pode ser a causa do seu problema inicial).

    Se voce estive no meu lugar... querendo ajudar e a contra-parte economizando informação... eu pergunto: Passa alguma sensação dentro de voce?

    Declaro que: Eu nao peço para postar regras para eu copiar. Peço pois as exposições... as descrições postadas na mensagens... são pobres em informação. Assim...para ajudar... só "chutando"... e entao... isso perde o sentido de FORUM. Poderia chamar de LOTERIA.






    Abraços,