+ Responder ao Tópico



  1. #1

    Padrão squid não inicia no boot

    Saldações galera da underlinux
    venho aqui tentar resolver um problema que parece ser simples mais está esquentando o meu juiso
    bom sou novo no linux instalei aqui o slackware depois compilei o squid está funcionando normal mais quando dou um boot na maquina o serviço não starta dei permição ao arquivo rc.squid mais não funcionou ai está o meu rc.squid

    #!/bin/sh
    squidconf=/etc/squid/squid.conf
    pid=`cat $squidconf | grep pid_filename | awk '{print $2}'`
    prefix=/usr/local/squid
    squid_start() {
    echo starting squid ...
    $prefix/sbin/squid
    }
    squid_stop() {
    echo stopping squid ...
    $prefix/sbin/squid -k shutdown 2>/dev/null
    sleep 1
    $prefix/sbin/squid -k kill 2>/dev/null
    $prefix/sbin/squid -k kill 2>/dev/null
    killall squid 2>/dev/null
    killall squid 2>/dev/null
    rm $pid 2>/dev/null
    }
    case "$1" in
    'start')
    squid_stop
    squid_start
    ;;
    'stop')
    squid_stop
    ;;
    'restart')
    squid_stop
    squid_start
    ;;
    *)
    echo usage $0 "start|stop|restart"
    ;;
    esac


    desde já muito obrigado

  2. #2

    Padrão problema resolvido

    não sei se foi da forma correta por favor min digam se está correto

    criei um arquivo dentro do /etc/rc.d chamado squid dentro do arquivo o conteudo /etc/rc.d/rc.squid start
    depois transformei em exe. chmod +x /etc/rc.d/squid
    depois coloquei dentro do /etc/rc.d/rc.local a seguinte linha /etc/rc.d/squid

    pronto quando reinicio o slackware ele startou normau

    esse procedimento está correto pessoal?



  3. #3

    Padrão

    dentro do rc.local voce tem que colocar

    /etc/rc.d/rc.squid start
    nao foi o start que voce esqueceu?

    sim, o procedimento está correto.

  4. #4

    Padrão

    oi patrik obrigado por sua atencao
    coloquei direto no rc.local o comando /etc/rc.d/rc.squid start

    mais nao funcionou so funcionou quando coloquei esse comando em outro arquivo e depois coloquei o mesmo dentro do rc.local ai ficou blzzzz

    brigadao



  5. #5

    Padrão

    aqui o squid tah instalando em /etc/squid
    dai no meu rc.local uso a linha seguinte
    /etc/squid/sbin/squid start
    funciona perfeitamente, squid 3.0 STABLE1

    sucesso ai!
    Abraço

  6. #6

    Padrão

    oi obriado amigo aquiestá funcionando blz

    /etc/rc.d/rc.squid start

    valeu memo galera pela atencao muito obrigado mesmo

    abracos