+ Responder ao Tópico



  1. Ola...



    entao por favor...

    1) qual é o sistema1;
    2) qual é o sistema2;
    3) qual é o bloco que executa com sucesso;
    4) qual é o bloco que NAO executa com sucesso;


    Responda essas perguntas.




    Abracos,

  2. Citação Postado originalmente por mson77 Ver Post
    Ola...




    entao por favor...

    1) qual é o sistema1;
    2) qual é o sistema2;
    3) qual é o bloco que executa com sucesso;
    4) qual é o bloco que NAO executa com sucesso;


    Responda essas perguntas.




    Abracos,
    Beleza!
    1) Debian Etch r3
    2) Debian Etch r3
    3) É extenso e acho que não precisamos dele, pois o bloco que não funciona está logo no inicio do script.
    4) Veja o inicio do meu tópico.

    Grato pela sua valiosa atenção e fico no aguardo.



  3. Bem, como parece que você já verificou as permissões e tudo mais, lendo o tópico me lembrei de algo similar que passei, eu tinha um script que fazia copia de backups e depois apagava alguns arquivos e um tempo depois eu percebi que o script não funcionava mais da forma certa, no meu caso especifico a parte que não funcionava era quando eu manda mudar o dono com o "chown" e no dia seguinte eu via que os arquivos não tinham mudado de dono e não mostrava erro nem nada, ou seja, bem parecido com o seu problema e depois de muito quebrar a cabeça eu descobri eu o tempo que eu tinha colocado no cron para ele executa já não era mais suficiente, pois ele executava o script *ANTES* dos arquivos de backup serem criados e por isso não mudava o dono do arquivo. Parecido com o seu, não? tentou conferir se no momento da execução do script os arquivos de fato existiam?

    Espero ter ajudado.

    ate+

  4. Citação Postado originalmente por rmaximo Ver Post
    Bem, como parece que você já verificou as permissões e tudo mais, lendo o tópico me lembrei de algo similar que passei, eu tinha um script que fazia copia de backups e depois apagava alguns arquivos e um tempo depois eu percebi que o script não funcionava mais da forma certa, no meu caso especifico a parte que não funcionava era quando eu manda mudar o dono com o "chown" e no dia seguinte eu via que os arquivos não tinham mudado de dono e não mostrava erro nem nada, ou seja, bem parecido com o seu problema e depois de muito quebrar a cabeça eu descobri eu o tempo que eu tinha colocado no cron para ele executa já não era mais suficiente, pois ele executava o script *ANTES* dos arquivos de backup serem criados e por isso não mudava o dono do arquivo. Parecido com o seu, não? tentou conferir se no momento da execução do script os arquivos de fato existiam?


    Espero ter ajudado.

    ate+
    Olá,

    Os arquivos existem sim, é quanto que eles já estão deixando o meu backup ENORME pois os referidos arquivos são todos arquivos desnecessarios.

    Já verifiquei tudo, e não sei mais o que fazer, por isso é pedi ajuda aqui no forum.

    Grato e aguardo qualquer ajuda.



  5. cara..
    experimenta usar o script abaixo, altere de acordo com o caminho dos arquivos:

    Código :
    #!/bin/bash
    cd /caminho/dos/arquivos
    a="dbf DBF fpt FPT idx IDX prn PRN"
    for i in $a; do
       rm -rf *.$i;
    done


    CUIDADO ao alterar este script, pois se houver um espaço entre o "*" e o "." será apagado tudo no diretório corrente..

    scripts que envolvem o comando 'rm' são perigosos...

    para testar, você pode substituir o comando "rm" pelo "ls", quando executar o script deverá mostrar todos os arquivos com as extensões contidas na variável $a

    poste a linha do cron que executa seu script






Tópicos Similares

  1. Bridge com duas Eth0 + Eth1...Help Me !!!
    Por Phillipe no fórum Redes
    Respostas: 9
    Último Post: 16-07-2006, 23:35
  2. help me com o cbq
    Por jhonnybravo no fórum Servidores de Rede
    Respostas: 2
    Último Post: 30-11-2005, 07:58
  3. Um script com politica INPUT DROP e squid
    Por alimasilva no fórum Servidores de Rede
    Respostas: 1
    Último Post: 18-08-2005, 10:16
  4. Preciso montar um servidor, com o slackware 10, help-me
    Por Enoch no fórum Servidores de Rede
    Respostas: 19
    Último Post: 20-07-2005, 16:08
  5. Script com erro Por favor alguem me ajude
    Por edilson no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 12-01-2003, 23:09

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L