Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Meu amigo, a última sugestão que eu tenho é mudar a linha de configuração do mrtg de:
    Target[perf]:'/home/vipnet/mrtg/mrtgstats-cpu.sh'

    para

    Target[perf]:`/home/vipnet/mrtg/mrtgstats-cpu.sh`


    Ou seja, ao invés de aspas simples você coloca essa outra aspas que é o mesmo sinal da crase.

    Espero que funcione.

    ate+

  2. Citação Postado originalmente por rmaximo Ver Post
    Meu amigo, a última sugestão que eu tenho é mudar a linha de configuração do mrtg de:

    Target[perf]:'/home/vipnet/mrtg/mrtgstats-cpu.sh'

    para

    Target[perf]:`/home/vipnet/mrtg/mrtgstats-cpu.sh`


    Ou seja, ao invés de aspas simples você coloca essa outra aspas que é o mesmo sinal da crase.

    Espero que funcione.

    ate+

    Muito obrigado por ter tentado ajudar! obrigado mesmo! são de pessoas como você que faz esse forum funcionar... mas infelizmente não deu certo... É tão simples utilizar o MRTG, não estou entendendo o porque de não estar conseguindo! visto que não tem segredo algum um script simples como esse.

    Troquei as aspas simples pelo simbolo `(usado em crase) porém sem exito... o MRTG retornou erro no script:

    vipnet-proxy:~# mrtg /home/vipnet/mrtg/mrtg.conf
    Daemonizing MRTG ...
    vipnet-proxy:~# 2008-03-11 16:29:15: WARNING: Could not get any data from external command '/home/vipnet/mrtg/mrtgstats-cpu.sh'
    Maybe the external command did not even start. (Illegal seek)
    2008-03-11 16:29:15: WARNING: Problem with External get '/home/vipnet/mrtg/mrtgstats-cpu.sh':
    Expected a Number for 'in' but nothing'
    2008-03-11 16:29:15: WARNING: Problem with External get '/home/vipnet/mrtg/mrtgstats-cpu.sh':
    Expected a Number for 'out' but nothing'
    2008-03-11 16:29:15: ERROR: Target[perf][_IN_] ' $target->[1]{$mode} ' did not eval into defined data
    2008-03-11 16:29:15: ERROR: Target[perf][_OUT_] ' $target->[1]{$mode} ' did not eval into defined data

    Ainda fico na esperança de ver esse negócio funfar sem eu enlouquecer! rs



  3. De fato o MRTG é algo muito simples, você já tentou verificar as permissões do script? O usuário que você está executando o MRTG tem permissão de execução para o script? O mesmo usuário também tem permissão para acessar o arquivo /proc/net/dev ?

  4. Citação Postado originalmente por rmaximo Ver Post
    De fato o MRTG é algo muito simples, você já tentou verificar as permissões do script? O usuário que você está executando o MRTG tem permissão de execução para o script? O mesmo usuário também tem permissão para acessar o arquivo /proc/net/dev ?

    Sim, estou executando como root. Estou tentando atualizar o MRTG para uma versão mais nova para ver se funciona... Vou postar os resultados. Obrigado.
    Última edição por vipnet; 11-03-2008 às 20:58.



  5. Te aconselho a tentar um agente snmp para facilitar essa coleta de informação... é bem mais facil, e tem muitos softwares que jah tem receita de bolo em muitos lugares. Eu sempre opto pelo SNMP porque da para coletar de diversas maquinas a partir de um unico ponto






Tópicos Similares

  1. Cacti não gera gráficos...Quem sabe???
    Por regisnr no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 05-04-2007, 12:58
  2. Cacti não gera gráficos
    Por Davi Junio no fórum Servidores de Rede
    Respostas: 1
    Último Post: 07-01-2006, 00:55
  3. Parte gráfica no Debian-CDD-Br não sob com Geforce 128mb
    Por rfdasilva1 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-04-2005, 15:55
  4. KDE no Debian!!! $DYSPLAY ERROR
    Por JVKurumin no fórum Servidores de Rede
    Respostas: 3
    Último Post: 27-08-2004, 15:34
  5. mrtg não gera gráfico
    Por cristianff no fórum Servidores de Rede
    Respostas: 9
    Último Post: 13-05-2004, 14:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L