+ Responder ao Tópico



  1. #1

    Padrão load balance, como fazer com links que caem?

    olá pessoal

    eu estou com uma duvida, tenho um load balance rodando no meu servidor para 2 links, estou fazendo redirecionamento por porta, e to com problema em 1 deles que costuma cair, e todos os aplicativos dependentes dessas portas param de funcionar.

    Tem com fazer como fazer quando um link para de funcionar o outro assuma todo o tráfego do servidor? e quando voltar o segundo link ele assuma as portas novamente?


    valeu pessoal

  2. #2

    Padrão

    tem sim.. mas nao eh 100% !!

    os seus links sao adsl ? caso sim.. faça um script que de 1 em 1 minuto. dispare um arping para cada modem.. os 2 vao responder.. quando nao responder.. ai vc executa comandos para passar o trafego para um link so...



  3. #3

  4. #4

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    tem sim.. mas nao eh 100% !!

    os seus links sao adsl ? caso sim.. faça um script que de 1 em 1 minuto. dispare um arping para cada modem.. os 2 vao responder.. quando nao responder.. ai vc executa comandos para passar o trafego para um link so...


    interessante, mais não manjo muito de script, vc tem algum material ou indicação onde posso aprender a fazer os scrípts


    valeu amigo



  5. #5

    Thumbs up

    Citação Postado originalmente por j34nsch Ver Post
    interessante, mais não manjo muito de script, vc tem algum material ou indicação onde posso aprender a fazer os scrípts


    valeu amigo


    Estude sobre Netwatch!
    pode te ajudar e muito !

  6. #6

    Padrão

    valeu pessoal, já consegui resolver o problema, fico muito grato a todos



  7. #7

    Padrão

    poste a solução entao companheiro assim o forum cresce

  8. #8

    Padrão solução

    ok amigo, eu fiz o seguinte, adicionei os dois gtw no mk, o principal deixei como main, e o segundo destinei para link2, assim marquei por ranges, conforme abaixo



    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Ranges associada ao Link2" disabled=no new-routing-mark=link2 passthrough=yes src-address=172.10.0.0/24

    add action=mark-routing chain=prerouting comment="" disabled=no new-routing-mark=link2 passthrough=yes src-address=172.11.1.0/24

    add action=mark-routing chain=prerouting comment="" disabled=no new-routing-mark=link2 passthrough=yes src-address=172.14.4.0/24

    add action=mark-routing chain=prerouting comment="" disabled=yes new-routing-mark=link2 passthrough=yes src-address=172.15.3.0/24

    add action=mark-packet chain=prerouting comment="Pacotes marcados do Link2" disabled=no new-packet-mark=link2 passthrough=yes routing-mark=link2


    os gtw ficou da seguinte maneira


    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=20x.xx.21x.xx routing-mark=main scope=30 target-scope=10

    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=xxx.1x8.45.54 routing-mark=link2 scope=30 target-scope=10


    assim fiz as rotas, mais como o meu link 2 costuma cair adicionei o seguinte netwatch, para pingar o meu gwt do link2


    /tool netwatch
    add comment="consultar_link2" disabled=no down-script=link2_down host=10 xxx.1x8.45.54 interval=5s timeout=1s


    eu não adicionei nada no up, pois se tiver pequenas variações do link2 seguidas, vai acabar atrapalhando os clientes, então adicionei um scheduler para a cada 10 minutos ele tentar levantar o link2

    /system scheduler
    add comment="" disabled=no interval=10m name="link2_up" on-event=link2_up start-date=jan/01/2008 start-time=00:10:00


    os scripts de down e up do link estão abaixo

    /system script
    add name="link2_up" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip route set [/ip route find gateway=xxx.1x8.45.54] disabled=no"

    add name="link2_down" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip route set [/ip route find gateway=xxx.1x8.45.54] disabled=yes"
    Última edição por j34nsch; 25-03-2008 às 10:03.



  9. #9

    Padrão

    pessoal acho que dá para entender, qualquer coisa posta ai no forum que eu explico


    valeu amigos