+ Responder ao Tópico



  1. Então cara...
    Para você habilitar o ip_forward você tem que fazer isso aqui:

    Código :
    echo "1" > /proc/sys/net/ipv4/ip_forward

    Você pode colocar esse comando no seu script de firewall!

    Para você liberar sua rede vai fazendo aquilo que te falei no post anterior!
    Liberando os serviços que você quer!
    Você colocou as regras para liberar os serviços??
    Sem isso não vai funcionar cara!

  2. Código:
    echo "1" > /proc/sys/net/ipv4/ip_forward
    Você pode colocar esse comando no seu script de firewall!

    Para você liberar sua rede vai fazendo aquilo que te falei no post anterior!
    Liberando os serviços que você quer!
    Você colocou as regras para liberar os serviços??
    Sem isso não vai funcionar cara!

    Eu digitei esse comando do ip_forward quando compartilhei a rede.

    é claro q eu digitei os comandos, ja fiz refiz deletei tudo depois digitei iptables -F e digitei de novo pra testa, e nada do outlook e o ftp funcionar.

    ta foda =/



  3. bom cara... uma coisa é certa!
    agente daqui (remotamente) podemos te dar dicas!
    você ai precisa tentar "debugar" o problema!

    você já verificou se suas regras estão fazendo match nos pacotes?
    para verificar isso você precisa executar o comando:

    Código :
    iptables -t filter -L -v -n
    por exemplo no meu computador, fiz uma regra só para te mostrar!

    Código :
    Chain INPUT (policy ACCEPT 289 packets, 21468 bytes)
     pkts bytes target     prot opt in     out     source               destination
       39  3068 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0           tcp dpt:22
    Essa regra mostra que ela esta fazendo match na minha conexão ssh! Você pode observar os campos "pkts" e "bytes" eles estao sendo incrementados!
    Estou usando porta 22 e protocolo tcp (obvio! )

    Outra coisa... suas regras de politica do iptables estao para drop?
    Se sim você não pode deixar de configurar para que as conexões possam voltar!

    Código :
    iptables -t filter -A FORWARD -p tcp -m state --state ESTABLISHED,RELATED -j ACCEPT
    Tenta aee manow!

  4. Outra coisa...
    O que você ta mandando para o squid?
    Exatamente TUDO ou porta 80?

    Com o squid ai no meio você tem mais um ponto de falha!
    Tem que analizar TUDO!
    Última edição por zenun; 24-03-2008 às 14:05.



  5. Código:
    Chain INPUT (policy ACCEPT 289 packets, 21468 bytes)
    pkts bytes target prot opt in out source destination
    39 3068 ACCEPT tcp -- * * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22
    Essa regra mostra que ela esta fazendo match na minha conexão ssh! Você pode observar os campos "pkts" e "bytes" eles estao sendo incrementados!
    Estou usando porta 22 e protocolo tcp (obvio! )

    Tipo fiz isso ai mas o meu aparece o IP, olha

    Código :
    root@Server:/etc/squid# iptables -t filter -L -v -n
    Chain INPUT (policy ACCEPT 83641 packets, 52M bytes)
     pkts bytes target     prot opt in     out     source               destination
     
    Chain FORWARD (policy ACCEPT 7553 packets, 498K bytes)
     pkts bytes target     prot opt in     out     source               destination
        0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED
        0     0 ACCEPT     tcp  --  192.168.0.254 *       0.0.0.0/0            0.0.0.0/0           multiport dports 21,20
        0     0 ACCEPT     tcp  --  192.168.0.254 *       0.0.0.0/0            0.0.0.0/0           multiport dports 25,110
        0     0 ACCEPT     tcp  --  192.168.0.3 *       0.0.0.0/0            0.0.0.0/0           multiport dports 25,110
        0     0 ACCEPT     tcp  --  192.168.0.2 *       0.0.0.0/0            0.0.0.0/0           multiport dports 25,110

    esse comando ai no lugar do LAN eu coloco o meu IP ou o do servidor ?
    mas de qualquer forma ja coloquei de todos jeitos possiveis.

    Código :
    iptables -t filter -A FORWARD -i $LAN -p tcp -m multiport --destination-port 25,110 -j ACCEPT


    meu squid não tem regra nenhuma especifica só ta fazendo cache, mostrando um arquivo pra sites bloqueados nada de mais.

    me fala o q mais eu posso te informar pra vc me ajudar melhor.

    vlw cara






Tópicos Similares

  1. Problemas com IPTABLES
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 20-01-2004, 10:35
  2. Problema com Iptables em Cache Server
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 04-10-2003, 00:53
  3. Problemas com IPTABLES
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-07-2003, 16:38
  4. Problemas com IPTABLES
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 26-06-2003, 10:00
  5. problemas com iptables
    Por no fórum Servidores de Rede
    Respostas: 15
    Último Post: 05-02-2003, 18:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L