Página 3 de 3 PrimeiroPrimeiro 123
+ Responder ao Tópico



  1. Citação Postado originalmente por milhardes Ver Post
    Amigo, segue abaixo meu script porém o nome da interface que é "pppoe-out" eu obtive no menu inteface no campo name tambem fiz um teste com o campo type que é "PPPoE out" mas nao deu certo este ultimo ele so inicia o script e nao retorna msg de erro algum mas tb não altera o ip, estou usando o dyndns e no site consigo entrar com esse dominio abaixo sem problema.

    Script:

    :log info "DDNS: Begin"
    :global ddns-user "****"
    :global ddns-pass "*****"
    :global ddns-host "netplus.homeunix.net"
    :global ddns-interface "pppoe-out"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"


    Obrigado
    André.

    Esse script que o amigo milhardes
    é o que deve ser usado na v2 do MK
    roda redondo


    o meu script é para a v3 do MK
    tb roda redondo

    de uma revisada nos seu script
    algum promenor que esta lhe escapandoo

  2. Citação Postado originalmente por milhardes Ver Post
    Script:

    :global ddns-host "netplus.homeunix.net"
    Amigo usa o changeip que da certo, esse homeunix é do dyndns
    falow

    CRIA A CONTA AKI------> Enhanced Dynamic DNS Solutions



  3. altera o pppout para a interface que esta direta no modem.

  4. Amigo,

    a interface que esta direta ao modem agora só inicializa o script ou seja no log do mkt ele só inicializa o "BEGIN" e nao traz nenhum retorno de confirmação ou se deu erro.
    Somente quendo eu coloco pppoe-out é que ele retorna a msg de erro "Authentication Failure" porém eu entro pelo site normalmente tanto no dyndns como no change ip.

    O que será q pode estar acontecendo.

    Obrigado
    Andre



  5. Citação Postado originalmente por milhardes Ver Post
    Amigo,

    a interface que esta direta ao modem agora só inicializa o script ou seja no log do mkt ele só inicializa o "BEGIN" e nao traz nenhum retorno de confirmação ou se deu erro.
    Somente quendo eu coloco pppoe-out é que ele retorna a msg de erro "Authentication Failure" porém eu entro pelo site normalmente tanto no dyndns como no change ip.

    O que será q pode estar acontecendo.

    Obrigado
    Andre

    amigo o codigo aqui citato esta correto, funciona 100% pra resolver seu problema de autenticacao eh necessario que dentro do changeip o seu Account Status: Active so isso. abraços






Tópicos Similares

  1. Postfix - Problema para enviar e-mail para servidores MS Exchange
    Por Gustavo Coppi no fórum Servidores de Rede
    Respostas: 0
    Último Post: 10-10-2013, 16:39
  2. COMO FAZER PARA NÃO MOSTRA IP PUBLICO DO LINK NO CLIENTE
    Por danielolainewireless no fórum Redes
    Respostas: 13
    Último Post: 24-06-2011, 18:29
  3. script para enviar 1 bit para porta paralela.
    Por fsoaress76 no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 25-05-2009, 11:53
  4. ERRO PARA ENVIAR E-mail para UOL
    Por Visitante no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-09-2005, 07:59
  5. ERRO PARA ENVIAR E-mail para UOL
    Por guilhermebsd no fórum Servidores de Rede
    Respostas: 2
    Último Post: 19-09-2005, 13:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L