+ Responder ao Tópico



  1. #19

    Padrão

    Farei o teste amigo muito obrigado

    abraços

    Clecio

    Citação Postado originalmente por Shturbo Internet Ver Post
    Brow.. vc tem que fazer uma regra direcionando tod trafego Http para sair sempre por um unico link q resolve... ip / firewall / mangle

  2. #20

    Padrão

    ate hj nada em clecio, fala serio, vamos tentar resolver isso aqui, na verdade mesmo marcando no mangle dentro do balance acho que nao vai dar certo, tem que marcar os pacotes antes de chegar no balance, aqui eu fiz o seguinte:
    servidor ---------- saida wireless
    servidor ---------- rede interna
    servidor----------- link balance
    servidor------------link proxy

    marcando os pacotes no mangle do servidor estou pondo rota no gateway mark=pacote mas mesmo assim nao estou conseguindo direcionar esses pacotes para o servidor proxy.

    obs: minha ideia eh enviar os pacotes http msn e tals para o servidor proxy que esta o link dedicado e deixando o lixo para o balance.

    o mais interresante eh o seguinte, na rede interna funciona blz...vai entender... ne...
    se quizer posto aqui o script que estou usando....



  3. #21

    Padrão

    problema resolvido.

    ip firewall mangle
    chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=rota_http passthrough=yes
    chain=prerouting routing-mark=rota_http action=mark-routing new-routing-mark=rota_http passthrough=yes

    ip route
    add gateway=seu gateway mark=rota_http

    pulo do gato:
    se adicionar essa regra no servidor e tiver rodando hotspot na interface onde deseja marcar os pacotes entao eh necessario desmarcar o proxy transparente no users profiles... abraços

  4. #22

    Padrão

    Pra mim funcionou aqui desse jeito, na tabela mangle criei a marcação da rota como bancos e na tabela Nat criei um Nat pra rota default que ja existe lá em ip routes só que marcando a tabela "bancos" dessa forma funcionou todos os bancos aqui:

    ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=bancos passthrough=no comment="bancos" disabled=no

    ip firewall nat
    add chain=srcnat routing-mark=bancos action=masquerade comment="Bancos" disabled=no

    Espero ter ajudado!!



  5. #23

    Padrão

    Amigo, me interessei no seu LB, como ele funciona?
    vc tem que adicionar os gateways manualmente para cada cliente, ou ele é automático?

    Citação Postado originalmente por cleciorodrigo Ver Post
    Amigos boa tarde, pessoal tenho um balanceamento rodando aqui com 2 ADSL, funcionando td perfeito, MSN, orkut, navegação porem agora tenho um cliente usando o site do Bradesco e não consegui, pois o IP muda durante a sessão de acesso ao Site. Alguem tem uma dica ai pra poder me ajudar, abaixo segue as informações de configuração do meu servidor Mikrotik

    ENDEREÇAMENTO IP


    ROTAS


    MANGLE


    NAT


    Abraços

    Clecio

  6. #24

    Padrão

    Amigos,
    Estou tentando fazer um LoadBalance a cerca de uns 3 dias... rs.. to meio perdido.. já li bastante coisa no fórum e este post foi até agora o mais específico para o meu caso. Olhei as configurações do nosso amigo Clecio, que abriu o post, e fiz exatamente igual (claro que adaptando à minha rede), mas não consigo fazer o balanceamento funcionar.
    Entretanto, vale dizer que há alguns ítens diferentes na minha rede:
    - tenho 3 links dedicados de 2Mbs da Telefonica, que já estão balanceados no meu roteador, então utilizo em meu servidor um IP público e fixo por onde já trafego os 6Mbs.
    - estou adicionando em minha rede + 2Mbs de outra prestadora, que também me fornecerá um IP público e fixo.
    - preciso juntar esses 6Mb que já tenho com mais esses 2Mb novos no meu server Mk.
    - meu pc que está com Mk só está com 2 placas de rede: uma para clientes e outra para o link. Estou adicionando os dois IPs públicos dos links na mesma interface.. será que isso pode estar impedindo o balanceamento de funcionar?
    - utilizo PPPoE para os clientes... teria algum problema?

    Serei muito grato a quem puder me ajudar... estou realmente muito perdido...
    Obrigado a todos,
    Att
    Ricardo