Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    no meu servidor de nat temos os seguintes mods ativados:

    echo "Carregando os modulos..."
    modprobe ip_conntrack_ftp
    modprobe ip_conntrack
    modprobe iptable_nat
    modprobe iptable_filter
    modprobe ip_nat_ftp
    modprobe ip_nat
    modprobe ip_tables

    isso no arquivo de firewall, nao esqueça de ativar o nat

    # Turn on IP forwarding
    echo 1 > /proc/sys/net/ipv4/ip_forward



    No meu caso uso o iptables no debian e as regras estão assim:

    echo "Criando regras de NAT..."
    iptables -t nat -A POSTROUTING -s 10.XX.XX.XX/16 -j SAME --nodst --to 201.XX.XX.XX-201.XX.XX.XX


    espero ter ajudado

  2. #22

    Padrão

    Tentei da forma que vc falou, com os módulos e nat ativados, mas não consegui navegar, abrir MSN, Orkut, etc.

    Desabilitei o squid e limpei as regras do firewall, deixando somente o SAME e mesmo assim nada.

    Alguma idéia do que pode ter acontecido, já que o meu servidor também é Debian? É um Debian 4.0 kernel 2.6.18.



  3. #23

    Padrão

    Olhei que existe o módulo ipt_SAME. Ativei-o, mas ficou tudo na mesma.

    Que onda!!!! hehehehehehe

  4. #24

    Padrão

    Consegui resolver .... É preciso criar alias na placa de rede para os IP's colocados no range do SAME, mas fiz um teste acessando www meuip com br e sempre apareceu o mesmo ip. Não ficava alternando entre os IPs cadastrados. No Rapidshare ficou a mesma coisa.

    Alguma idéia agora?
    Última edição por macvitor; 10-04-2008 às 12:17.