Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. DNS - Dinamico_acesso_remoto
    --------------------------------------------------------------------
    Dynamic DNS Update Script for ChangeIP.com
    From MikroTik Wiki
    Jump to: navigation, search
    The following script should be created when you wish to update your ChangeIP.com Dynamic DNS account. Once created you should schedule this to run once in a while. The :global variables should be edited to include your unique username and password, interface name, etc.
    :log info "DDNS: Begin"
    :global ddns-user "YOURUSERID"
    :global ddns-pass "YOURPASSWORD"
    :global ddns-host "*1"
    :global ddns-interface "EXACTINTERFACENAME"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

  2. vc tem de ter atenção
    existem dos scripts para o mikrotik

    um para a versao 2.0
    que é esse que o amigo postou ai anteriormente


    e um outro para a versao 3.0


    :global ddnsuser "USER"
    :global ddnspass "PWD"
    :global ddnshost "my.dyn.ip"
    :global ddnsip
    :global ddnslastip [:tostr [:resolve $ddnshost] ]
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
    :global ddnsinterface "SUA_INTERFACE_PPOE"
    :global ddnssystem ("mt-" . [/system package get system version] )

    :local int

    :local ddnsipfn [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
    :global ddnsip [ick $ddnsipfn 0 [:find $ddnsipfn "/"]]

    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=$ddnsip key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={
    :log info "DDNS: No update required."
    }

    }


    Abraços



  3. Blza agora onde eu coloco esse scripts..

    Citação Postado originalmente por iceboxrj Ver Post
    vc tem de ter atenção
    existem dos scripts para o mikrotik

    um para a versao 2.0
    que é esse que o amigo postou ai anteriormente


    e um outro para a versao 3.0


    :global ddnsuser "USER"
    :global ddnspass "PWD"
    :global ddnshost "my.dyn.ip"
    :global ddnsip
    :global ddnslastip [:tostr [:resolve $ddnshost] ]
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
    :global ddnsinterface "SUA_INTERFACE_PPOE"
    :global ddnssystem ("mt-" . [/system package get system version] )

    :local int

    :local ddnsipfn [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
    :global ddnsip [ick $ddnsipfn 0 [:find $ddnsipfn "/"]]

    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=$ddnsip key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={
    :log info "DDNS: No update required."
    }

    }


    Abraços

  4. Pessoal pra nao aparecer essas carinhas o texto (smiles) qdo for postar marquem em baixo de opçoes diversas a ultima caixa desativar smiles fica mais facil de entender o script, que ai nao aparece akela carinha chata no script falow abraços



  5. Olá,

    se você estiver usando ADSL ou banda larga terá problemas se o modem estiver roteado, pois o NAT pode está fechando o acesso externo ao Mikrotik. Além das regras de acesso externo no Mikrotik terá abrir a porta do NAT no modem e redirecioná-la ao Mikrotik.






Tópicos Similares

  1. Problemas para acessar o Mk via WinBox...
    Por guicio no fórum Redes
    Respostas: 7
    Último Post: 20-06-2008, 12:29
  2. Acesso ao MK via Winbox com wine no linux.
    Por andrighetti no fórum Redes
    Respostas: 6
    Último Post: 15-02-2008, 10:18
  3. Respostas: 2
    Último Post: 06-11-2007, 15:20
  4. Não consigo acessar o MK pelo Winbox
    Por Mirandapb no fórum Redes
    Respostas: 2
    Último Post: 17-01-2007, 08:20
  5. Respostas: 5
    Último Post: 12-08-2006, 12:40

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L