Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão Script Web Pronto Para Monitorar Sinal

    Muito bom broder parabens pela iniciativa, agora so disponibilizar o script para nos.

  2. #22

    Padrão

    aproveitando o tópico será q nesse script téria como desconectar os clientes por exemple -80 só conectão os clientes q estejão com -80......



  3. #23

    Padrão

    Citação Postado originalmente por talesarconet Ver Post
    aproveitando o tópico será q nesse script téria como desconectar os clientes por exemple -80 só conectão os clientes q estejão com -80......
    para isso basta você atualizar o mikrotik para uma versão nova que tem essa opção.

  4. #24

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    para isso basta você atualizar o mikrotik para uma versão nova que tem essa opção.

    na versão 3.9 mais ela está estável....a parte wireless?



  5. #25
    Moderador Avatar de ederamboni
    Ingresso
    Oct 2004
    Localização
    Montes Claros
    Posts
    880
    Posts de Blog
    13

    Padrão

    entao acima de v3 ja tem essa opcao do sinal muito acima do normal desconectar o cliente...
    e o script amigo!!!!!

  6. #26



  7. #27

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    o script para fazer isso funcionar mostrando de cada cliente no log seria isso

    :foreach i in=[ /int wir reg find interface=wlan1] do={ log info ([/system identity get name] . "," . [get $i mac-address ] . "," . [get $i last-ip] . "," . [get $i rx-rate] . "," . [get $i tx-rate] . "," . [get $i uptime] . "," . [get $i last-activity] . "," . [get $i signal-strength] . "," . [get $i signal-to-noise] . "," . [get $i tx-ccq] . "," . [get $i bytes] . "," . [get $i packets]) }

    porem nao consegui botar pra funcionar isso,

    alguem ja conseguiu?

    tipo da que o foreach nao é um comando, num sei nao entendi essa parte ainda.

    entao teria sse que pegar essas informações dos logs e gerar um html com elas,

    ficou muito legal a pagina do amigo iniciador do topico.

    volte aqui amigo, e ajude esse pessoal todo.
    Amigo postei o script com o passo-a-passo pra instalar neste post!
    https://under-linux.org/forums/mikro...-new-post.html

  8. #28

    Padrão

    fala galera..
    alguem poderia me dar uma força com um script?

    preciso que quando o script rode, e na interface configurada nele o número de clients registrados..

    tentei usar o script de ack postado aqui e fazer as mudanças, mas não consegui sucesso...parece que a variavel para capturar o numero de clientes registrado na interface não é "registered-clients", mas é assim que aparece quando do um 'monitor' na interface.

    Código :
     Defina abaixo o valor mínimo de ACK
    :global ack 1;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 1;
    :global drop 1;
    # Defina abaixo 1 para reiniciar a Interface quando um cliente estiver acima do valor mínimo e 0 para não fazer nada
    # Obs.: Ative apenas no último dos casos, pois derruba todos clientes enlaçados na Interface
    :global intdis 0;
    # Defina abaixo a Interface
    :global interf "Clientes";
     
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global cliente "";
    :log info ("Listando Clientes com ACK acima de " . $ack . " ms:");
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
      :if ([/interface wireless registration-table get $i registered-clients] < $ack) do={
        :log info ("COMENTARIO:  REINICIOU");
         :if ($block = 1) do={
          /interface wireless disable $interf;
      /interface wireless enable $interf;
        };
        :set total total+1;
      };
    };
    :if ($total = 0) do={
      :log info ("Nenhum Cliente com ACK acima de " . $ack . " ms encontrado.");
    } else {
      :if ($intdis = 1) do={
        /interface wireless disable $interf;
        /interface wireless enable $interf;
      };
    };