+ Responder ao Tópico



  1. #1

    Padrão Cache-Full

    amigos estow com uma duvida que está marcado de vermelho e fiqueium pouco perdido perdido

    algem poderia dá uma olhada nessas regras e ver se ta td certinho .

    / ip firewall mangle

    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" action=mark-connection new-connection-mark=squid-connection-HIT passthrough=yes comment="Cache-squid" disabled=no
    add chain=output connection-mark=squid-connection-HIT action=mark-packet new-packet-mark=squid-packet-HIT passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=ether2 src-address=10.10.0.0/24 action=mark-packet new-packet-mark=test-up passthrough=no comment="UP TRAFFIC" disabled=no
    add chain=forward src-address=10.10.0.0/24 action=mark-connection new-connection-mark=test-conn passthrough=yes comment="CONN-MARK" disabled=no
    add chain=forward in-interface=ether1 connection-mark=test-conn action=mark-packet new-packet-mark=test-down passthrough=no comment="DOWN-DIRECT CONNECTION" disabled=no
    add chain=output out-interface=ether2 dst-address=10.10.0.0/24 action=mark-packet new-packet-mark=test-down passthrough=no comment="DOWN-VIA PROXY
    disabled=no

    / queue tree
    aq tinha o nome cliente
    add name="downstream" parent=aq uso oq packet-mark=test-down limit-at=1024000 queue=default priority=1 max-limit=1024000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="upstream" parent=global-in packet-mark=test-up limit-at=512000 queue=default priority=1 max-limit=512000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="Cache-full" parent=global-out packet-mark=squid-packet-HIT limit-at=2000000 queue=default priority=8 max-limit=2000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no

    agradeço a todos do under sempre nos ajudando.

  2. #2
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    pode tirar essa linha
    add name="downstream" parent=aq uso oq packet-mark=test-down limit-at=1024000 queue=default priority=1 max-limit=1024000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no

    ;}



  3. #3
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão

    Olá Telearconet vejo que vc tb é um dos que quer enganar seus usuarios.
    Bom por isso darei sua resposta resumidamente e restante terá de pesquisar o intem em vermelho é pra selecionar a prioridade da regra.

  4. #4

    Padrão

    o problema ñ é enganar o proposito é oferecer o melhor serviço e rapidez já q tesmos alternativas.

    como link é um pouco caro.

    Sei q essa regra faz isso mais pra quer serve essa segra

    add name="downstream" parent=global-in ou out packet-mark=test-down limit-at=1024000 queue=default priority=1 max-limit=1024000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no


    sempre tenntando aprender



  5. #5

    Padrão

    Explicar melhor a sua afirmação, de que cache-full é "enganar o cliente" minelli.

  6. #6
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Proxy Full

    Olá EdilsonLSouza, ñ veja a diferença:

    Ao vc habilitar o cache full o cliente verá que sua velocidade contratada continua a mesma por ex. 256k e qd faz down de algo q ñ está no cache vem a 32k, porem para que nós tenhamos a possibilidade de adquirir mais clientes com o mesmo link sem necessitar aumenta-lo então ativamos o proxy full fara uma enorme economia de banda, mas o cliente sabe que sua banda é 256 e que tem um cache e td que vem do cache vem liberado pq eu trabalho assim e explico ao cliente qd assinamos o contrato.

    Veja a diferença o que o colega acima quer é que qd o cliente entre no RJnet por ex marca uma velocidade que ñ é real, que ñ é a oferecida pelo cliente. Cada uma trabalha de uma forma, mas vai bastar 1 experto pra poder colocar um processo em qqr um que faça isso e só dividir a velocidade contratada por 8 e já se sabe a taxa de dow ou vice versa se tem a taxa de down multiplica por 8 e se tem a banda.... é só um alerta cuidado. Já vi um provedor da cidade vizinha fechar as portas por ordem juducil por causa desse motivo. É só um alerta.
    Procurem trabalhar honestamente......., é mais caro mas fale a pena.



  7. #7

    Talking

    Minelli, tem como vc posta suas regras d proxy? pq eu entendo como funciona mas nao sei fazer.. ou vc usa um outro servido a parte fazer este serviço? VLW

  8. #8

    Padrão

    Agradeço a resposta, mas o tópico se trada de proxy-full / cache-full? Não li sobre MEDIDORES DE VELOCIDADE, por isso fiz a pergunta, você mesmo usa profy e cache, por quê explicar o cliente que em sua maioria é um simples usuário, caso o cliente queira processar e se não estiver em contrato a tecnica de nada adianta explicar, concorda?



  9. #9
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Respostas

    Bom vamos lá :

    Bom como todos aqui podem perceber os nomes Proxy e Cache são usados com o mesmo objetivo ao abrirem um tópico referindo-se a mesma coisa apesar de terem diferença:

    Código :
    Na verdade o que você está falando são termos distintos, o que acontece é o seguinte:
     
    Proxy - Intermediário entre a net e a rede interna (ao pé da letra), entenda como um servidor(gatway) de internet para a rede interna da sua empresa. Exemplos disso são: Squid, etc.
     
    Cache - O cache é um armazenamento de qualquer tipo de documento (páginas da internet, arquivos, etc) para uma visualização mais rápida posteriormente. Exemplo disso: O usuário X abre a página da belladasemana. O servidor cache armazena essa página na HD para quando o usuário Y fizer a requisição da mesma página, ela não seja puxada da internet novamente, a menos que a mesma tenha sido alterada.
     
    Cache-Full - A mesma coisa do Cache mas vem sem limite se estiver no HD.
     
    O Squid (sistema de web-proxy do MK até a versão 2.9.51 pois após essa versão os desenvolvedores criaram seu proprio web-proxy ficando uma porcaria por não marcar pacoto como X-Cache: Hit...), junta os dois elementos acima, tornando-se um servidor PROXY-CACHE, ou seja: Ele é tanto um servidor de internet para a sua rede interna, como um servidor de caching de páginas visualizadas e arquivos.
     
    Observação: Não entenda "Servidor de internet" como servidor de algum provedor, como UOL, mas sim um gargalo de rede ou um gateway.
     
    Proxy transparente: Os usuários utilizam o seu proxy obrigatoriamente, sendo transferidas todas as requisições feitas com destino à porta 80 da internet para a porta 3128 (a do Web-Proxy Squid). Diz-se TRANSPARENTE pelos usuários não perceberem que eles estão utilizando o mesmo. Para ativa-lo tera que criar regras de redirecionamento.

    O colega acima está montando um devio tipo toda vez que o cliente acessar alguns medidores de velocidade ele libera a banda do restante funciona normal.

    Ao explicar aos clientes vc está sendo + que transparente apesar de varios não saberem o que é a maioria pesquisa e se informa sem contar a parte boa propagam que existe um diferencial em seu sistema em comparação a concorrencia.

    Mais duvidas mandem ai, em quanto eu souber respoder, estarei respondendo.

    Quanto as regras, são as mesma do video do Alexandre Correa.

  10. #10

    Padrão

    Citação Postado originalmente por EdilsonLSouza Ver Post
    Explicar melhor a sua afirmação, de que cache-full é "enganar o cliente" minelli.
    Mineli, também não entendi o "enganar" poderia explicar?



  11. #11

    Padrão

    tbm gostaria de saber como se esta "enganando" pq
    eu fiz um desta forma e todos estão baixando na velocidade contratada mesmo e não por um "suposta velocidade mentiroza"
    a velocidade deles soma sim a quantidade normal que eu tenho
    o bom é que ganho mais uma folga nos sites somente isso
    se for errado gostaria que vc postace ai passo a passo onde estamos enganado blz
    e agradeço por tudo que for colocar aqui...

  12. #12
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Ultima Tentativa

    Pessoal ñ digo enganar por usarem o proxy full............
    O que digo enganar seria fazer um QOS dos pacotes com destino os sites que medem velocidade.
    Alguem entendeu o que estou querendo dizer......... gente olha as regras q ele postou.



  13. #13

    Padrão analizar...

    Este proxyfull esta file para ambas configuraçoes ou verçoes.


    / ip firewall mangle
    add chain=output action=mark-connection new-connection-mark=superproxy passthrough=yes src-port=3128 protocol=tcp comment="SUPER-PROXY" disabled=no
    add chain=output action=mark-packet new-packet-mark=superproxy passthrough=yes connection-mark=superproxy comment="" disabled=no
    add chain=output action=return connection-mark=superproxy comment="" disabled=no


    /queue simple
    add name="SUPER-PROXY" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=superproxy direction=both priority=8 \
    queue=default/default limit-at=0/0 max-limit=0/0 total-queue=default-small disabled=no

    / ip firewall nat
    add chain=dstnat dst-port=80 action=redirect to-ports=3128 comment="PROXY REDIRECTION" disabled=no



    Segunda opção



    MK 2.9.xx
    /ip firewall mangle
    add action=mark connection chain=output coment=X-Cache: Hit disable=no new-connection-mark=squid_hit passthrough=yes protocol=tcp src-port=3128
    add action=mark packet chain=output connection-mark=cache_hit disable=no new-packet-mark=cache full passthrough=yes

    /ip queue tree

    name=Squid parent=global-out packet-mark=cachefull queue-type=ethernet-default Priorit=8



    MK 3.x
    /ip firewall mangle
    add action=mark-connection chain=output content=!X-Cache:HIT disabled=no new-connection-mark=cache_hit passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output connection-mark=cache_hit disabled=no new-packet-mark=cachefull passthrough=no

    /ip queue tree

    name=squid parent=global-out packet-mark=cachefull queue type=ethernet-default Priorit=8
    Última edição por djjean2006; 22-04-2008 às 21:09.