Use a última versão do MK 3.7 , que aceita Sata.