+ Responder ao Tópico



  1. #1

    Padrão Duvida Web-Proxy

    Oi galera, desculpa se estiver fazendo uma pergunta muito besta ou se nao for no lugar correto, mas eu já procurei em "todo" lugar no forum e nao achei a minha duvida ainda. Vamos lah entaum. É o seguinte, quando se configura os web-proxys ne cada cliente vc tem que ativar o proxy lah na aba ferramentas e talz???

    Ou tem como fazer o redirecionamento de tal forma que todos os pedidos da porta 80 redirecione automaticamente no MK e devolva para os clientes sem ter que fazer essas mudancas nas estações clientes???

    Se tiver como tem jeito de alguem posta ai as configs??? Ou eh akele tutorial mesmo de icoslau????

    Grato!!!

  2. #2
    davys
    Visitante

    Padrão

    Amigo esta faltando mais dados qual sistema vc usa ? se for no mkt vc configura na ip - web-proxy na porta 8080 ou outra e no ip -firewall vc redireciona o trafeco da porta 80 pra porta 8080
    no new terminal no mkt vc cola o comando :
    ;;; Regra de redirecionamento pro proxy
    chain=dstnat in-interface=lan protocol=tcp dst-port=80 action=redirect
    to-ports=8080



  3. #3

    Padrão

    Citação Postado originalmente por davys Ver Post
    Amigo esta faltando mais dados qual sistema vc usa ? se for no mkt vc configura na ip - web-proxy na porta 8080 ou outra e no ip -firewall vc redireciona o trafeco da porta 80 pra porta 8080
    no new terminal no mkt vc cola o comando :
    ;;; Regra de redirecionamento pro proxy
    chain=dstnat in-interface=lan protocol=tcp dst-port=80 action=redirect
    to-ports=8080
    Obrigado amigo, eu uso o Mk 2.9.27 a famosa versao 27....rsrsrrs..

    Certo amigo vou testar essas configs que vc me falou, agora eu vou ter que colocar em todos os clientes( Maquinas) as configurações de PROXY tipow, no internet explorer, mozila e nos programas que utilizam da internet???

    E mais uma ultima pergunta, pra fazer o cache-ful funcionar tenho que montar regras aonde??? ( No firewall, nat, queue e web-proxy apenas??? ou tem mais lugar pra ir??? )

    Grato.

  4. #4
    davys
    Visitante

    Smile

    A minha versao e a 2.927 e uso o proxy blz ele e transparente nao precisa colocar nada nao ! so que no nat vc vai ter que fazer algumas regras por exemplo site da caixa pra passar direto pelo proxy se nao da pau !!!

    Sobre o cache full nao sei dizer eu fiz um cache normal aqui nas config do ip -web-proxy e esta dando um ganho de 20 %



  5. #5

    Padrão

    Citação Postado originalmente por davys Ver Post
    A minha versao e a 2.927 e uso o proxy blz ele e transparente nao precisa colocar nada nao ! so que no nat vc vai ter que fazer algumas regras por exemplo site da caixa pra passar direto pelo proxy se nao da pau !!!

    Sobre o cache full nao sei dizer eu fiz um cache normal aqui nas config do ip -web-proxy e esta dando um ganho de 20 %
    Hum, certo entendo, essa regra que vc vez ajudou para navegacao de sites??? eu soh quero que me ajude nessa hora, pois ne download de programa entre outras coisas tah ne uma velocidade boa, 23kbps ate 40kbps por cliente.

    Será que teria como vc me passar sua regra??? pra ver se consigo adaptar com a minha rede???

    Grato.

    Obrigado pela ajuda.

  6. #6

    Padrão

    Citação Postado originalmente por davys Ver Post
    A minha versao e a 2.927 e uso o proxy blz ele e transparente nao precisa colocar nada nao ! so que no nat vc vai ter que fazer algumas regras por exemplo site da caixa pra passar direto pelo proxy se nao da pau !!!

    Sobre o cache full nao sei dizer eu fiz um cache normal aqui nas config do ip -web-proxy e esta dando um ganho de 20 %
    Galera o Cache FULL, peguei as regras no Video do Alexandre Jeronimo Correa, excelente configuração, mas o mesmo antes d configurado, o bom deve ser feito numa maquina boa. segue ai o link de onde eu peguei... Onda Internet - Tutorial Mikrotik - Webproxy+cache-Full

    Creditos dele, peguei num post, so nao lembro onde.



  7. #7

    Padrão

    Obrigado AKA2005, eu tbm jah tinha visto esse post, mesmo assim obrigado, a minha duvida eh quais regras que tenho que ativar, tipow a regra do proxy transparente mesmo ele nao mostra criando ela, ou mostra???
    Entao eu gostaria de quais as ordens das regras que tenho que fazer para deixa o web-proxy funcionando com cache-full e talz.
    Desculpa por qlquer coisa, eh que eu sou iniciante no MK.


    Grato.

  8. #8

    Padrão

    Citação Postado originalmente por maverickv12 Ver Post
    Obrigado AKA2005, eu tbm jah tinha visto esse post, mesmo assim obrigado, a minha duvida eh quais regras que tenho que ativar, tipow a regra do proxy transparente mesmo ele nao mostra criando ela, ou mostra???
    Entao eu gostaria de quais as ordens das regras que tenho que fazer para deixa o web-proxy funcionando com cache-full e talz.
    Desculpa por qlquer coisa, eh que eu sou iniciante no MK.


    Grato.
    Sem problema amigo, tbm tive e tenho muitas duvidas, e aki no forum soluciono a maioria... bom o Cache, se seguindo a dica do nosso amigo Alexandre blz, agora o proxy, to testando aki e o q axei foi esse aqui... Tutoriais/Wireless/guia-passoa-passo-mikrotik - UnderLinux Wiki e ate agora nao deu problema pra mim.



  9. #9

    Padrão

    Citação Postado originalmente por aka2005 Ver Post
    Sem problema amigo, tbm tive e tenho muitas duvidas, e aki no forum soluciono a maioria... bom o Cache, se seguindo a dica do nosso amigo Alexandre blz, agora o proxy, to testando aki e o q axei foi esse aqui... Tutoriais/Wireless/guia-passoa-passo-mikrotik - UnderLinux Wiki e ate agora nao deu problema pra mim.

    Obrigado amigo, vou testar esse tuto que vc me passou, e posto aki o resultado.

    Grato

    T+

  10. #10

    Padrão

    Oi galera....testei as regras do alexandre, akelas do video que parecem ser mto boas, porem nao toh conseguin do fazer funcionar.....parece que nao estou conseguindo armazenar os caches, será que alguem poderia me ajudar.

    Minhas regras sao:

    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy" \
    transparent-proxy=yes parent-proxy=0.0.0.0:0 \
    cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \
    max-cache-size=100000KiB max-ram-cache-size=128000KiB
    / ip web-proxy access
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
    disabled=no
    / ip web-proxy cache
    add url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" \
    disabled=no

    / ip firewall mangle
    add chain=prerouting p2p=all-p2p action=mark-connection new-connection-mark=p2p_conn passthrough=yes comment="P2P \
    CONTROLE
    " disabled=no
    add chain=prerouting connection-mark=p2p_conn action=mark-packet new-packet-mark=p2p passthrough=yes comment="" \
    disabled=no
    add chain=output protocol=tcp src-port=3128 content=X-Cache:HIT action=mark-connection \
    new-connection-mark=squid-connection-HIT passthrough=yes comment="Web-Proxy - FULL" disabled=no
    add chain=output connection-mark=squid-connection-HIT action=mark-packet new-packet-mark=squid-packet-HIT passthrough=yes \
    comment="" disabled=no
    / ip firewall nat
    add chain=srcnat out-interface=ether2 action=masquerade comment="NAT" disabled=no
    / ip firewall connection tracking
    set enabled=yes tcp-syn-sent-timeout=5s tcp-syn-received-timeout=5s tcp-established-timeout=1d tcp-fin-wait-timeout=10s \
    tcp-close-wait-timeout=10s tcp-last-ack-timeout=10s tcp-time-wait-timeout=10s tcp-close-timeout=10s udp-timeout=10s \
    udp-stream-timeout=3m icmp-timeout=10s generic-timeout=10m tcp-syncookie=no
    / ip firewall service-port
    set ftp ports=21 disabled=no
    set tftp ports=69 disabled=no
    set irc ports=6667 disabled=no
    set h323 disabled=yes
    set quake3 disabled=no
    set gre disabled=yes
    set pptp disabled=yes

    Alguem sabe e poderia me ajudar no que estou errando??

    Desde jah agradeco...

    Abraco!!!



  11. #11

    Padrão

    Só uma observação:

    Primeiro vc deve colocar seu web-proxy pra funcionar perfeito com todas as configurações e regras corretas, feito isso, e só depois disso, vc deve se preocupar em deixá-lo "FULL" seguindo o vídeo do Alexandre.
    Espero q a dica lhe ajude !
    Abçs,

  12. #12

    Padrão

    Ajudou sim, mas como posso fazer pro Web-Proxy funcionar direitinho e como sei se estar funcionando direito????


    Grato, desde já!!!



  13. #13

    Padrão Finish

    Obrigado a todos do forum under-linux, consegui fazer o web-proxy funcionar.

    Quem estiver com o mesmo problema, a solução foi o seguinte, tive que colocar o servidor DNS pra funcionar sem ele nao estava funcionando o proxy e nem o proxy-full.

    Se alguem tiver alguma dúvida é só postar que ajudarei.

    Obs: Utilizei o MK 2.9.27

    Grato a todos!!!

  14. #14
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    Você está falando do /IP/DNS/ , ai você add um dns local e isso?



  15. #15

    Padrão

    Citação Postado originalmente por angelangra Ver Post
    Você está falando do /IP/DNS/ , ai você add um dns local e isso?

    Sim, isso mesmo, foi lah que tive que colocar o dns pro web-proxy funcionar, será que teria como deixar sem o servidor dns ativo e web-proxy funcionar normalmente???

    Obs: Não uso DHCP, todos os clientes teem IP FIXO.

    Grato!!!
    Última edição por maverickv12; 27-05-2008 às 09:20.

  16. #16
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    Só 1 comentário Básico:

    " max-ram-cache-size=128000KiB "

    Troque por:

    " max-ram-cache-size=0KiB "

    ou por :

    " max-ram-cache-size=none "

    Siga o que estou te falando
    2 anos usando Mikrotik como webproxy, há poucos que to migrando pro Debian + Squid TProxy.



  17. #17

    Padrão

    Citação Postado originalmente por luizbe Ver Post
    Só 1 comentário Básico:

    " max-ram-cache-size=128000KiB "

    Troque por:

    " max-ram-cache-size=0KiB "

    ou por :

    " max-ram-cache-size=none "

    Siga o que estou te falando
    2 anos usando Mikrotik como webproxy, há poucos que to migrando pro Debian + Squid TProxy.

    Obrigado, vou testar mas da outra fez que fiz isso o ram cache size fica a 2048Kb, não consigo colocar mais mesmo especificando a 128mb nao pega, nao sei prq, alguem poderia me ajudar???

    Agradeço desde já!

  18. #18
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    primeiro você tem que dar um Disable / Stop no proxy,

    colocar a configuração da ram, e depois apertar Apply! e depois iniciar o serviço!

    Att.



  19. #19

    Padrão

    Citação Postado originalmente por luizbe Ver Post
    primeiro você tem que dar um Disable / Stop no proxy,

    colocar a configuração da ram, e depois apertar Apply! e depois iniciar o serviço!

    Att.

    Obrigado luizbe, eu estava fazendo isso mas mesmo assim estava deixando apenas 2048kb mas descobrir o que era o problema, troquei a memoria de 256mb que tinha antes por 1Gb e agora tah funcionando tudo belezinha. rsrsrs

    Obrigado a vc e todos as pessoas aqui do forum.

    Esse forum é excelente continuem assim galera!!!

    Abrass 4 all