+ Responder ao Tópico



  1. #1

    Thumbs up Codigo load balance com Marcação de pacotes !

    Pessoal, eu sou meio leigo ainda em relação ao MK mas, tenho um script pronto , deixarei ele com algums parenteses para guiar melhor aonde voces deveram modificar de acordo com as configurações de seus respectivos MK. COPIEM PARA O BLOCO DE NOTAS PARA UMA MELHOR VISUALIZAÇÃO,SÓ APAGUEM O QUE ESTÁ ENTRE PARENTESES.

    se houver algum erro por favor postem para um melhor funcionamento.
    ====================================================

    (NO IN-INTERFACE PONHA O NOME DO DA SAIDA PARA CLIENTES)
    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    (NO TO-ADDRESSES PONHA O ENDEREÇO PONHA O Nº DO IP DA SUA SAIDA PARA CLIENTES)
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="outro" disabled=no

    (NA GATEWAY PONHA O ENDEREÇO DOS LINKS DE SUA INTERNET.) ("NOTA = O "COMMENT" VOCE PODE POR O NOME DO MODEM OU O QUAL DESEJAR")
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 routing-mark=odd comment="GW Planet" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.15.30.254 scope=255 target-scope=10 routing-mark=even comment="GW SpeedStream" disabled=no

    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 comment="Link Principal" disabled=yes

    (SE TIVER UMA REGRA NAT CRIADO DESABILITE-O EM CASO DE MAL FUNCIONAMENTO)
    Última edição por magrock; 14-05-2008 às 17:31. Razão: troca do titulo

  2. #2

    Padrão

    Magrock, essa é a minha solução que procuro a algum tempo. MAs no meu caso o mangle não está sendo criado da forma que vc postou, uso o mikrotik versão 3.2, e no parametro nth ele só aceita 1,0 e 1,1, não aceita 1,1,0, no caso criei um com 1,0 e o segundo 1,1. Só que ele só marca o 1,0, não chega a marcar o segundo pacote, portanto ele não faz o balanceamento.. toda a carga cai em um único link e o outro fica zerado.
    Veja como ficou meu script:

    / ip firewall mangle
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="LB Odd" \
    connection-state=new disabled=yes in-interface=clientes \
    new-connection-mark=odd nth=1,0 passthrough=yes
    add action=mark-routing chain=prerouting comment="Odd LB" connection-mark=odd \
    disabled=yes in-interface=clientes new-routing-mark=odd passthrough=no
    add action=mark-connection chain=prerouting comment="LB Even" \
    connection-state=new disabled=yes in-interface=clientes \
    new-connection-mark=even nth=1,1 passthrough=yes
    add action=mark-routing chain=prerouting comment="Even LB" \
    connection-mark=even disabled=yes in-interface=clientes \
    new-routing-mark=even passthrough=no

    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules \
    here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=50.10.10.0/24
    add action=src-nat chain=srcnat comment="LB Redirect odd" connection-mark=odd \
    disabled=yes nth=0,0 to-addresses=201.48.16.198 to-ports=0-65535
    add action=src-nat chain=srcnat comment="LB Redirect even" \
    connection-mark=even disabled=yes to-addresses=192.168.254.254 \
    to-ports=0-65535

    /ip route
    add comment="LB Route Odd" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 routing-mark=odd scope=255 target-scope=10
    add comment="LB Route Odd" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=192.168.254.254 routing-mark=even scope=255 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 scope=255 target-scope=10
    add comment="LB Route No Mark" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 scope=255 target-scope=10



    Citação Postado originalmente por magrock Ver Post
    Pessoal, eu sou meio leigo ainda em relação ao MK mas, tenho um script pronto , deixarei ele com algums parenteses para guiar melhor aonde voces deveram modificar de acordo com as configurações de seus respectivos MK. COPIEM PARA O BLOCO DE NOTAS PARA UMA MELHOR VISUALIZAÇÃO,SÓ APAGUEM O QUE ESTÁ ENTRE PARENTESES.

    se houver algum erro por favor postem para um melhor funcionamento.
    ====================================================

    (NO IN-INTERFACE PONHA O NOME DO DA SAIDA PARA CLIENTES)
    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    (NO TO-ADDRESSES PONHA O ENDEREÇO PONHA O Nº DO IP DA SUA SAIDA PARA CLIENTES)
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="outro" disabled=no

    (NA GATEWAY PONHA O ENDEREÇO DOS LINKS DE SUA INTERNET.) ("NOTA = O "COMMENT" VOCE PODE POR O NOME DO MODEM OU O QUAL DESEJAR")
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 routing-mark=odd comment="GW Planet" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.15.30.254 scope=255 target-scope=10 routing-mark=even comment="GW SpeedStream" disabled=no

    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 comment="Link Principal" disabled=yes

    (SE TIVER UMA REGRA NAT CRIADO DESABILITE-O EM CASO DE MAL FUNCIONAMENTO)
    Última edição por dougdoidao; 28-05-2008 às 17:45. Razão: inclusão de scripts



  3. #3

    Padrão Balanceamento

    Amigo eu tentei fazer o balanceamento que vc passo a baixo e parece que deu certo, mais vamos supor que um dos links caia o outro assumi a rede?


    E outra coisa como que eu sei que está funcionando tem alguma lugar para olhar e saber se está funcionando ou não???


    Desde já agradeço té mais....





    Citação Postado originalmente por magrock Ver Post
    Pessoal, eu sou meio leigo ainda em relação ao MK mas, tenho um script pronto , deixarei ele com algums parenteses para guiar melhor aonde voces deveram modificar de acordo com as configurações de seus respectivos MK. COPIEM PARA O BLOCO DE NOTAS PARA UMA MELHOR VISUALIZAÇÃO,SÓ APAGUEM O QUE ESTÁ ENTRE PARENTESES.

    se houver algum erro por favor postem para um melhor funcionamento.
    ====================================================

    (NO IN-INTERFACE PONHA O NOME DO DA SAIDA PARA CLIENTES)
    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    (NO TO-ADDRESSES PONHA O ENDEREÇO PONHA O Nº DO IP DA SUA SAIDA PARA CLIENTES)
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="outro" disabled=no

    (NA GATEWAY PONHA O ENDEREÇO DOS LINKS DE SUA INTERNET.) ("NOTA = O "COMMENT" VOCE PODE POR O NOME DO MODEM OU O QUAL DESEJAR")
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 routing-mark=odd comment="GW Planet" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.15.30.254 scope=255 target-scope=10 routing-mark=even comment="GW SpeedStream" disabled=no

    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 comment="Link Principal" disabled=yes

    (SE TIVER UMA REGRA NAT CRIADO DESABILITE-O EM CASO DE MAL FUNCIONAMENTO)

  4. #4

    Padrão

    O Load Balance por nth requer muito conhecimento e dedicação para deixá-lo rodando tudo certim. Você terá que criar excessões nas regras pra Bancos, etc.
    Faça por rotas estaticas, tipo:
    link 01 default
    link 02 msn, orkut, etc...
    e monte o script de monitoramento pra quando um cair o outro assumir e vice versa.



  5. #5

    Padrão sofrendo pra fazer o balance

    Citação Postado originalmente por rps67 Ver Post
    O Load Balance por nth requer muito conhecimento e dedicação para deixá-lo rodando tudo certim. Você terá que criar excessões nas regras pra Bancos, etc.
    Faça por rotas estaticas, tipo:
    link 01 default
    link 02 msn, orkut, etc...
    e monte o script de monitoramento pra quando um cair o outro assumir e vice versa.

    amigo, to tentando fazer um load balance com 2 ADSL, achei interessante como você falou sobre link 01 default e 02 man, orkut, etc....

    como faço isso? tens algum link que eu possa ver os scripts???

  6. #6

    Padrão

    meu amigo não qubre a cabeça com relação a esse script, vai uma dica que eu aderi e gostei muito
    procure informações sobre um aparelho da marca D-LINK DI-LB604 ele sim faz balanceamento de carga, trabalho como redundante e soma seu link sem nenhuma preocupação, esse script que eu criei só deu dor de cabeça na minha rede, pois ela tem 160 usuarios, nos dias de pico ficam 120 conectados, e o msn trava totalmente, impedindo que voce envie a sua mensagem ao destinatario, esse aparelho eu aderi e aprovo, facil configuração e não da dor de cabeça aqui no RJ custou 250,00 mas no mercado livre é até mais barato procure saber mais..
    fica ai a dica mas se voce optar pelo MK não discordo de voce pois ele é poderoso, mas como eu sou leigo sobre ele ai fica dificil eu uso esse aparelho junto ao MK sem nenhum problema qualquer coisa ta ai meu msn:[email protected]
    abraços



  7. #7

    Wink Balanceamento

    Citação Postado originalmente por rps67 Ver Post
    O Load Balance por nth requer muito conhecimento e dedicação para deixá-lo rodando tudo certim. Você terá que criar excessões nas regras pra Bancos, etc.
    Faça por rotas estaticas, tipo:
    link 01 default
    link 02 msn, orkut, etc...
    e monte o script de monitoramento pra quando um cair o outro assumir e vice versa.


    Blz mais tem como vc me passar como eu faço, desculpe a minha ingnorancia é que so novo na area de linux e não conheço muito bem o Mikrotik, este é o meu primeiro sevidor de internet com o mikrotik e por isso pesso que se tiver como vc me passar um passo a passo para que eu possa entender os procedimentos a serem tomados eu agradeço, olha lendo alguns topicos do site eu vi algo sobre Bonding, vc conhece sabe se ele funciona ou como configura etc....

    Desde já agradeço....

  8. #8

    Padrão Balanceamento não funciona

    Citação Postado originalmente por magrock Ver Post
    Pessoal, eu sou meio leigo ainda em relação ao MK mas, tenho um script pronto , deixarei ele com algums parenteses para guiar melhor aonde voces deveram modificar de acordo com as configurações de seus respectivos MK. COPIEM PARA O BLOCO DE NOTAS PARA UMA MELHOR VISUALIZAÇÃO,SÓ APAGUEM O QUE ESTÁ ENTRE PARENTESES.

    se houver algum erro por favor postem para um melhor funcionamento.
    ====================================================

    (NO IN-INTERFACE PONHA O NOME DO DA SAIDA PARA CLIENTES)
    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    (NO TO-ADDRESSES PONHA O ENDEREÇO PONHA O Nº DO IP DA SUA SAIDA PARA CLIENTES)
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="outro" disabled=no

    (NA GATEWAY PONHA O ENDEREÇO DOS LINKS DE SUA INTERNET.) ("NOTA = O "COMMENT" VOCE PODE POR O NOME DO MODEM OU O QUAL DESEJAR")
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 routing-mark=odd comment="GW Planet" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.15.30.254 scope=255 target-scope=10 routing-mark=even comment="GW SpeedStream" disabled=no

    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 comment="Link Principal" disabled=yes

    (SE TIVER UMA REGRA NAT CRIADO DESABILITE-O EM CASO DE MAL FUNCIONAMENTO)

    Amigo, ja botou esse script pra funcionar? Basta só esses escripts pra funcionar normalmente? É que pus esse escript no meu server, "mudando os ips claro" e mesmo assim não funcionou, mudei também o nome da interface, mas também não funciona, tem que ver a posição deles nas regras do nat? coomo é que coloca o ip la no nat TO ADRESS ???? Acho que to me batendo aí



  9. #9

    Padrão

    Citação Postado originalmente por magrock Ver Post
    meu amigo não qubre a cabeça com relação a esse script, vai uma dica que eu aderi e gostei muito
    procure informações sobre um aparelho da marca D-LINK DI-LB604 ele sim faz balanceamento de carga, trabalho como redundante e soma seu link sem nenhuma preocupação, esse script que eu criei só deu dor de cabeça na minha rede, pois ela tem 160 usuarios, nos dias de pico ficam 120 conectados, e o msn trava totalmente, impedindo que voce envie a sua mensagem ao destinatario, esse aparelho eu aderi e aprovo, facil configuração e não da dor de cabeça aqui no RJ custou 250,00 mas no mercado livre é até mais barato procure saber mais..
    fica ai a dica mas se voce optar pelo MK não discordo de voce pois ele é poderoso, mas como eu sou leigo sobre ele ai fica dificil eu uso esse aparelho junto ao MK sem nenhum problema qualquer coisa ta ai meu msn:[email protected]
    abraços

    Amigo, jah usei um Load Balance da Planet com 5 WAN e era uma maravilha no inicio mas depois só me deu dor de cabeça travava minha rede e eu naum sabia o motivo ! Depois disso se for usar algo do genero só com produto da CISco pq eu sei que eh robusto e eh feito pra uma demanda alta de requisições !

  10. #10
    Moderador Avatar de ederamboni
    Ingresso
    Oct 2004
    Localização
    Montes Claros
    Posts
    880
    Posts de Blog
    13

    Padrão

    tbm tive problema com esse aparelho... 6 meses apos implanta-lo comecou a travar...



  11. #11

    Exclamation Caros Leitores

    Não me levem a mal, a minha rede tem 160, usuarios e cabeada (Não tenho Wireless) sendo que 98% só utilizam para msn,orkut e videozinho no youtube este aparelho para mim está bom demais, a respeito do script acima no meu server funcionou sim mas tive uma baita dor de cabeça a respeito ao msn pois ele retornava as mensagens enviadas, postei no forum o meu problema e ninguem me deu ao menos uma luz (era só o que eu nescecitava) e outra se o script não rodar assim alteradas as confs. remova a regra nat antiga e crie outra apos o script adicionado pode ser uma regra nat basica, agora Mikrotik foi uma experiencia de orelhada que eu gostei, adquiri, aprovei e estudei seu livro até mais da metade de seus capitulos, se eu estiver no forum errado me desculpem .sendo que mais da metade aqui no forum vem atrás de respostas faceis, mastigadas e prontas para serem emplementadas a seus servers, bem ao menos estou sendo sincero a todos que venham ver o meu post, se quiserem perguntar mais alguma coisa estou a disposição. SEM OFENSAS A NINGUEM AQUI NO FORUM, OK...OBRIGADO A TODOS PELA COMPREENSÃO..
    " PROFISSIONAIS CONSTRUÍRAM TITANIC, AMADORES CONSTRUÍRAM A ARCA DE NOÉ "
    Última edição por magrock; 06-08-2008 às 05:23.

  12. #12

    Lightbulb

    Citação Postado originalmente por sandrohacker Ver Post
    Amigo eu tentei fazer o balanceamento que vc passo a baixo e parece que deu certo, mais vamos supor que um dos links caia o outro assumi a rede?


    E outra coisa como que eu sei que está funcionando tem alguma lugar para olhar e saber se está funcionando ou não???


    Desde já agradeço té mais....
    AMIGO em casos de um link cair e o outro segurar tem um lance do Fail-over



  13. #13

    Lightbulb

    Citação Postado originalmente por sandrohacker Ver Post
    Blz mais tem como vc me passar como eu faço, desculpe a minha ingnorancia é que so novo na area de linux e não conheço muito bem o Mikrotik, este é o meu primeiro sevidor de internet com o mikrotik e por isso pesso que se tiver como vc me passar um passo a passo para que eu possa entender os procedimentos a serem tomados eu agradeço, olha lendo alguns topicos do site eu vi algo sobre Bonding, vc conhece sabe se ele funciona ou como configura etc....

    Desde já agradeço....
    sobre BONDING eu não entendo muito não cara mas se voce souber mexer um pouco com mikrotik me add no msn que eu posso te passar um passo a passoe eu tambem não sou lá grandes cranio em relação a mk não cara mas eu faço o que posso o que não dá agente inventa, certo grande abraço

  14. #14

    Lightbulb

    Citação Postado originalmente por socrates10 Ver Post
    Amigo, ja botou esse script pra funcionar? Basta só esses escripts pra funcionar normalmente? É que pus esse escript no meu server, "mudando os ips claro" e mesmo assim não funcionou, mudei também o nome da interface, mas também não funciona, tem que ver a posição deles nas regras do nat? coomo é que coloca o ip la no nat TO ADRESS ???? Acho que to me batendo aí
    sim jah coloquei sim mas deu um certo problema com msn ele retornava as mensagens enviadas, agora vou deixar aqui o que voce tem que mudar em vermelho para a sua interface para clientes
    ===============================================================================

    / ip firewall mangle
    add chain=prerouting in-interface=
    Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface=
    Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=
    Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=
    Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    ====================================================================================
    .::Altere o que está em VERMELHO para o IP da sua placa de Saida para clientes::.

    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=
    10.80.1.254 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=
    10.80.1.254 to-ports=0-65535 comment="" disabled=no
    =====================================================================================
    .::Altere o que está em VERMELHO para o IP do seu LINK COM A INTERNET::. Obs:EM "COMENT" ENTRE AS ASPAS VOCE PODE ALTERAR PARA SEUS DEVIDOS GATEWAYS,NÃO APAGANDO AS ASPAS...

    / ip route
    add dst-address=0.0.0.0/0 gateway=
    10.15.40.254 scope=255 target-scope=10 routing-mark=odd comment="GW Planet" disabled=no
    add dst-address=0.0.0.0/0 gateway=
    10.15.30.254 scope=255 target-scope=10 routing-mark=even comment="GW SpeedStream" disabled=no

    add dst-address=0.0.0.0/0 gateway=
    10.15.40.254 scope=255 target-scope=10 comment="Link Principal" disabled=yes
    =========================================================================================

    AGORA VÁ NO WINBOX E ABRA A OPÇÃO "NEW TERMINAL" E COPIE DA ORDEM QUE ESTÁ AI DESCRITA ACIMA COM AS SUAS DEVIDAS ALTERAÇÕES, DESABILITE A NAT ANTIGA E CRIE UMA NOVA FEITO ISSO VÁ EM IP ==>ROUTE E DESABILITE O GATEWAY ANTIGO, FEITO ISSO TEM TUDO A DAR CERTO
    QUALQUER COISA ADD NO MSN:[email protected]



  15. #15

    Padrão

    Amigo,parabéns pela script,eu aqui tenho um link dedicado de ip fixo e um adsl dinamico,como faço aqui,agradeço pela atenção.




    Citação Postado originalmente por magrock Ver Post
    sim jah coloquei sim mas deu um certo problema com msn ele retornava as mensagens
    enviadas, agora vou deixar aqui o que voce tem que mudar em vermelho para a sua interface para clientes
    ===============================================================================

    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface=
    Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=
    Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=
    Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    ====================================================================================
    .::Altere o que está em VERMELHO para o IP da sua placa de Saida para clientes::.

    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=
    10.80.1.254 to-ports=0-65535 comment="" disabled=no
    =====================================================================================
    .::Altere o que está em VERMELHO para o IP do seu LINK COM A INTERNET::. Obs:EM "COMENT" ENTRE AS ASPAS VOCE PODE ALTERAR PARA SEUS DEVIDOS GATEWAYS,NÃO APAGANDO AS ASPAS...

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 routing-mark=odd comment="GW Planet" disabled=no
    add dst-address=0.0.0.0/0 gateway=
    10.15.30.254 scope=255 target-scope=10 routing-mark=even comment="GW SpeedStream" disabled=no

    add dst-address=0.0.0.0/0 gateway=
    10.15.40.254 scope=255 target-scope=10 comment="Link Principal" disabled=yes
    =========================================================================================

    AGORA VÁ NO WINBOX E ABRA A OPÇÃO "NEW TERMINAL" E COPIE DA ORDEM QUE ESTÁ AI DESCRITA ACIMA COM AS SUAS DEVIDAS ALTERAÇÕES, DESABILITE A NAT ANTIGA E CRIE UMA NOVA FEITO ISSO VÁ EM IP ==>ROUTE E DESABILITE O GATEWAY ANTIGO, FEITO ISSO TEM TUDO A DAR CERTO
    QUALQUER COISA ADD NO MSN:[email protected]