+ Responder ao Tópico



  1. #25

    Padrão

    Djjean2006, essa é a minha solução que procuro a algum tempo. MAs no meu caso o mangle não está sendo criado da forma que vc postou, uso o mikrotik versão 3.2, e no parametro nth ele só aceita 1,0 e 1,1, não aceita 1,1,0, no caso criei um com 1,0 e o segundo 1,1. Só que ele só marca o 1,0, não chega a marcar o segundo pacote, portanto ele não faz o balanceamento.. toda a carga cai em um único link e o outro fica zerado. Segue o meu script

    / ip firewall mangle
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="LB Odd" \
    connection-state=new disabled=yes in-interface=clientes \
    new-connection-mark=odd nth=1,0 passthrough=yes
    add action=mark-routing chain=prerouting comment="Odd LB" connection-mark=odd \
    disabled=yes in-interface=clientes new-routing-mark=odd passthrough=no
    add action=mark-connection chain=prerouting comment="LB Even" \
    connection-state=new disabled=yes in-interface=clientes \
    new-connection-mark=even nth=1,1 passthrough=yes
    add action=mark-routing chain=prerouting comment="Even LB" \
    connection-mark=even disabled=yes in-interface=clientes \
    new-routing-mark=even passthrough=no

    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules \
    here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=50.10.10.0/24
    add action=src-nat chain=srcnat comment="LB Redirect odd" connection-mark=odd \
    disabled=yes nth=0,0 to-addresses=201.48.16.198 to-ports=0-65535
    add action=src-nat chain=srcnat comment="LB Redirect even" \
    connection-mark=even disabled=yes to-addresses=192.168.254.254 \
    to-ports=0-65535

    /ip route
    add comment="LB Route Odd" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 routing-mark=odd scope=255 target-scope=10
    add comment="LB Route Odd" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=192.168.254.254 routing-mark=even scope=255 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 scope=255 target-scope=10
    add comment="LB Route No Mark" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 scope=255 target-scope=10

    Citação Postado originalmente por djjean2006 Ver Post
    balance de cargas entre os modens para a interface
    cliente que vc vai ter que alterar para sua intreface do ip 10.x.x.x

    / ip firewall mangle
    add chain=prerouting in-interface=clientes connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="LB Odd" disabled=no
    add chain=prerouting in-interface=clientes connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="Odd LB" disabled=no
    add chain=prerouting in-interface=clientes connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="LB Even" disabled=no
    add chain=prerouting in-interface=clientes connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="Even LB" disabled=no


    os links com marcaçã ode pacotes

    / ip firewall nat
    add chain=srcnat connection-mark=even action=src-nat to-addresses=201.88.52.201 to-ports=0-65535 comment="LB Redirect Even" disabled=no
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=192.168.2.1 to-ports=0-65535 comment="LB Redirect Odd" disabled=no


    as rotas e o modem patrão é o de 8 megas

    / ip route
    add dst-address=0.0.0.0/0 gateway=201.88.52.201 scope=255 target-scope=10 routing-mark=even comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=odd comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 comment="LB Route No Mark" disabled=no



    aqui estou colocando o link que vc pediu para o dns que vai para o link do ip 201.x.x.x

    / ip route
    add dst-address=0.0.0.0/0 gateway=201.88.52.201 scope=255 target-scope=10 routing-mark=DNS comment="Market packets redirect to port DNS" disabled=no



    aqui esta a marcação de pacotes dele para vc acompanhar tudo


    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=53 action=mark-routing new-routing-mark=DNS passthrough=yes in-interface=clientes comment="Redirect port to DNS" disabled=no
    add chain=prerouting routing-mark=DNS action=mark-packet new-packet-mark=DNS passthrough=yes comment="Market packets to DNS" disabled=no



    se for isso mesmo que eu entendi no seu pedido

    não esquecer de agradecer...
    Última edição por dougdoidao; 28-05-2008 às 16:46. Razão: inclusão de script

  2. #26

    Padrão Ajuda Load 4 ADSL 1 MB

    opa, aproveitando o tópico, tenho algumas dúvidas sobre este caso, ao colocar 4 ADSL os modens devem ficar em modo Router?
    não acontece problemas como queda de msn, site de bancos e casos tipicos de balanceamento mal feito? ja testei um equipament planet e me deu dor de cabeça, estou precisando de uma solução que funcione perfeitamente, e com o servidor configurado em pppoe para o cliente, e DHCP fixando IP pelo mac do cliente...
    se alguem tiver uma solução que funcione sem problemas ja testado em uso deixe sua experiencia



  3. #27

    Padrão

    Citação Postado originalmente por Majorred Ver Post
    opa, aproveitando o tópico, tenho algumas dúvidas sobre este caso, ao colocar 4 ADSL os modens devem ficar em modo Router?
    não acontece problemas como queda de msn, site de bancos e casos tipicos de balanceamento mal feito? ja testei um equipament planet e me deu dor de cabeça, estou precisando de uma solução que funcione perfeitamente, e com o servidor configurado em pppoe para o cliente, e DHCP fixando IP pelo mac do cliente...
    se alguem tiver uma solução que funcione sem problemas ja testado em uso deixe sua experiencia
    Meu loadbalance funciona perfeito...
    3 links... 2mb / 1mb / 1mb
    o primeiro com peso 2 e os outros com peso 1
    ou seja, o primeiro link absorve 50% do trafego e os outros 2 25% cada...
    Não tenho problemas com banco e nem com MSN...
    Os modem estão em modo router...
    Diga o que vc já fez e o que exatamente vc precisa pra gente ajudar...
    Abraços...

  4. #28

    Padrão

    dougdoidão coloque mais estas regras ai para ficar com os dois modens trabalhando.... deve ser isso que vc quer ver hehe


    / ip route
    add dst-address=16.0.0.0/4 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=32.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=64.0.0.0/8 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=65.0.0.0/8 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=66.232.99.0/24 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=64.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=96.0.0.0/8 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="SITES INTERNACIONAIS" disabled=no
    add dst-address=96.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=128.0.0.0/8 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="SITES INTERNACIONAIS" disabled=no
    add dst-address=128.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=170.66.0.0/16 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=189.38.18.122/32 gateway=192.168.1.254 scope=255 \
    target-scope=10 comment="ABUSAR" disabled=no
    add dst-address=160.0.0.0/3 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.0.0.0/24 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=200.101.81.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.128.0.0/16 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.140.120.29/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="MEDIDOR GRATIS" disabled=no
    add dst-address=200.141.254.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.159.128.189/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="RJ NET" disabled=no
    add dst-address=200.184.179.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.199.252.68/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=200.199.252.72/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=200.203.191.8/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.204.154.42/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=200.221.2.45/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.221.2.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.253.251.32/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=201.24.134.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=201.34.35.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=201.38.128.49/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="TESTE LINK2 N REMOVER - Catolica" disabled=no
    add dst-address=201.67.44.177/32 gateway=192.168.1.254 scope=255 \
    target-scope=10 comment="TESTE LINK1 N REMOVER - Catolica" disabled=no
    add dst-address=206.57.4.13/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="MERCADO LIVRE" disabled=no
    add dst-address=207.0.0.0/8 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=208.65.0.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="YOU TUBE" disabled=no
    add dst-address=208.67.0.0/16 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="GOOGLE" disabled=no
    add dst-address=209.0.0.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="ORKUT" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 distance=2 scope=255 \
    target-scope=10 comment="link2" disabled=no


    não esquecer de agradecer isso fica bom para todos



  5. #29

    Padrão

    Citação Postado originalmente por froyer Ver Post
    Meu loadbalance funciona perfeito...
    3 links... 2mb / 1mb / 1mb
    o primeiro com peso 2 e os outros com peso 1
    ou seja, o primeiro link absorve 50% do trafego e os outros 2 25% cada...
    Não tenho problemas com banco e nem com MSN...
    Os modem estão em modo router...
    Diga o que vc já fez e o que exatamente vc precisa pra gente ajudar...
    Abraços...

    Amigo Froyer, eu não tenho load balance aki, mas tenho acompanhado vários posts sobre esse assunto pra poder aprender um pouco mais e testar depois.
    Portanto te pergunto: vc fez utilizando o contador nth ? quais daqueles algarismos definem o peso que devo colocar em tal link ? ( no seu caso deve ter sido: 3,1,0 / 3,1,1 / 3,1,2 / 3,1,3 ? ) ou o peso é conseguindo repetindo a regra de mark-routing ? Por favor ainda não conseguí captar e entender muito bem o mecanismo de funcinamento do nth em função do peso.
    Se puder contribuir com meu estudo, ficaria muito grato.

    Abç,

  6. #30

    Padrão

    Citação Postado originalmente por iron Ver Post
    Amigo Froyer, eu não tenho load balance aki, mas tenho acompanhado vários posts sobre esse assunto pra poder aprender um pouco mais e testar depois.
    Portanto te pergunto: vc fez utilizando o contador nth ? quais daqueles algarismos definem o peso que devo colocar em tal link ? ( no seu caso deve ter sido: 3,1,0 / 3,1,1 / 3,1,2 / 3,1,3 ? ) ou o peso é conseguindo repetindo a regra de mark-routing ? Por favor ainda não conseguí captar e entender muito bem o mecanismo de funcinamento do nth em função do peso.
    Se puder contribuir com meu estudo, ficaria muito grato.

    Abç,
    Exatamente....
    No mangle vc marca cada nova conexão e rota com os contadores 3,1,0 / 3,1,1 / 3,1,2 / 3,1,3....
    No Nat vc faz o seguinte:
    chain=srcnat connection-mark=con310 action=src-nat to-addresses=172.16.1.1 to-ports=0-65535
    chain=srcnat connection-mark=con311 action=src-nat to-addresses=172.16.2.1 to-ports=0-65535
    chain=srcnat connection-mark=con312 action=src-nat to-addresses=172.16.3.1 to-ports=0-65535
    chain=srcnat connection-mark=con313 action=src-nat to-addresses=172.16.3.1 to-ports=0-65535
    Esses endereços ips são os endereços que vc atribuiu para cada interface em que está ligado cada link (no meu caso tenho 3 placas de rede, uma para cada link, mas vc pode tbm ligar os 3 links num hub e ligar em uma interface apenas no mkt loadbalance.. a vantagem de vc ter uma placa para cada link é que vc pode monitorar o consumo de cada link independentemente)
    Observe que os contadores nth 312 e 313 estao apontando para a mesma interface 172.16.3.1 (é aqui e depois no /ip route que ele faz o peso 2)...
    Entendeu?
    Abs