+ Responder ao Tópico



  1. #13

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Este gateway(route) para os pacotes é criado em /ip route.
    Primeiro deve-se marcar os pacotes com destino a porta 80 e na ação colocar um new routing para a mesma, em /ip route criar o gateway.

    Ex:

    /ip firewall mangle add chain=output src-address=192.168.100.0/24 dst-port=80 action=mark-routing new-routing-mark="porta80" passthrough=yes disabled=no comment="marcacao para porta 80"

    /ip route add gateway=192.168.1.1 routing-mark=porta80


    Com isto aí ele marca tudo o que passa pela porta 80 e coloca em um gateway específico, pode ser um link separado ou uma rede criada somente para atender a este serviço, no linux ou mikrotik.

    É isto aí.

    Qualquer coisa...
    rapaz vc me deu a luz que falatava, muito obrigado mesmo é sempre bom achar pessoas que estão disposta a compartilhar conheçimento , mas olha só vi em um outro post, do proprio Jhonne e lá ele usou o termo prerouting. estou na duvida só enquanto a isso, e em chain, escolho output ou prerouting e na classe de ip que vc usou, aqui uso 2 classe de ips pra os clientes, como faço pra que todos passem pela marquação?

    olhe a esplicação dele [https://under-linux.org/forums/mikro...d-linux-2.html[/link]

  2. #14

    Padrão

    [quote=georgegomes;327451]... estou na duvida ...em chain, escolho output ou prerouting e na classe de ip que vc usou, aqui uso 2 classe de ips pra os clientes, como faço pra que todos passem pela marquação?[quote]

    Amigo,
    É prerouting mesmo, foi um erro de digitação. Para que todos os ips passem pela regra é colocar 0.0.0.0/0 ou deixar em branco.

    Obs: faltou informar o protocol=tcp na regra acima.

    /ip firewall mangle add chain=prerouting src-address=0.0.0.0/0 protocol=tcp dst-port=80 action=mark-routing new-routing-mark="porta80" passthrough=yes disabled=no comment="marcacao para porta 80"

    Qualquer coisa...



  3. #15

    Padrão

    [quote=Mr. RG;327456][quote=georgegomes;327451]... estou na duvida ...em chain, escolho output ou prerouting e na classe de ip que vc usou, aqui uso 2 classe de ips pra os clientes, como faço pra que todos passem pela marquação?

    Amigo,
    É prerouting mesmo, foi um erro de digitação. Para que todos os ips passem pela regra é colocar 0.0.0.0/0 ou deixar em branco.

    Obs: faltou informar o protocol=tcp na regra acima.

    /ip firewall mangle add chain=prerouting src-address=0.0.0.0/0 protocol=tcp dst-port=80 action=mark-routing new-routing-mark="porta80" passthrough=yes disabled=no comment="marcacao para porta 80"

    Qualquer coisa...

    Mr. MG pow brother, fiz tudinho como vc me disse e segui tbm o esqueminha do Jhonne, mas não consegui navegar, não sei o que tem de errado?

    mas valews pelas dicas.

  4. #16

    Padrão

    [quote=georgegomes;327598][quote=Mr. RG;327456]
    Citação Postado originalmente por georgegomes Ver Post
    ... estou na duvida ...em chain, escolho output ou prerouting e na classe de ip que vc usou, aqui uso 2 classe de ips pra os clientes, como faço pra que todos passem pela marquação?


    Mr. MG pow brother, fiz tudinho como vc me disse e segui tbm o esqueminha do Jhonne, mas não consegui navegar, não sei o que tem de errado?

    mas valews pelas dicas.
    posta as regras ai, quem sabe agente acha o erro!

    te add no msn confomre mp.



  5. #17

    Padrão

    [quote=JHONNE;327599][quote=georgegomes;327598]
    Citação Postado originalmente por Mr. RG Ver Post

    posta as regras ai, quem sabe agente acha o erro!

    te add no msn confomre mp.
    nos ips ficou assim no MKT
    / ip address
    add address=10.100.100.2/29 network=10.100.100.0 broadcast=10.100.100.7 \
    interface=SQUID comment="IP´s Squid" disabled=no <-- interface 1

    add address=10.200.200.1/30 network=10.200.200.0 broadcast=10.200.200.3 \
    interface=SQUIFOUT comment="" disabled=no <--interface 2

    add address=172.19.100.110/28 network=172.19.100.96 broadcast=172.19.100.111 \
    interface=WAN comment="gateway net" disabled=no

    no mangle :
    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing \
    new-routing-mark="Porat 80" passthrough=yes comment="" disabled=no

    e no route assim :
    ip route
    add dst-address=0.0.0.0/0 gateway=172.19.100.100 scope=255 target-scope=10 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.100.100.1 scope=255 target-scope=10 \
    routing-mark="Porat 80" comment="" disabled=no

    configurei os ips no BFW como está no esquema, cloquei até as placas como vc usa e tudo mais.
    pow amigo se vc puder add mesmo, fico muito grato e pago até se for preciso, estava usando aqui um webproxy do MT, tudo indo bem, mas depois ficou uma merda.

    agradeço muito.

  6. #18

    Padrão

    [quote=georgegomes;327611][quote=JHONNE;327599]
    Citação Postado originalmente por georgegomes Ver Post

    nos ips ficou assim no MKT
    / ip address
    add address=10.100.100.2/29 network=10.100.100.0 broadcast=10.100.100.7 \
    interface=SQUID comment="IP´s Squid" disabled=no <-- interface 1

    add address=10.200.200.1/30 network=10.200.200.0 broadcast=10.200.200.3 \
    interface=SQUIFOUT comment="" disabled=no <--interface 2

    add address=172.19.100.110/28 network=172.19.100.96 broadcast=172.19.100.111 \
    interface=WAN comment="gateway net" disabled=no

    no mangle :
    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing \
    new-routing-mark="Porat 80" passthrough=yes comment="" disabled=no

    e no route assim :
    ip route
    add dst-address=0.0.0.0/0 gateway=172.19.100.100 scope=255 target-scope=10 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.100.100.1 scope=255 target-scope=10 \
    routing-mark="Porat 80" comment="" disabled=no

    configurei os ips no BFW como está no esquema, cloquei até as placas como vc usa e tudo mais.
    pow amigo se vc puder add mesmo, fico muito grato e pago até se for preciso, estava usando aqui um webproxy do MT, tudo indo bem, mas depois ficou uma merda.

    agradeço muito.

    crie a rota marcada primeiro que as outras