+ Responder ao Tópico



  1. [quote=JHONNE;328101][quote=georgegomes;327856]
    Citação Postado originalmente por JHONNE Ver Post

    Cara quanto ao bfw é preciso ter certeza que o transparent proxy do squid está ativado, senão realmente o cache não vai funcionar. Volte ao wizard do bfw e verfique a faixa de ip que vc colocou na rede, desative o dhcp e coloque o ip manualmente mesmo no mk

    aqui etá tudo ok!! transparencia ativada, fazendo cache, quando ligo o notebook no bfw funfa bem ,quando ligo no mkt sem a regra funfa bem dom mesmo jeito, é a questão do redirecionamento que não está funcionando, como disse anteriormente quando ativo a regra, ele para de navegar, quando desligo e ele volta a o normal, porq ai no caso ele usa o gateway do mkt mesmo.

    esquema de ligação ::

    BFW - 10.100.100.1
    Link ---->>> (clientes) 172.246.100.0/24
    Mikrotik - 10.100.100.2

    o bfw tem um ip valido (200.x.x.x) e o miktoik tbm tem um (200.x.x.x)
    o ip que o mikrotik pega do bfw é o 10.100.100.2 com gate 10.100.100.1 no caso o do redirecionamento.
    as regras eztão assim


    /ip firewall mangle add chain=output src-address=172.246.100.0/24 dst-port=80 action=mark-routing new-routing-mark="porta80" passthrough=yes disabled=no comment="marcacao para porta80"


    /ip route add gateway=10.100.100.1 routing-mark=porta80

    no mais é só

    valews ai pela ajuda !!!!!

  2. Citação Postado originalmente por georgegomes Ver Post
    ...

    Olá amigo,
    Dá um print nos routes para ver como tá.

    /ip route print detail



  3. Citação Postado originalmente por Mr. RG Ver Post
    Olá amigo,
    Dá um print nos routes para ver como tá.

    /ip route print detail
    /ip route print detail
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf
    0 ADC dst-address=10.100.100.0/30 pref-src=10.100.100.2 interface=SQUID
    scope=10 target-scope=0

    1 ADC dst-address=172.19.100.0/24 pref-src=172.19.100.100 interface=WAN
    scope=10 target-scope=0

    2 ADC dst-address=172.246.100.0/24 pref-src=172.246.100.100 interface=WLAN-EW
    scope=10 target-scope=0

    3 ADC dst-address=200.165.138.88/29 pref-src=200.165.138.90 interface=WAN
    scope=10 target-scope=0

    4 A S dst-address=0.0.0.0/0 gateway=200.165.138.89 interface=WAN
    gateway-state=reachable scope=255 target-scope=10

    5 A S dst-address=0.0.0.0/0 gateway=10.100.100.1 interface=SQUID
    gateway-state=reachable scope=255 target-scope=10
    routing-mark=Redire_pota_80

  4. Citação Postado originalmente por georgegomes Ver Post
    ...

    4 A S dst-address=0.0.0.0/0 gateway=200.165.138.89 interface=WAN
    gateway-state=reachable scope=255 target-scope=10

    5 A S dst-address=0.0.0.0/0 gateway=10.100.100.1 interface=SQUID
    gateway-state=reachable scope=255 target-scope=10
    routing-mark=Redire_pota_80
    Vejamos desta forma:

    Marcaremos os pacotes para a porta 80 e o que não passarão pela mesma:

    /ip firewall mangle add chain=prerouting src-address=172.100.10.0/24 protocol=tcp dst-port=80 action=mark-routing new-routing-mark=porta80 passthrough=no

    /ip firewall mangle add chain=prerouting src-address=172.100.10.0/24 protocol=tcp dst-port=!80 action=mark-routing new-routing-mark=outra passthrough=no


    Adicionaremos os routes para as marcações:

    /ip route add dst-address=0.0.0.0/32 gateway=172.0.0.1 interface=internet gateway-state=reachable scope=255 target-scope=10 routing-mark=outra

    /ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1 interface=internet gateway-state=reachable scope=255 target-scope=10 routing-mark=porta80


    Troque as faixas de rede.
    Os clientes estão conectados somente no mikrotik ou também no linux?



  5. [quote=georgegomes;328319][quote=JHONNE;328101]
    Citação Postado originalmente por georgegomes Ver Post


    aqui etá tudo ok!! transparencia ativada, fazendo cache, quando ligo o notebook no bfw funfa bem ,quando ligo no mkt sem a regra funfa bem dom mesmo jeito, é a questão do redirecionamento que não está funcionando, como disse anteriormente quando ativo a regra, ele para de navegar, quando desligo e ele volta a o normal, porq ai no caso ele usa o gateway do mkt mesmo.

    esquema de ligação ::

    BFW - 10.100.100.1
    Link ---->>> (clientes) 172.246.100.0/24
    Mikrotik - 10.100.100.2

    o bfw tem um ip valido (200.x.x.x) e o miktoik tbm tem um (200.x.x.x)
    o ip que o mikrotik pega do bfw é o 10.100.100.2 com gate 10.100.100.1 no caso o do redirecionamento.
    as regras eztão assim


    /ip firewall mangle add chain=output src-address=172.246.100.0/24 dst-port=80 action=mark-routing new-routing-mark="porta80" passthrough=yes disabled=no comment="marcacao para porta80"


    /ip route add gateway=10.100.100.1 routing-mark=porta80

    no mais é só

    valews ai pela ajuda !!!!!

    tente colocar a regra de marcan;áo na chain prerouting, porque senão nao vai funcionar, porque seu ip ja estara mascado






Tópicos Similares

  1. Respostas: 1
    Último Post: 15-01-2015, 19:53
  2. RB 433 em paralelo com servidor Mikrotik.
    Por andrebuy no fórum Redes
    Respostas: 0
    Último Post: 17-07-2013, 11:21
  3. Squid em paralelo com o mikrotik qual Cabo Usar crossover ou Normal?
    Por georgegleyson no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-06-2012, 13:29
  4. SpeedR em Paralelo com o Mikrotik e TProxy Ativo
    Por cleciorodrigo no fórum Servidores de Rede
    Respostas: 36
    Último Post: 07-03-2012, 22:31
  5. Proxy em paralelo com Mikrotik
    Por juderlan no fórum Redes
    Respostas: 13
    Último Post: 13-07-2008, 11:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L