Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    Citação Postado originalmente por deson00 Ver Post
    todos eles navegam na faixa de rede 255.255.255.0
    todos eles ips setado de 10.0.0.2 ate 10.0.0.254
    nao quero ir nos clientes alterar e gostaria de saber se eu desativar o dhcp nao vai fazer diferença por q os ips ja esta posto entao quer dizer q eles ainda continara a navegar
    Se o que você usa nos clientes é a faixa 10.0.0.2 à 10.0.0254/255.0.0.0
    Então pode remover a outra. E use esta acima para o pppoe.

  2. #22

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Se o que você usa nos clientes é a faixa 10.0.0.2 à 10.0.0254/255.0.0.0
    Então pode remover a outra. E use esta acima para o pppoe.
    desculpe mas nao estou conseguindo compreender onde é que tenho q removo a outra em q menu do winbox
    meu pool é 10.0.0.2-10.0.0.254



  3. #23

    Padrão

    Citação Postado originalmente por deson00 Ver Post
    desculpe mas nao estou conseguindo compreender ...
    Deixe seu mikrotik configurado apenas com a faixa de ip que você está usando para os clientes e a de internet.

    Você usa os dois servidores dhcp (dhcp1 e dhcp2 citado por você)?

    ...

  4. #24

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Deixe seu mikrotik configurado apenas com a faixa de ip que você está usando para os clientes e a de internet.

    Você usa os dois servidores dhcp (dhcp1 e dhcp2 citado por você)?

    ...
    acho q agora entendi veja se estou correto tenho uma pool q é 10.0.0.2-10.0.0.254
    meu dhcp esta mandando os ips de acordo com essa pool q seria minha pool1 entao posso criar uma pool2 e colocar 10.0.2.2-10.0.2.254 e colocar como servidor dhcp para ale fornecer esses ips para q os clientes nao navegue ate ai tudo bem se for isso e vejo q realmente se estiver como altomatico ele nao navega mas se por acaso o proprio cliente resolva colocar manual seus ips e acerte a rede q esta a pool1 ele navegaria numa boa correto?
    como fazer para ele noanavegar



  5. #25

    Padrão

    Citação Postado originalmente por deson00 Ver Post
    acho q agora entendi veja se estou correto tenho uma pool q é 10.0.0.2-10.0.0.254...
    como fazer para ele noanavegar
    Estou terminando uma configuração básica de pppoe e já posto aqui para você dá uma olhada.
    Mas me diga uma coisa... você quer que apenas funcione o ppp?
    Última edição por Raniel; 08-06-2008 às 03:08.

  6. #26

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Estou terminando uma configuração básica de pppoe e já posto aqui para você dá uma olhada.
    Mas me diga uma coisa... você quer que apenas funcione o ppp?
    isso mesmo so funcione ppoe dos clientes se por acaso eles colocar algum ip nao funcione so navegue depois de discar

    estou no aguardo do q vc ira me mandar ok



  7. #27

    Padrão

    Bem amigo,
    Depois de muito quebrar a cabeça testando o seu problema, cheguei a uma configuração que, ao meu vê, é a mais indicada para a sua necessidade, peço desculpas se alguém já postou, e se tinha outra, mas como eu disse, esta é eficaz*.

    Pois bem amigo, olha só a hora, 04:22, vamos lá, já que amanhã não estarei para discutir assuntos do forum, mas na segunda pela tarde...

    Pois bem.... temos por ficção as faixas de redes 192.168.100.0/24 e 172.16.0.0/24.

    1º cria-se uma rede falsa (192.168.100.0/24 se tiver mais de 253 clientes, cria-se duas ou mais redes falsas):

    /ip address add address=192.168.100.254 netmask=255.255.255.0 network=192.168.100.0 broadcast=192.168.100.255 interface=ether1* comment="rede falsa" disabled=no

    *interface onde os clientes estarão conectados.

    Note: não faça nenhuma marcação de pacotes, masquerade ou outro qualquer para esta rede, lembre-se que é uma rede fantasma, mais abaixo vai entender o porquê.

    Depois vamos criar a rede verdadeira (172.16.0.0/24 mesmo caso acima):

    /ip address add address=172.16.0.254 netmask=255.255.255.0 network=172.16.0.0 broadcast=172.16.0.255 interface=ether1* comment="rede cliente" disabled=no

    *interface onde os clientes estarão conectados.

    Agora vamos fazer o masquerade para nossa rede cliente:

    /ip firewall nat add chain=srcnat src-address=172.16.0.0/24
    action=masquerade comment="masquerade" disabled=no

    Vamos criar o pool para nossa rede cliente:

    /ip pool add name=clientes ranges=172.16.0.1-172.16.0.253 next-pool=none

    Vamos criar o perfil para o servidor pppoe:

    /ppp profile add name="PPPoE Perfil" local-address=172.16.0.254 remote-address=clientes use-compression=no use-vj-compression=no use-encryption=no only-one=default change-tcp-mss=yes dns-server=172.16.0.254

    Criamos o secret(login) para o usuario:

    /ppp secret add name="teste_cliente" service=pppoe caller-id
    =00:11:22:33:44:55 password=123123

    Não deu para fazer o servidor pppoe por terminal:
    Nome: PPPoE Server interface=ether1 max MTU e MRU=1488 keepalive...=10 default profile=PPPoE Perfil one session per host=true
    authentication=all

    Agora vem a parte de uso da rede falsa:

    /ip arp add address=192.168.100.1 mac-address=11:22:33:44:55
    interface=ether1 disabled=no comment="teste_cliente"

    Explicação: Toda vez que o pppoe e discado, ele abre um tunelamento, ou seja, sua proprio conexao servidor-cliente e vice-versa. Assim que o pppoe é desconectado, pois é uma conexao dinamica, a o ip da rede falsa assume. Se o cliente get o ip 172.16.0.2 por pppoe e tem 192.168.100.2 pelo arp, quando está conectado via pppoe, ele navegará e quando desconectar, travará numa tela de erro ou mesmo numa tela branca, mesmo, que ele coloque o ip do pppoe nas propriedades tcp/ip da placa de rede.

    Importante:

    /interface ethernet set ether1 arp=reply-only

    Isto fará com que minha explicação acima seja confirmada.

    É isto aí amigo, acho que não estou esquecendo de nada, pois são 05:14 am e o sono já atrapalha.
    Vou postar as configs em outro post que este ficou grande.

  8. #28

    Padrão

    Veja bem:

    0 ;;; rede da internet
    192.168.139.2/24 192.168.139.0 192.168.139.255 ether1
    1 ;;; rede para clientes
    172.16.0.254/24 172.16.0.0 172.16.0.255 ether1
    2 ;;; rede falsa
    192.168.100.254/24 192.168.100.0 192.168.100.255 ether1


    0 ;;; rede da internet
    192.168.139.2/24 192.168.139.0 192.168.139.255 ether1
    1 ;;; rede para clientes
    172.16.0.254/24 172.16.0.0 172.16.0.255 ether1
    2 ;;; rede falsa
    192.168.100.254/24 192.168.100.0 192.168.100.255 ether1
    3 D 172.16.0.254/32 172.16.0.251 0.0.0.0 <pppoe-teste>

    Se observou, depois que eu loguei com no pppoe ele retornou uma 4ª conexão e está, dinâmica, como expliquei acima.

    0 192.168.100.2 00:0C:29:82:BC:3B ether1

    Este é o ip x mac que está para o cliente no arp

    É isto aí, tá na minha hora.

    Qualquer coisa...

    Só segunda pela tarde, ou se eu acordar antes das 14:30.

    Falous.



  9. #29

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Veja bem:

    0 ;;; rede da internet
    192.168.139.2/24 192.168.139.0 192.168.139.255 ether1
    1 ;;; rede para clientes
    172.16.0.254/24 172.16.0.0 172.16.0.255 ether1
    2 ;;; rede falsa
    192.168.100.254/24 192.168.100.0 192.168.100.255 ether1


    0 ;;; rede da internet
    192.168.139.2/24 192.168.139.0 192.168.139.255 ether1
    1 ;;; rede para clientes
    172.16.0.254/24 172.16.0.0 172.16.0.255 ether1
    2 ;;; rede falsa
    192.168.100.254/24 192.168.100.0 192.168.100.255 ether1
    3 D 172.16.0.254/32 172.16.0.251 0.0.0.0 <pppoe-teste>

    Se observou, depois que eu loguei com no pppoe ele retornou uma 4ª conexão e está, dinâmica, como expliquei acima.

    0 192.168.100.2 00:0C:29:82:BC:3B ether1

    Este é o ip x mac que está para o cliente no arp

    É isto aí, tá na minha hora.

    Qualquer coisa...

    Só segunda pela tarde, ou se eu acordar antes das 14:30.

    Falous.
    obrigado amigo vc resolvel meu problema
    e vendo isso agora compreendo mais e enquanto vc estava fazendo essa explicação consegui encontrar uma solução provisoria q seria apenas trocar minha faixa de rede como vc avia dito mas eu nao compreendido ao invez de eu tutilizar 10.0.0.1-10.0.0.254 epenas mudei para 10.0.2.1-10.0.2.254 nesse caso nao navegava ate eles acertar essa faixa de ip.