+ Responder ao Tópico



  1. #1

    Padrão ap em bridge não pega nat do servidor

    É o seguinte pessoal, tenho um servidor com duas interfaces de rede eth1 (rede interna) eth0 (internet), a interface eth1
    está ligada em um hub onde tem x maquinas ligadas e um ap configurado em modo ap mesmo com a mesma faixa de ips, nesse ap tem
    outro ap fazendo brigde entre esse ap e um outro ap também configurado como bridge, todos usando a mesma classe de ip.

    ou seja:

    Eth0-Servidor-Eth1-Hub-Ap-Ap2(bridge)-Ap3(bridge)-Rede Secundária

    onde:
    Eth0: 201.x.x.x (Internet)
    Eth1: 192.168.2.1 (Rede Primária)
    Ap: 192.168.2.100 (Rádio em modo AP)
    Ap2: 192.168.2.110 (Rádio em modo bridge)
    Ap3: 192.168.2.120 (Rádio em modo bridge)
    Rede Secundária: 192.168.2.x (Rede Secundária)

    NetMask: 255.255.255.0


    Regras de NAT (Iptables)

    iptables --flush
    iptables --table nat --flush
    iptables --delete-chain
    iptables --table nat --delete-chain

    iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE
    iptables --append FORWARD --in-interface eth1 -j ACCEPT

    echo 1 > /proc/sys/net/ipv4/ip_forward


    Agora o problema....

    a rede secundária só consegue acessar a internet utilizando proxy autenticado (squid), se pingar da Rede Secundária
    para a internet não retorna resposta alguma, para o restante da rede está respondendo normalmente. A rede primária consegue
    pingar normalmente para a internet, e também consegue acessar a internet sem o proxy, isso comprova que o nat está funcionando
    corretamente, então porque não acontece o mesmo com a rede secundária? preciso fazer roteamento no servidor mesmo usando a mesma faixa
    de ips e o mesmo netmask? como deverá ser esse roteamento? se consigo pingar da rede interna para rede secundária e vice-versa
    teóricamente o roteamento entre elas está certo, não?

    Valeu, isso está me dando dor de cabeça já há muito tempo.

  2. #2

    Padrão

    Você disse que a rede primária consegue pingar pra internet. De onde você testou esse ping?? de uma estação conectada ao hub?? Você tem 3 APs, o AP2 e o AP3 estão conectados ao AP certo?? O pessoal dessa "rede secundária" ta vindo de qual AP??

    Aparentemente o problema não é roteamento nem NAT...
    Última edição por Magnun; 16-06-2008 às 22:02.



  3. #3

    Padrão

    sim a rede primária está conectada com o hub, como eu citei o ap que está ligado no hub está como ap, os outros dois fazem bridge com a rede interna através desse ap, a rede interna acessa a rede dos aps tranquilamente e vice-versa.

    Na lista de discussão do debian eu recebi algumas dicas em relação ao firewall, parece que os pacotes que passem pelos aps vem com flags especificas, amanhã vou testar e se der certo posto aqui.

  4. #4

    Padrão

    O AP geralemente fazem marcação de prioridade e pra QoS, mas isso não deveria influenciar no FW a menos que você esteja especificando a permissão de apenas algumas flags...



  5. #5

    Padrão

    Não tem algum equipamento proxy_arp nessa sua rede não?

  6. #6

    Padrão

    Citação Postado originalmente por allisonvoll Ver Post
    Valeu, isso está me dando dor de cabeça já há muito tempo.
    Você deveria evitar o cross-posting, principalmente fingindo ser outra pessoa. Niguém vai te dar preferência por usar um nome (pseudo) feminino.

    Já tentou verificar a rota default dos terminais da rede secundária?



  7. #7

    Padrão

    Citação Postado originalmente por PEdroArthurJEdi Ver Post
    Você deveria evitar o cross-posting, principalmente fingindo ser outra pessoa. Niguém vai te dar preferência por usar um nome (pseudo) feminino.
    Esse não é o meu caso... fiz crossposting sim, e peço desculpas por isso mais não fingi ser outra pessoa.

    Não tem algum equipamento proxy_arp nessa sua rede não?
    Jim, não tem nenhum equipamento proxy_arp não, alias o que seria isso exatamente?

    Já tentou verificar a rota default dos terminais da rede secundária?
    Sim, apesar de achar muito estranho parece que não tem nada de errado, segue o arquivo com as rotas de um dos terminais em anexo
    Arquivos Anexos Arquivos Anexos

  8. #8

    Padrão

    Primeiro, não entendi pq "cross posting" Allisson não é um nome feminino.

    Proxy Arp é o equipamento que não repassa o MAC dos clientes, repassa o MAC dele, fazendo que apenas um MAC seja visto. Seu servidor não entrega o IP pq já possui um IP associado a este MAC.

    Para verificar isso, sete um IP manualmente no cliente, pingue o servidor e verifique no servidor qual MAC aparece para o IP do cliente. Se for o AP da bridge, é proxy arp.



  9. #9

    Padrão

    Citação Postado originalmente por Jim Ver Post
    Primeiro, não entendi pq "cross posting" Allisson não é um nome feminino.
    Cross-posting acontece quando se envia uma mensagem para diversas listas de discursão e/ou foruns. Ele fez isso.

    O feminino foi um erro, eu vi um e-mail com o nome de fernanda e achei que fosse o dele, erro meu. O conteúdo da mensagem era o mesmo.

  10. #10

    Padrão

    Citação Postado originalmente por PEdroArthurJEdi Ver Post
    Cross-posting acontece quando se envia uma mensagem para diversas listas de discursão e/ou foruns. Ele fez isso.

    O feminino foi um erro, eu vi um e-mail com o nome de fernanda e achei que fosse o dele, erro meu. O conteúdo da mensagem era o mesmo.
    blz.