+ Responder ao Tópico



  1. #1

    Padrão cache em outro mikrotik

    É o seguinte, eu tenho um RB com mikrotik 2.9.7 como gateway e quero fazer o cache em outra maquina que tambem roda mikrotik, já procurei em todo lugar e nao encontrei nada a respeito, se alguem puder me ajudar, valeu!
    Última edição por SLIPPERY; 18-06-2008 às 13:02.

  2. #2

    Padrão

    amigo faça o seguinte:
    na sua rb, na ba ip > firewall > nat
    adicione a seguinte regra:
    / ip firewall nat
    add chain=dstnat in-interface=Rede_dos_clientes protocol=tcp dst-port=80 action=src-nat to-addresses=IP_do_PC_Mikrotik to-ports=Porta_do_web-proxy_do_PC comment="" disabled=no

    qualquer coisa poste aqui, pra gente tiar sua duvida
    abraços
    Josevaldo Rocha



  3. #3

    Padrão

    Citação Postado originalmente por SLIPPERY Ver Post
    É o seguinte, eu tenho um RB com mikrotik 2.9.7 como gateway e quero fazer o cache em outra maquina que tambem roda mikrotik, já procurei em todo lugar e nao encontrei nada a respeito, se alguem puder me ajudar, valeu!
    Proxy em paralelo com o squid-linux será melhor.
    Dá uma olhada nisto:
    Linux: Proxy em paralelo com o mikrotik [Artigo]

  4. #4

    Padrão não funcionou

    Eu fiz do jeito que vc disse e nao deu certo.



  5. #5

    Padrão

    Citação Postado originalmente por SLIPPERY Ver Post
    Eu fiz do jeito que vc disse e nao deu certo.
    Descreva como tá sua estrutura de rede:
    IP do mikrotik;
    IP do linux;
    IP do ISP;
    Entre outros.
    Isto ajudará na confecção de uma resposta mais adequada

  6. #6

    Padrão estrutura

    speedy - 201.x.x.x - ether2
    mikrotik gateway - 192.168.1.254 - ether1(dhcp ligado)
    ap - 192.168.1.x(dhcp desligado).
    ai eu tenho um pc com mk instalado na mesma rede e pretendo deixá-lo como cache.
    Valeu!!!



  7. #7

    Padrão

    Vc ja esta com o mikrotik com o cache ativado e funcionando?

  8. #8

    Padrão Cache Ativado

    Está ativado e funcionando. Só uma coisa, a porta ethernet do mikrotik que eu to usando para cache tem que estar enable??? Tem mais alguma regra que eu tenho que adicionar no MK que vai fazer o cache???



  9. #9

    Padrão

    Olá amigo,
    Fiz uma breve introdução de como ficaria a configuração no mikrotik. O resto é tudo normal, só seguir direitinho que tudo dá certo.

    Vamos lá:

    Para melhor organização, costumo renomear as ethers:

    /interface set ether3 name=squid
    /interface set ether2 name=internet
    /interface set ether1 name=network


    Configuramos os ips:

    /ip address add address=201.x.x.2/x interface=internet
    /ip address add address=192.168.1.254/24 interface=network


    Configuramos o gateway e o dns:

    /ip route add gateway=201.x.x.1
    /ip dns set primary-dns=201.x.x.x
    /ip dns static add name="DNS Local" address=192.168.1.254


    Configuramos o nat:

    /ip firewall nat add chain=srcnat src-address=192.168.1.0/24 action=masquerade

    Configura deixo por sua conta.

    Com isto já estará funcionando para a rede 192.168.1.0/24

    Vamos fazer a rede para o linux-mikrotik:

    /ip address add address=10.1.0.1/30 interface=squid

    /ip firewall nat add chain=srcnat src-address=10.1.0.0/30 action=masquerade


    Configuração do linux:

    ifconfig eth0 10.1.0.2 netmask 255.255.255.252
    route add default gw 10.1.0.1

    No squid.conf, se estiver dando erro por causa do ip 10.1.0.1, troque:
    acl redelocal src 10.1.0.0/30
    http_access allow redelocal

    Quando ele falou em ip válido, quis dizer que o ip 201.x.x.1 não será o destino da rede quando for acessar o proxy, então deve colocar o ip 201.x.x.1 em dst address quando for fazer o redirecionamento da rede:
    /ip firewall nat add chain=dstnat src-address=10.1.1.0/24 dst-address=!201.x.x.1 protocol=tcp dst-port=80 in-interface=network action=redirect to-ports=3128

    Qualquer coisa...

  10. #10

    Padrão Nao Deu Certo

    Eu fiz o que vc disse mas nao deu certo, minha dúvida é a seguinte, como devo configurar o outro mikrotik que vai ser proxy remoto???
    Valeu!!!



  11. #11

    Padrão Agora funcionou!!!

    Pequenos detalhes.

    Eu nao havia desabilitado o cache da rb por isso nao tava funcionando, e a porta ethernet do pc que ta fazendo o cache ta configurada como enable, eu coloquei como reply-only mas n funcionou. Obrigado a todos!!!