+ Responder ao Tópico



  1. #1

    Angry NAT não funciona, ou melhor, o mikrotik inteiro

    Pessoal, to jogando a toalha, se prepara que o tópico vai ser comprido. (vou tentar ser mais objetivo possível)
    Instalei a 2.9.27 aqui e apanhei pra fazer funcionar, mas consegui...fiz controle de banda, liberar IP/MAC, web proxy e etc.
    Mas o winbox inssiste em desconectar do nada, só consigo reconectar pelo MAC. Então instalei a versão shareware 3.1 pra ver se o problema continuava e num deu, até instalei o kurumin e o XP na maquina pra ver se não era problema no pc e tals e blz, nos outros OS funciona normal, as placas de rede e etc.

    Vou passar minha estrutura de rede:

    AP Edimax em bridge na torre com IP 10.1.120.1 e criptografia WPA.
    Recebo ADSL num modem Intelbrás roteado, Gateway 192.168.1.1 (DHCP)

    No LinuxAP tenho duas placas de rede, uma recebendo o link de ADSL pelo IP 192.168.1.21

    A outra placa envia a net pro rádio na torre e está com IP 10.1.1.1 e configurada em Reply-only pra controle de IP/MAC

    Criei a NAT no firewall como no tuto do Catv, mesmo assim não navegava, então fui em IP>Routes e botei lá destination 0.0.0.0/0 Gateway 192.168.1.1 (que é o IP do gateway do dhcp do modem de ADSL certo?)
    Depois botei Destination: 10.1.1.1 (que é o gateway da placa dos clientes) e Gateway: 192.168.1.1 (que é o gateway do modem)

    Coloco o DNS da Brasil Telemerda em IP>DNS>Settings 201.10.120.3
    e 201.10.1.2
    Blza, já consigo pingar para fora no New terminal.

    No Edimax na torre tenho uma Omni ligada, então num pc aqui pra teste tenho uma plaquinha PCI dlink G520, nela coloco o IP 10.1.1.16 e Gateway 10.1.1.1 (que coloquei lá em Adresses na placa de rede no mikrotik).

    Blz, só que na versão 2.9.27 eu até consegui fazer funcionar como havia dito, mas com muito pau, desconectando do nada, winbox caindo e etc, agora com a versão demo de 24hrs não consigo fazer funfar nem a pau juvenal.
    Eu estou ciente que o melhor a fazer é botar o modem em bridge e usar PPOE, mas aqui na loja usamos a internet com muita frequência e não posso mexer em nada, inclusive o modem não está num lugar de fácil acesso, por isso a configuração medonha desse jeito. Fazendo tudo funcionar, aí sim, vou trocar o modem de lugar, arrumar os cabos de rede e etc...

    Se alguém puder me dar uma luz, pois já faz uns 20 dias que tô rachando o côco aqui pra fazer isso funcionar e nada, já cheguei a cogitar o uso do PfSense em vez do mikrotik, mas tenho grande encanto pelo potencial do mikro.
    (Agradeço a paciência de quem leu meu lamento :-)

  2. #2

    Padrão

    Citação Postado originalmente por mendigo Ver Post
    ...

    Se alguém puder me dar uma luz, pois já faz uns 20 dias que tô rachando o côco aqui pra fazer isso funcionar e nada, já cheguei a cogitar o uso do PfSense em vez do mikrotik, mas tenho grande encanto pelo potencial do mikro.
    (Agradeço a paciência de quem leu meu lamento :-)
    Olá amigo,

    Faça só o basicão para vê:

    Configura:
    Para melhor identificação:
    /interface set ether1 name=internet
    /interface set ether2 name=network


    IP:
    /ip address add address=IP_LINK interface=internet
    /ip address add address=IP_NETWORK interface=network


    Route:
    /ip route add gateway=GT_LINK

    DNS, configure o dns da telemar em settings e adicione um dns estático:
    /ip dns set primary-dns=DNS_TEL
    /ip dns static add name=Local address=IP_SERVIDOR


    Masquerade:
    /ip firewall nat add chain=srcnat src-address=IP_NETWORK.0/24 action=masquerade

    Acho que não esqueci de nada.

    Se não funcionar, tire o hd do mikrotik coloque em outro pc e reinstale-o. Faça uns testei e diga-nos se continua o mesmo problema.

    Espero que isto lhe seja util.



  3. #3

    Padrão

    Amigo, valeu pela ajuda, mas mesmo assim não quer funcionar. Inclusive já montei o mikrotik em outro pc pra ver se o problema parava mas continua na mesma. Sinceramente, to quase desistindo, pois uma hora funciona, outra hora pára...e assim vai.

    Pelo que entendi usando o modem de adsl roteado passando IP por DHCP pra interface LINK no mikrotik eu tenho que adicionar uma rota: IP>Routes>Destination 0.0.0.0/0 e Gateway 192.168.1.1 (que é o mesmo Gateway do modem de ADSL correto? E colocar o Masquerade no Firewall pra fazer as redes se comunicarem.
    Já se eu usar o modem de ADSL em Bridge com PPOE dentro do mikrotik tenho que adicionar somente uma Bridge na guia Interfaces correto?

  4. #4

    Padrão

    Citação Postado originalmente por mendigo Ver Post
    ...
    Pelo que entendi usando o modem de adsl roteado passando IP por DHCP pra interface LINK no mikrotik eu tenho que adicionar uma rota: IP>Routes>Destination 0.0.0.0/0 e Gateway 192.168.1.1 (que é o mesmo Gateway do modem de ADSL correto?
    O gateway deve ser o ip do adsl e não o mesmo gateway, já que o modem está roteado.

    Citação Postado originalmente por mendigo Ver Post
    ...
    Já se eu usar o modem de ADSL em Bridge com PPOE dentro do mikrotik tenho que adicionar somente uma Bridge na guia Interfaces correto?
    Você usa o modem como bridge e disca direto do mikrotik. Aí faz o nat para rede local.

    No forum tem um material de como configurar o modem em bridge.



  5. #5

    Padrão

    Mr. RG, cara....vc me deu uma luz no fim do túnel!

    Saca só, coloquei isso aqui como vc falou:

    /ip dns set primary-dns=DNS_TEL
    /ip dns static add name=Local address=IP_SERVIDOR


    Eu estava somente colocando os DNS da Brasil Telecom em Settings e não colocava o DNS estático que no meu caso seria 10.1.1.1

    Foi só ajustar isso que funcionou, mas o winbox ainda inssiste em desconectar e de vez em quando cai tudo, mas blz, já foi um avanço.
    O estranho é que com a versão 2.9.27 eu não precisei adicionar DNS estático, simplesmente funcionou do nada...huahueuhuaeh

    Agora o próximo passo é fazer o webproxy funfar em 100% pq até agora a "master" queue do proxy não tá dando certo.

  6. #6

    Padrão

    sobre o proxy, dá uma olhada no arquivo que segue em anexo.
    Miniaturas de Anexos Miniaturas de Anexos MikroTik - configuração do cachefull.pdf  



  7. #7

    Padrão

    Valeu pelo link Mr. RG, mas já li esse tuto de trás pra frente e nada. Bom, o proxy deixo pra mais tarde.

    Cara, de tarde o mikro tava funfando legal, mas agora de noite deu pau de novo, por fim só acessava o portal do Terra e mais nada...muito estranho.

    Vê se os meus IP's estão certo:

    IP da placa que recebe o link:
    IP: 192.168.1.12/24
    Network: 192.168.1.0
    Broadcast: 192.168.1.255

    IP da placa que envia pro rádio na torre:
    IP: 10.1.1.1/24
    Network: 10.1.1.0
    Broadcast: 10.1.1.255

    DNS estático que botei 192.168.1.1

    IP configurado no cliente:
    IP: 10.1.1.16
    Mask: 255.0.0.0
    Gway: 10.1.1.1
    DNS primário: 10.1.1.1

    Configs do rádio na torre que está em bridge (modo AP)
    IP: 10.1.120.1
    Mask: 255.0.0.0
    Default Gway: 10.0.0.1

    Será que tá tudo certo? Pq já tá começando a cair cabelo da minha cabeça

  8. #8

    Padrão

    Citação Postado originalmente por mendigo Ver Post
    ...

    Vê se os meus IP's estão certo:

    IP da placa que recebe o link:
    IP: 192.168.1.12/24
    Network: 192.168.1.0
    Broadcast: 192.168.1.255

    IP da placa que envia pro rádio na torre:
    IP: 10.1.1.1/24
    Network: 10.1.1.0
    Broadcast: 10.1.1.255
    Até aqui tá tudo correto.

    Citação Postado originalmente por mendigo Ver Post
    ...
    DNS estático que botei 192.168.1.1

    IP configurado no cliente:
    IP: 10.1.1.16
    Mask: 255.0.0.0
    Gway: 10.1.1.1
    DNS primário: 10.1.1.1

    Configs do rádio na torre que está em bridge (modo AP)
    IP: 10.1.120.1
    Mask: 255.0.0.0
    Default Gway: 10.0.0.1
    Agora esta configuração que está a desejar.

    O dns estático, qual dns primário que colocou para o mikrotik?

    /ip dns set primary-dns=ip do gw do modem
    /ip dns static add name=local address=10.1.1.1

    Os ips, se estão na rede 10.1.1.0/24, o que eu acho a desejar é a forma que você os colocou nos rádios e clientes, no caso acima, você terá uma rede com como está 10.1.1.1/8 com brodcast 10.255.255.255 e a rede 10.0.0.0.
    Então, ao meu ver, ficaria assim:

    /ip address add address=10.1.1.1/24 interface=clientes

    No masquerade:
    /ip firewall nat add chain=srcnat src-address=10.1.1.0/24 action=masquerade comment="masquerade"

    Nos clientes e rádios:
    IP: 10.1.1.x
    Subnet: 255.255.255.0
    Gateway: 10.1.1.1
    DNS: 10.10.1.1

    Com isto o cache também irá funcionar.

    Caso o dns não funcione corretamente, pode-se colocar outro dns, tipo o do gw do modem.

    É isto aí.

    Qualquer coisa...



  9. #9

    Padrão

    Cara, valeu mesmo pela ajuda que vc está me dando :-)

    O Masquerade aqui eu não tinha jogada IP nenhum e não deu diferença.
    Só ainda não descobri o problema de conexão do Winbox, muito estranho isso.

    Outra coisa, estive procurando aqui no fórum sobre qual a unidade de medida do Cache do Webproxy do MK e fiquei confuso pq falaram que era em Mega, mas lá está escrito que é em KiB (Kbytes) então se eu quero manter objetos com tamanho máximo de 512 mega vou botar ali 524288 Kib correto?

    Mas por enquanto valeu por tudo ae!
    Última edição por mendigo; 20-06-2008 às 19:47.

  10. #10

    Padrão

    Citação Postado originalmente por mendigo Ver Post
    ...

    se eu quero manter objetos com tamanho máximo de 512 mega vou botar ali 524288 Kib correto?

    ...
    Isto mesmo amigo,
    Pode-se colocar por exemplo: 512000 k que ele interpreta os 0's e transforma em 512 MB