Página 6 de 7 PrimeiroPrimeiro ... 234567 ÚltimoÚltimo
+ Responder ao Tópico



  1. #101

    Padrão

    Citação Postado originalmente por aka2005 Ver Post
    Ola pessoal, to entrando agora no topico, desculpa qualquer ignorancia, ou preguiçar de ler...
    Mas fazendo cache full nao é so usar o Simple Queue do MK, setar la o Limits ??, ou é preciso mesmo instalr o ZPH??
    Na verdade não é preciso instalar o zph. Mas ele conta com mais precisão os objetos contidos no cache.

  2. #102

    Padrão

    Olá Mr.RG.

    Conseguimos configurar beleza de acordo com as suas instruções, porém.... quando ativado, fica mais lento que o próprio cache Web-proxy do Mikrotik. Existe um delay maior, como se ele estivesse procurando demais no cache paralelo, depois aparece a página e ainda fica carregando umas figuras, como se o cache não estivesse funcionando, mas está!!! quando desativo, volta ao normal do web-proxy.
    O que poderia estar havendo num caso desses?

    Obrigado desde já pela cooperação.

    flw



  3. #103

    Padrão

    Ola amigo,
    Deve-se observar se o filter não tem alguma regra que esteje bloqueando o proxy paralelo. No mais é você testar o proxy linux individual.

  4. #104

    Padrão

    aqui ( Servidores Linux, Guia Prático: Configurando um proxy transparente ) tem um tutorial em português MUITO interessante para quem quer entender um pouco mais de squid
    Última edição por numlock; 31-12-2008 às 10:47.



  5. #105

    Padrão sera q ta dando certo????

    seguinte ::

    fiz tudo como manda no tuto
    o debian ta instalado e o squid rodando

    as paginas tão sendo carregadas com mais rapidez

    baixei um aplicativo de 7Mb na minha maquina levou o tempo normal ( compativel com a velocidade)
    depois deletei o aplicativo dei um tempo e mandei baixar denovo qdo cliquei em salvar ele ja baixou no meu desktop, porem ,qdo vou em outra maquina e faço a mesma operação ele torna abaixar o arquivo da net

    sera q ta dando certo????

    tem como saber ????


    ps vou no MK e fico olhando o trafego das placas
    10.1.1.5 MK> dispara depois para
    10.1.1.6 minha placa > tempo todo ativa
    15.15.0.2 debian> dispara depois para

  6. #106

    Padrão

    amigo, ~qual o tamanho do arquivo que vc configurou no squid.conf ? e no mikrotik?

    Obrigado....





    Citação Postado originalmente por ivovid Ver Post
    seguinte ::

    fiz tudo como manda no tuto
    o debian ta instalado e o squid rodando

    as paginas tão sendo carregadas com mais rapidez

    baixei um aplicativo de 7Mb na minha maquina levou o tempo normal ( compativel com a velocidade)
    depois deletei o aplicativo dei um tempo e mandei baixar denovo qdo cliquei em salvar ele ja baixou no meu desktop, porem ,qdo vou em outra maquina e faço a mesma operação ele torna abaixar o arquivo da net

    sera q ta dando certo????

    tem como saber ????


    ps vou no MK e fico olhando o trafego das placas
    10.1.1.5 MK> dispara depois para
    10.1.1.6 minha placa > tempo todo ativa
    15.15.0.2 debian> dispara depois para



  7. #107

    Padrão

    Citação Postado originalmente por byosni Ver Post
    amigo, ~qual o tamanho do arquivo que vc configurou no squid.conf ? e no mikrotik?

    Obrigado....

    desculpa mas naum estendi bem sua pergunta
    o .conf foi o q esta no tutorial e no mk foram as configuraçoes no NAT E FIREWALL

    no webproxy
    max-object-size=4096
    no squid
    cache_mem 32 MB
    maximum_object_size_in_memory 64 KB
    maximum_object_size 512 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95


    desculpa
    Última edição por ivovid; 04-02-2009 às 10:54.

  8. #108

    Padrão

    então amigo, pelo o que eu entendi, se vc configurou pra ele somente cachear arquivo no max-object-size=4096KiB(4M) como que vc quer que ele faça cache de um arquivo de 7MB, acho que foi isto que eu entendi de sua pergunta, desculpe-me posso estar errado.


    Até mais...


    Citação Postado originalmente por ivovid Ver Post
    desculpa mas naum estendi bem sua pergunta
    o .conf foi o q esta no tutorial e no mk foram as configuraçoes no NAT E FIREWALL

    no webproxy
    max-object-size=4096
    no squid
    cache_mem 32 MB
    maximum_object_size_in_memory 64 KB
    maximum_object_size 512 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95


    desculpa



  9. #109

    Padrão reconfigurei o web proxy

    Citação Postado originalmente por byosni Ver Post
    então amigo, pelo o que eu entendi, se vc configurou pra ele somente cachear arquivo no max-object-size=4096KiB(4M) como que vc quer que ele faça cache de um arquivo de 7MB, acho que foi isto que eu entendi de sua pergunta, desculpe-me posso estar errado.


    Até mais...
    reconfigurei o webproxy aumentei o valor "max-object-size=70000" (70MB)vou continuar fazendo os testes pra ver se realmente o debian esta fazendo o proxy em paralelo

    o squid esta configurado para 512Mb essa diferença entre oas 2 configuraões pode atrapalhar em algo??
    Última edição por ivovid; 04-02-2009 às 13:06.

  10. #110



  11. #111

    Post

    Citação Postado originalmente por Raniel Ver Post
    Dá uma olhada nisto aqui, desta forma acho melhor
    Raniel

    boa tarde

    amigo desde ja agradeço por disponibilizar os tutoriais

    segui o tuto do "https://under-linux.org/f110119-detalhando-proxy-paralelo-com-o-linux"

    obs
    disponibilizei uma placa so pra a rede (cabo cross )
    o mk e o debian se comunicão ping 15.15.0.1 mk 15.15.0.2 debian
    squid copiado e colado no squid.conf

    o debian esta todo atualizado (apt-get update )

    no mk vou na aba interface e fico obervando
    a int. modem (tx -rx) existe o trafego (os numeros ficam ocilando)
    na int.clientes (tx -rx) existe o trafego (os numeros ficam ocilando)
    NA INT. DEBIAN (TX-RX) DEFICILMENTE ELE MOSTRA O TRAFEGO na minha opnião deveria ter o mesmo trafego q q int clientes, ne isso??

    qual a diferença de seguir esse tuto q vc esta me sugerindo pra esse q segui ?

    uso a 2.9.27 do mk e o debian 4.o como squid 2.6 tem algum prob se continuar com esses ??

    AMIGO SO ESTOU DEPENDO DE ATIVAR ESSE PROXY PARA MONTAR UMA REPETIDORA

    naum sou expert no debian + estou me esfoçando pra aprender

    aproveitando a oportunidade

    como faria pra configurar o debian depois do mk??

    mk>debian(squid-apache-sarg)>clientes
    assim poderia usar o sarg pra gerar relatorios
    Última edição por ivovid; 09-02-2009 às 13:52.

  12. #112

    Padrão

    Olá amigo,
    Tenho um esquema montado igual ao link que te passei e funciona perfeitamente, só que uso slackware ao invés do debian.
    Quanto as interfaces, a interface mikrotik-linux é normal que fique com um tráfego maior, pois está priorizando.



  13. #113

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Olá amigo,
    Tenho um esquema montado igual ao link que te passei e funciona perfeitamente, só que uso slackware ao invés do debian.
    Quanto as interfaces, a interface mikrotik-linux é normal que fique com um tráfego maior, pois está priorizando.

    Raniel desde ja muito obrigado por me responder

    + o q esta acontecendo com minha interface mk-linux e exatamente o contrario

    ela qse naum tem trafego fica o tempo todo tx=0 rx=0
    naum sei se o proxy esta funcionado com esses tutorial
    + vou começar tudo denovo e tentar com esse q vc m indicou agora

    muito obrigado

  14. #114

    Padrão

    Tá ae uma tela de como anda o trafego das interfaces.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         mikrotik-slack.bmp
Visualizações:	111
Tamanho: 	985,3 KB
ID:      	3566  



  15. #115

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Tá ae uma tela de como anda o trafego das interfaces.
    caro amigo

    + uma vez muito obrigado

    agora pude ver q fiz alguma coisa errada na configuraçaõ

    vou rever meus passos

  16. #116

    Padrão

    Amigo, se não tiver conseguido, segue esse tuto que achei nesse link. è muito bom, conseguir rodar de primeira.
    http://www.vivaolinux.com.br/artigo/...rotik?pagina=2
    mérito: André A. Ferreira
    Obs: voltei à usar o web proxy do MK por não ver diferença nenhuma em ter um proxy paralelo, temos que ter é máquina de alta performance e memoria a rodo.
    Espero ter ajudado.
    Última edição por agnaldo52; 21-02-2009 às 15:41.



  17. #117

    Padrão

    Cara blz pela dica!!

    To em fase de testes apenas coloquei no Linux (Debian)
    estou fazendo uns testes para depois colocar em produção, mais o cache é esvaziado só ou precisa reiniciar o squid?

  18. #118

    Padrão

    Citação Postado originalmente por gleitao Ver Post
    Cara blz pela dica!!

    To em fase de testes apenas coloquei no Linux (Debian)
    estou fazendo uns testes para depois colocar em produção, mais o cache é esvaziado só ou precisa reiniciar o squid?

    Uma dica para quem está fazendo proxy paralelo;

    cuidado com o número de arquivos simultaneos que a sua distribuição linux pode abrir!! Isto pode causar crash com travamento do servidor proxy.



  19. #119

    Padrão

    gleitao, usei para teste uns 10 dias, setei um espaço de 5gb para cache em disco, quando atinge 90% ele começa à limpar os arquivos mais antigos, ou seja limpa sozinho.
    Ps. não vi diferença entre o paralelo e o do mikrotik v3.16 e 3.20
    Não esqueça que para proxy cache deve usar máquina de alta performance.

  20. #120

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    ola amigos, estou com uma duvida aqui...
    vou explicar a estrutura que em penso...

    pc mk, recebendo link adsl, com hotspot, controle de banda, etc

    pc linux squid, como cliente do mk, passando por ip blinding no hotspot 'sem altenticar'

    e clientes com proxy transparante,,, usando o proxy do linux..
    e nos relatorios do proxy, serem gerados com os ips dos clientes,,, e nao com o ip do gw 'mk'
    desde ja agradeço a todos!
    vlw
    vc ja testou dessa forma??? deu certo???