+ Responder ao Tópico



  1. Citação Postado originalmente por arium Ver Post
    assim que tiver um tempo sobrando irei estudar suas modificações!
    cara, estou testando o script aqui e detectei um problema, nao sei se ocorre com o seu.

    na primeira vez que vejo o video, ele faz todo o processo para baixar o video direitinho, cria o html, o sed esta substituindo o player.

    a pagina original carrega, enquanto está baixando, mas o video do site original, so começa a carregar depois que o download do video para o hd termina.

    isso acontece com o seu script?

    se nao acontece, vou ter que estudar uma solução para isso.

    grato,

  2. não acontece com o meu não amigo!

    o meu apenas tem um controle que verifica se o download acabou ou não

    caso não acabou manda pra url original... caso acabou manda pro cache!

    Abraços



  3. Citação Postado originalmente por arium Ver Post
    não acontece com o meu não amigo!
    o retorno do script para o squid deve ser apenas a URL ou deve-se acrescentar mais informações?

  4. á entrada vai ser:

    URL <SP> client_ip "/" fqdn <SP> user <SP> method <SP> urlgroup
    [<SP> kvpairs] <NL>


    a saida:

    And the rewriter may return a rewritten URL. The other components of
    the request line does not need to be returned (ignored if they are).

    ou seja só a url o resto nao precisa

    o maximo que vc pode fazer é isso:

    The rewriter can also indicate that a client-side redirect should
    be performed to the new URL. This is done by prefixing the returned
    URL with "301:" (moved permanently) or 302: (moved temporarily).

    adicionando 301: ou 302: na frente da url tipo 302:youtube.com.br

    mais não vi nenhuma utilidade nisso :P



  5. Citação Postado originalmente por arium Ver Post
    And the rewriter may return a rewritten URL. The other components of
    the request line does not need to be returned (ignored if they are).
    ok ok,

    entao meu script está certo retornando apenas a url (original) ou a url com 302:url_local. (apesar de nao ver utilidade tb, mas aparece no log como REDIRECT)

    e eu retorno a URL original antes mesmo de iniciar o download, ai ele abre normal o site. so que o vídeo na carrega normalmente.

    tirei a url_rewrite pra testar e esta funcionando normal.

    vou tentar conseguir um tempo pra fazer mais testes hoje, pois o negocio aqui está "apurado".






Tópicos Similares

  1. Squid. Msg de erro apó o STOP
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 25-08-2003, 13:42
  2. Squid - limite de usuarios (authenticate_children 32)
    Por Wal no fórum Servidores de Rede
    Respostas: 2
    Último Post: 01-08-2003, 17:32
  3. Usar Squid atraves de outro Proxy
    Por lucianotome no fórum Servidores de Rede
    Respostas: 4
    Último Post: 20-05-2003, 10:24
  4. Firewall + Squid ==> Estao de Ficando meio Maluco.
    Por A-Marcio no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-03-2003, 20:43
  5. Socorro - Squid parou de autenticar após atualização de paco
    Por Ganymede no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-02-2003, 13:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L