Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #13

    Padrão

    Eu resetei todos os HTMLs do hotspot pro arquivo radvert original voltasse, ai nesse arquivo eu somente traduzi oq tem escrito lá, e criei o arquivo aviso.html e block.html, o radvert realmente aparece na pagina, agora o aviso e block vem em pop-up!

    ip hotspot user profile
    set Wireless name="Wireless" idle-timeout=none keepalive-timeout=2m status-autorefresh=1m shared-users=1 \
    transparent-proxy=no
    add name="Atrazo" idle-timeout=none keepalive-timeout=20s status-autorefresh=1m shared-users=unlimited \
    transparent-proxy=yes open-status-page=always advertise=yes \
    advertise-url=http://auth.meganet.com.br/aviso.html,http://auth.meganet.com.br/aviso.html advertise-interval=20m \
    advertise-timeout=immediately
    add name="cortado" session-timeout=1m idle-timeout=none keepalive-timeout=20s status-autorefresh=1m shared-users=unlimited \
    rate-limit="15k/15k" transparent-proxy=yes open-status-page=http-login advertise=yes \
    advertise-url=http://auth.meganet.com.br/block.html,http://auth.meganet.com.br/block.html advertise-interval=1s,1s \
    advertise-timeout=immediately

  2. #14

    Padrão

    Olá amigo,
    Coloque suas paginas dentro da pasta hotspot, se já tiver..., daí você muda o endereço http://auth.meganet.com.br/aviso.html pois se você tentar acessar, acredito que ele não vai encontrar os arquivos.

    Acredito que você colocou o dns do servidor hotspot com o endereço acima.
    Os pop-ups que você diz estão sendo bloqueados, é a pag de status.

    Faça uma alteração na suas configs:

    ■ No dns:
    /ip dns static add name=192.168.1.1 address=192.168.1.1

    ■ No perfil do servidor hotspot:
    /ip hotspot profile set "nome_profile" hotspot-address=192.168.1.1 dns-name="192.168.1.1"

    ■ Nos profiles dos usuários:
    advertise=yes advertise-url=block.html

    advertise=yes advertise-url=aviso.html

    Faça isto e veja se funciona.
    Última edição por Raniel; 10-07-2008 às 08:51.



  3. #15

    Padrão

    Não deixe de observar o material, pois muitos têm feito e dado certo:

    Linux: Configurando servidor MikroTik com Hotspot e páginas de aviso (atraso e bloqueio) [Artigo]

    Principalmente na pagina 4.
    Última edição por Raniel; 10-07-2008 às 08:52.

  4. #16

    Padrão

    Fiço os testes e a unica pagina q aparece é a do radvert mesmo, mais ela não sai automaticamente e ai o cliente tem de clicar no link pra poder ir para pagina seguinte, ai sim, ao clicar aparece a tela de aviso ou bloqueio!



  5. #17

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Fiço os testes e a unica pagina q aparece é a do radvert mesmo, mais ela não sai automaticamente e ai o cliente tem de clicar no link pra poder ir para pagina seguinte, ai sim, ao clicar aparece a tela de aviso ou bloqueio!
    Está tendo algum problema, era para ele redirecionar em mesmo de 3 segundos (time=1000 em milisegundos).
    Faça um backup e use o 2.9.50 e siga o material:

    Linux: Configurando servidor MikroTik com Hotspot e páginas de aviso (atraso e bloqueio) [Artigo]

    Fiz os testes novamente e redirecionou.

    Qualquer coisa entre em contato que veremos isto aí.

  6. #18

    Padrão

    Outra coisa que eu esqueci de mencionar é que a autenticação tem que está como http-chap:

    login-by=mac,http-chap