+ Responder ao Tópico



  1. #1

    Padrão Script para alterar Queues!!!

    Pessoal,

    Como acontece em qualquer outro provedor, existe uma sobra muito grande de link de internet na madrugada. Estava pensando na possibilidade de "adicionar" à banda liberada para cada cliente um adicional de 1mbps, por exemplo, no horário entre a meia-noite e as 6 da manhã. Atualmente tenho um script que simplesmente dá um disabled=yes em todas as queues, mas isso não está sendo uma solução muito boa pois um único cliente poderia usar uma banda de mais de 5 mbps e simplesmente "esgotar" a capacidade do AP, deixando o acesso dos outros clientes que usam o mesmo AP uma porcaria. Fiz testes aqui e é isso mesmo que acontece.

    Existe a possibilidade de "adicionar" mais banda a uma referida queue através de script, e voltar à banda original pela manhã, sem precisar criar 2 Queues para cada cliente (uma para cada período de tempo)???

    Outras sugestões são bem-vindas!!!

    Obrigado!

  2. #2

    Padrão

    Existe uma forma de fazer sim e, em princípio, até simples. Você pode postar as configurações de uma das queues pra eu dar uma olhada nos parâmetros?



  3. #3
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão

    Isso, posta a configuração pra gente da uma olhada.

  4. #4

    Smile Banda da madrugada

    Citação Postado originalmente por _AGM_ Ver Post
    Pessoal,

    Como acontece em qualquer outro provedor, existe uma sobra muito grande de link de internet na madrugada. Estava pensando na possibilidade de "adicionar" à banda liberada para cada cliente um adicional de 1mbps, por exemplo, no horário entre a meia-noite e as 6 da manhã. Atualmente tenho um script que simplesmente dá um disabled=yes em todas as queues, mas isso não está sendo uma solução muito boa pois um único cliente poderia usar uma banda de mais de 5 mbps e simplesmente "esgotar" a capacidade do AP, deixando o acesso dos outros clientes que usam o mesmo AP uma porcaria. Fiz testes aqui e é isso mesmo que acontece.

    Existe a possibilidade de "adicionar" mais banda a uma referida queue através de script, e voltar à banda original pela manhã, sem precisar criar 2 Queues para cada cliente (uma para cada período de tempo)???

    Outras sugestões são bem-vindas!!!

    Obrigado!
    Pode sim ser usado eu faço isso a mais de um ano

    se usa simple queue vc tem que criar mais de uma queue e usar o parametro time para que ela no horário desejado, ou seja uma queue no período normal e outra queue no período da madrugada, se usa dinamic queue ai tem que criar um script pra alterar , fica o invoniente que o cliente tem que deslogar pra aproveitar a queue nova mas o pior mesmo nesse caso é que vc vai ter que deslogar o cliente pela manha se não ele fica com a queue da madrugada o dia todo. veja qual é o seu caso que eu te mando os meus scripts



  5. #5

    Padrão

    Você pode ter duas configurações de queues para os clientes, um ficará disabled.
    Ex para apenas 1 usuários:
    1ª - Usuários da madrugada: banda 512k
    2ª - Usuários do dia: banda: 128k

    Cria um script para desabiltar a 1ª e a 2ª nos horários determinados.

  6. #6

    Padrão

    Segue uma linha de minhas configurações de queue... São toda siguais, mudando somente o IP e a banda de um para outro.

    /queue simple
    add name="10.11.17.2" target-addresses=10.11.17.2/32 dst-address=0.0.0.0/0 interface=all parent=none direction=both priority=8 \
    queue=default-small/default-small limit-at=0/0 max-limit=50000/130000 total-queue=default-small disabled=no

    Lembrando que não gostaria de ter que fazer 2 queues para cada cliente. Não há como fazer com que um aúnica regra de queue que aplique uma banda individual para cada IP que passar pelo router?



  7. #7

    Red face Script e schedule

    Citação Postado originalmente por _AGM_ Ver Post
    Segue uma linha de minhas configurações de queue... São toda siguais, mudando somente o IP e a banda de um para outro.

    /queue simple
    add name="10.11.17.2" target-addresses=10.11.17.2/32 dst-address=0.0.0.0/0 interface=all parent=none direction=both priority=8 \
    queue=default-small/default-small limit-at=0/0 max-limit=50000/130000 total-queue=default-small disabled=no

    Lembrando que não gostaria de ter que fazer 2 queues para cada cliente. Não há como fazer com que um aúnica regra de queue que aplique uma banda individual para cada IP que passar pelo router?
    vc tem que criar um script e um schedule o script executa a ação e o schedule altera no horário que vc deseja

    ex de script para liberar banda

    / system script add name="liberabanda" source="set name=\"10.11.17.2\" \
    max-limit=100000/260000
    \nset name=\"10.11.17.3\" \
    max-limit=100000/260000
    \nset name=\"10.11.17.4\" \
    max-limit=100000/260000
    \n" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
    ex de script para bloquear banda

    add name="bloqueiabanda" source="set name=\"10.11.17.2\" \
    max-limit=50000/130000
    \nset name=\"10.11.17.3\" \
    max-limit=50000/130000
    \nset name=\"10.11.17.4\" \
    max-limit=50000/130000
    \n" \
    policy=ftp,reboot,read,write,policy,test,winbox,password

    ai cria 2 schedule

    / system scheduler
    add name="bandafree" on-event=liberabanda start-date=sep/14/2008 \
    start-time=00:00:01 interval=1d comment="" disabled=no
    add name="bandanormal" on-event=bloqueiabanda start-date=sep/14/2008 \
    start-time=07:00:00 interval=1d comment="" disabled=no

    acho que está tudo ai, deve resolver

    obs pra cada ip que quiser o controle vc tem que incluir depois um a um
    obs 2 não tive tempo de testar todo os scripts, qualquer erro posta ai

    não se esqueça de verificar a hora do seu mk, se não dá tudo errado

  8. #8

    Padrão

    Valew, moçada, vou analisar as sugestões e ver o que melhor se adapta ao meu problema... Depois posto os resultados... Muito obrigado a todos...



  9. #9

    Padrão

    Citação Postado originalmente por _AGM_ Ver Post
    Pessoal,

    Como acontece em qualquer outro provedor, existe uma sobra muito grande de link de internet na madrugada. Estava pensando na possibilidade de "adicionar" à banda liberada para cada cliente um adicional de 1mbps, por exemplo, no horário entre a meia-noite e as 6 da manhã. Atualmente tenho um script que simplesmente dá um disabled=yes em todas as queues, mas isso não está sendo uma solução muito boa pois um único cliente poderia usar uma banda de mais de 5 mbps e simplesmente "esgotar" a capacidade do AP, deixando o acesso dos outros clientes que usam o mesmo AP uma porcaria. Fiz testes aqui e é isso mesmo que acontece.

    Existe a possibilidade de "adicionar" mais banda a uma referida queue através de script, e voltar à banda original pela manhã, sem precisar criar 2 Queues para cada cliente (uma para cada período de tempo)???

    Outras sugestões são bem-vindas!!!

    Obrigado!
    Segue uma linha de minhas configurações de queue... São toda siguais, mudando somente o IP e a banda de um para outro.

    /queue simple
    add name="10.11.17.2" target-addresses=10.11.17.2/32 dst-address=0.0.0.0/0 interface=all parent=none direction=both priority=8 \
    queue=default-small/default-small limit-at=0/0 max-limit=50000/130000 total-queue=default-small disabled=no

    vc pode aplicar no script alterando a velocidade que que o usuario tenha no horario da madrugada por exemplo

  10. #10

    Padrão

    Gostei da ideia e gostaria de implementar essa regra em meu sistema ..
    mas não obtive sucesso.
    Gostaria de criar algo que liberasse o dobro de velocidade para todos os clientes no horario de 00:00 hs as 09:00 hs.
    se alguém poder ou tiver algo que possa ajudar eu agradeço...