+ Responder ao Tópico



  1. #1

    Thumbs up Scrip de Backup por email

    /tool e-mail set server="SEU SERVIDOR DE EMAIL" from="SEU EMAIL"
    /system script add name=Gera_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source={/system backup save name=[/system identity get name]}
    /system script add name=Email_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source={/tool e-mail send file=[/system identity get name] to="SEU EMAIL" subject=Backup}
    /system scheduler add name=Gera_Backup on-event=Gera_Backup start-time=21:00:00
    /system scheduler add name=Email_Backup on-event=Email_Backup start-time=21:01:00
    /system script add name=remove_backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source={/file remove=[/system identity get name]}
    /system scheduler add name=remove_backup on-event=remove_backup start-time=22:00:00



    Bem galera adicionei uma paradinha no script para buscar o nome que esta no mk e salvar o backup com o msm..
    Gera o backup envia por email e apaga o backup
    já testei e ta funcionando se alguem quiser ta ai pra galera mais só não sei fazer com servidor de e-mail que requer autenticação
    Mais se já ajudar alguém já eh lucro neh!!!!!!!!!!!!!
    Vlw abç
    Última edição por heavyzin; 17-07-2008 às 12:04.

  2. #2

    Padrão

    O problema agora é:


    Onde arrumar um servidor de email? :/



  3. #3
    danielmenezes
    Visitante

    Padrão

    ótima dica !!

    implementei aqui e já está funcionando.

  4. #4
    danielmenezes
    Visitante

    Padrão

    Citação Postado originalmente por danielmenezes Ver Post
    ótima dica !!

    implementei aqui e já está funcionando.
    ahh, só uma coisa ...

    uso a versao 3.11, tive q tirar o '=' do remove_backup .. ai funcionou!
    aqui: " .... source={/file rem....", tira ele .. fica assim: " .... source {/file rem...."



  5. #5

    Padrão

    Danielmenezes, o servidor de E-mail que vc colocou para enviar o backup tem autenticador?

  6. #6
    danielmenezes
    Visitante

    Padrão

    Citação Postado originalmente por GivigiRJ Ver Post
    Danielmenezes, o servidor de E-mail que vc colocou para enviar o backup tem autenticador?
    não tem, mas é um server interno aqui da empresa onde trabalho.




  7. #7

    Padrão

    Citação Postado originalmente por danielmenezes Ver Post
    não tem, mas é um server interno aqui da empresa onde trabalho.

    O que a maioria precisa é de uma alma caridosa que possa disponibilizar um servidor de email público que não tenha autenticação. Mas isso é quase impossível de se encontrar devido a falta de segurança e uma porta aberta para toneladas de spam, muito embora talvez haja uma saída.

    Se esse servidor público, pudesse implementar contas de email, onde só permitisse a entrada de determinado email de origem (o que está configurado no MK) e apenas um determinado destino (o email para onde será enviado o backup) rejeitando todos os demais, poderia ser uma solução segura para uma conta sem autenticação.

    É só teoria...