Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Ola amigos,


    Eu tentei fazer como magnum falou... configurando como cliente DHCP... e deu certo....
    NOTA: os dispositivos estavam invertidos aqui no servidor... a ultima pessoa que mexeu nele... deve ter se enganado.
    Entao tirei um e deixei o outro para conferir qual era qual... e deu certo.

    Configurei a ETH1 como cliente DHCP... consegui obter IP e estou navengando.(ligado direto a modem rotiado)

    Falei com Kleber tb... e vi uma outra forma de se fazer... que estou tentando no outro HD tb...

    queria saber agora... nesse... que ja estou navegando...

    vou configurar a placa ETH0 como 10.0.0.147 para compartilhar conexao com a rede local.

    como faco agora... adiciono somente as regras do iptables?

    aguardo

    valeu galera!

  2. Isso, configura a eth0 como ip fixo. Lembrar de não configurar gateway padrão para essa interface. Muitos erros de configuração de server é porque as pessoas acham que toda interface tem que ter um gateway padrão.

    Não esquece de ativar o roteamento: echo '1' > /proc/sys/net/ipv4/ip_forward

    Por último aS regraS de iptables. Provavelmente não serão só uma não. Adiciona aquela que você postou de masquerade e verifica se não tem nenhum regra que possa impedir o roteamento. Dá uma olhada nas chains input, output e forward com o comando iptables -nL.

    Acho que é só...

    ### Update ###
    Acabei de perceber... Você tem um modem, ele já ta distribuindo DHCP, muito provavelmente ele também está fazendo nat... Talvez você não precise configurar regras de nat no iptables... Configura a eth0 e ativa o roteamento. Depois testa de uma máquina cliente se ele pinga o IP do Modem. Se até ai estiver tudo certo, pinga pra internet...
    Última edição por Magnun; 23-07-2008 às 15:47.



  3. Entao configurei a ETH0... quando dou um ifup para ativar ela... nao consigo mais pingar nada... parece que o firewall ta bloqueando a configuracao..

    e agora?

  4. estranho quando dou iptables -nL ... nao aparece nada da regra que eu acrescentei... era para aparecer
    algo referete ao ip 10.0.0.147 nao era?



  5. Foi mal pela demora.
    Não as regras de iptables que você adicionou são pra tabela NAT, essa tabela que você está visualizando é a Filter. Pra visualizar a tabela nat utilize o comando iptables -nat -nL;

    Quanto a não pingar mais nada você se refere a que? Pingar de onde pra onde??? Se for do cliente vamos devagar. Faz primeiro ele pingar o Linux. Pingou? Confirma se o gateway desse cliente é o linux?? É põe o cliente pra pingar a eth1 do Linux. Pingou? Pinga o Modem. Tudo OK até aqui? Pinga pra internet...

    Se você não tá pingando nada do linux, ve sua tabela de roteamento: route -n

    Até mais...






Tópicos Similares

  1. 2 placas de rede no servidor
    Por fbssolucoes no fórum Servidores de Rede
    Respostas: 2
    Último Post: 10-01-2007, 07:19
  2. Configurar 3 placas de rede no Servidor Proxy / Firewall
    Por pssgyn no fórum Servidores de Rede
    Respostas: 4
    Último Post: 14-01-2005, 07:59
  3. Base de dados MYsql no servidor de internet
    Por Gil no fórum Servidores de Rede
    Respostas: 2
    Último Post: 19-10-2004, 15:59
  4. Duas placas de rede no servidor NFS
    Por pedromorgado no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 28-07-2004, 19:17
  5. Samba limitando tamanho compartilhamento no Servidor 2000
    Por queirozc no fórum Servidores de Rede
    Respostas: 0
    Último Post: 23-06-2004, 09:16

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L