+ Responder ao Tópico



  1. #1

    Padrão Linux proxy + mk

    galera, gostaria de saber a viabilidade dessa config..

    server1
    mk 2 lan 3 wlan, 1 lan e 3 wlan em bridge, 1 lan recebe link
    switch
    linux proxy squid, 1 lan


    -- o mk recebe link, faz o roteamento, altentica os clientes com hotspot, e pppoe, firewall, ' as 3 wlan, fazem ptp em wds, para os radios pops.'

    -- o linux proxy, recebe link do mk como um cliente sem controles,

    --- o redirecionamento do proxy no fire do mk, esta o default,, 'redireciona na propria maquina'

    --- em proxy,, 'nao web-proxy' ativado, e apontando o iporta do linux proxy 'web-proxy desativado!'

    aqui esta funcionando blza! ate com cache full no mk 'x cache hit'

    essa config é viavel??
    tem como, em vez do linux gerar relatorios do gw, gerar dos ips dos clientes??

    agradeço a ajuda!
    vlws

  2. #2
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Amigo,

    como assim viabilidade??? Não entendi.

    Você quer saber se funciona? Se bem configurado funciona.



  3. #3

    Padrão

    Citação Postado originalmente por MarceloGOIAS Ver Post
    Amigo,

    como assim viabilidade??? Não entendi.

    Você quer saber se funciona? Se bem configurado funciona.
    assim amigo,, tenho configurado aqui, rodando legal.
    quero saber sobre a estabilidade dessa configuraçao,
    e outra, gostaria de saber, nessa config, como posso registrar nos logs do squid, os ips dos clientes, e nao o ip do gw,
    grato,
    vlws

  4. #4



  5. #5

    Padrão

    Amigo me passe maiores informações sobre a legalização de estação estou com um parceiro mas esta cobrando muito caro

  6. #6

    Padrão

    Faça assim amigo,
    Para registrar no log do squid os acessos, você tem que fazer o linux ser um cliente do mikrotik.

    Anexa seu squid.conf para eu dar uma olhada. E qual versão está usando.

    A regra para que ele rode blz é:nat add chain=dstnat src-address=!ipdolinux dst-address=!ipdolinux protocol=tcp dst-port=80 action=dst-nat to-address=ipdolinux to-port=proxyporta



  7. #7

    Padrão

    desculpa a demora mr.rg

    ta aqui as confs

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 # https
    acl SSL_ports port 563 # snews
    acl SSL_ports port 873 # rsync
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 # https
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 631 # cups
    acl Safe_ports port 873 # rsync
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost
    http_access deny all
    icp_access allow all
    http_port 3128
    visible_hostname proxy
    cache_mem 32 MB
    maximum_object_size_in_memory 80 KB
    maximum_object_size 20 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95
    cache_dir ufs /var/spool/squid/cache 40000 16 256
    cache_access_log /var/log/squid/access_cache.log
    hierarchy_stoplist cgi-bin ?
    access_log /var/log/squid/access.log squid
    acl QUERY urlpath_regex cgi-bin \?
    cache deny QUERY
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    acl apache rep_header Server ^Apache
    broken_vary_encoding allow apache
    extension_methods REPORT MERGE MKACTIVITY CHECKOUT
    hosts_file /etc/hosts
    coredump_dir /var/spool/squid

  8. #8

    Padrão

    usando o proxy como cliente do mk usando hs, registrado em ip-blindings "direto"

    ubuntu server 8.04
    Squid Cache: Version 2.6.STABLE18

    mk 2.9.27

    ligaçao direta, cabo cross

    ...........

    preciso ativar o ip-proxy do mk apontando pro server linux?
    ou o redirecionamento resolve tudo??
    e o access.log registrado os ips dos clientes?
    vlw parcero
    Última edição por alanvictorjp; 24-09-2008 às 03:04.



  9. #9

    Padrão

    Muda isto aqui http_access deny all para http_access allow all

    ou crie uma acl com a sua rede e dê permissão a mesma:

    acl localnet src 192.168.1.0/24

    http_access allow localnet
    http_access deny all

  10. #10

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Muda isto aqui http_access deny all para http_access allow all

    ou crie uma acl com a sua rede e dê permissão a mesma:

    acl localnet src 192.168.1.0/24

    http_access allow localnet
    http_access deny all
    ja tinha feito isso,

    uma coisa q percebi
    eh preciso por o transparent
    http_port 80 transparent
    senao fica dando invalid request


    chain=hs-auth src-address=!192.168.2.8 dst-address=!192.168.2.8 protocol=tcp dst-port=80 src-address-list=clientes
    dst-address-list=!fora_do_proxy action=dst-nat to-addresses=192.168.2.8 to-ports=3128

    192.168.2.8 proxy

    to usando essa regra ai
    tem alguns clientes q nao ta navegando direito,,
    alguma luz?
    vlwss



  11. #11

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    ja tinha feito isso,

    uma coisa q percebi
    eh preciso por o transparent
    http_port 80 transparent
    senao fica dando invalid request


    chain=hs-auth src-address=!192.168.2.8 dst-address=!192.168.2.8 protocol=tcp dst-port=80 src-address-list=clientes
    dst-address-list=!fora_do_proxy action=dst-nat to-addresses=192.168.2.8 to-ports=3128

    192.168.2.8 proxy

    to usando essa regra ai
    tem alguns clientes q nao ta navegando direito,,
    alguma luz?
    vlwss
    Não use esta regra para redirecionar. Use a convencional. Faço da seguinte forma: Não habilito a opção Transparent Proxy dos profiles normais e faço a regra de redirecionamento como dstnat. Faça desta forma.

  12. #12

    Padrão

    tb nao uso Transparent Proxy dos profiles
    o transparent q digo, eh no squid.conf

    e sim, estou redirecionando com apenas 1 regra,
    add chain=dstnat src-address=!192.168.2.8 dst-address=!192.168.2.8 protocol=tcp dst-port=80 src-address-list=clientes \
    dst-address-list=!fora_do_proxy action=dst-nat to-addresses=192.168.2.8 to-ports=3128 comment="" disabled=no

    tenho umas list dos clientes
    uma lists de sites q nao qeuro q entre no proxy

    uma duvida,,
    vc usa o ip-proxy do mk, para apontar o proxy linux??
    ou apenas com os redirecionamentos msm??
    vlws