Página 5 de 5 PrimeiroPrimeiro 12345
+ Responder ao Tópico



  1. Olá a todos, achei o script bem interessante e a interface dele ficou bem legal, só que havia ainda muitos bugs no codigo do script.... ele só funcionava em casos espcificos... testei ele e pra mim aconteciam muitos bugs... inclusive esse bug da pagina ficar em branco que os colegas já relataram... então resolvi inspecionar o codigo e fiz diversas correções e otimizações no mesmo... ainda existe algum bug... mas posso dizer que em 95% dos casos o script que estou postando agora deve funcionar... mantive os creditos do kandango e adicionei os meus... ... outra coisa tambem, não é mais necessario que esteja cadastrado o nome do cliente no access-list do radio, o script que fiz no lugar no nome pega o mac do cliente, então não interessa nomes, continuam necessarios os arquivos pixelverde.png e pixelvermelho.png que encontram-se disponiveis aqui no topico, esse arquivos tem que ficar na mesma pasta onde os html ficam hospedados, instruções de instalação seguem abaixo:

    1. Crie uma pasta para que você possa colocar o script dentro (é necessaria a pasta só para o script pois são criados varios arquivos ao rodar o script, ai pra evitar a bagunça deixa o script só dentro de uma pasta reservada)

    2. edite o script e modifique os campos abaixo:
    FTP_HOST = coloque o ip do radio a ser monitorado
    FTP_USER = usuario que fara acesso ao FTP do radio em questão
    FTP_PASS = senha para o ftp do radio
    NOMEAP = Nome do Radio a ser monitorado
    PAGINA = Nome do arquivo html que sera gerado
    PASTAFILES = endereço da pasta onde o script esta (onde serao gerados os arquivos temporarios)
    PASTAPAGINA = endereço da pasta onde sera gerado o html

    3. Adicione a seguinte configuração ao seu radio MK

    Código :
    /system scheduler
    add comment="" disabled=no interval=5m name="Gera Lista de Sinal" on-event=\
        "/interface wireless registration-table print stats file=sinal" \
        start-date=feb/03/2009 start-time=12:03:00
     
    /user group
    add name=pegasinal policy="ftp,!local,!telnet,!ssh,!reboot,!read,!write,!polic\
        y,!test,!winbox,!password,!web,!sniff"
     
    /user
    add address=0.0.0.0/0 comment="" disabled=no group=pegasinal name=[B]SEUUSER[/B]

    PS: Onde tem SEUUSER substitua pelo nome que você quer para o usuario que vai fazer o login ao FTP.

    Depois é só colocar uma senha para esse usuario.

    4. Por ultimo adicione um agendamento na maquina linux para que o script seja executado de 5 em 5 minutos... dessa forma:

    */5 * * * * root /PASTA/DO/SEU/SCRIPT/scriptsinal

    OBS: É importante que a pasta que você vão escolher para a saida do arquivo html seja uma pasta acessivel pelo seu webserver, caso contrario (obvio) não conseguirão acessar o relatorio.

    O arquivo do script está em anexo, é isso espero que gostem, até mais.
    Arquivos Anexos Arquivos Anexos

  2. Citação Postado originalmente por TheHawk Ver Post
    Olá a todos, achei o script bem interessante e a interface dele ficou bem legal, só que havia ainda muitos bugs no codigo do script.... ele só funcionava em casos espcificos... testei ele e pra mim aconteciam muitos bugs... inclusive esse bug da pagina ficar em branco que os colegas já relataram... então resolvi inspecionar o codigo e fiz diversas correções e otimizações no mesmo... ainda existe algum bug... mas posso dizer que em 95% dos casos o script que estou postando agora deve funcionar... mantive os creditos do kandango e adicionei os meus... ... outra coisa tambem, não é mais necessario que esteja cadastrado o nome do cliente no access-list do radio, o script que fiz no lugar no nome pega o mac do cliente, então não interessa nomes, continuam necessarios os arquivos pixelverde.png e pixelvermelho.png que encontram-se disponiveis aqui no topico, esse arquivos tem que ficar na mesma pasta onde os html ficam hospedados, instruções de instalação seguem abaixo:

    1. Crie uma pasta para que você possa colocar o script dentro (é necessaria a pasta só para o script pois são criados varios arquivos ao rodar o script, ai pra evitar a bagunça deixa o script só dentro de uma pasta reservada)

    2. edite o script e modifique os campos abaixo:
    FTP_HOST = coloque o ip do radio a ser monitorado
    FTP_USER = usuario que fara acesso ao FTP do radio em questão
    FTP_PASS = senha para o ftp do radio
    NOMEAP = Nome do Radio a ser monitorado
    PAGINA = Nome do arquivo html que sera gerado
    PASTAFILES = endereço da pasta onde o script esta (onde serao gerados os arquivos temporarios)
    PASTAPAGINA = endereço da pasta onde sera gerado o html

    3. Adicione a seguinte configuração ao seu radio MK

    Código :
    /system scheduler
    add comment="" disabled=no interval=5m name="Gera Lista de Sinal" on-event=\
        "/interface wireless registration-table print stats file=sinal" \
        start-date=feb/03/2009 start-time=12:03:00
     
    /user group
    add name=pegasinal policy="ftp,!local,!telnet,!ssh,!reboot,!read,!write,!polic\
        y,!test,!winbox,!password,!web,!sniff"
     
    /user
    add address=0.0.0.0/0 comment="" disabled=no group=pegasinal name=[B]SEUUSER[/B]
    PS: Onde tem SEUUSER substitua pelo nome que você quer para o usuario que vai fazer o login ao FTP.

    Depois é só colocar uma senha para esse usuario.

    4. Por ultimo adicione um agendamento na maquina linux para que o script seja executado de 5 em 5 minutos... dessa forma:

    */5 * * * * root /PASTA/DO/SEU/SCRIPT/scriptsinal

    OBS: É importante que a pasta que você vão escolher para a saida do arquivo html seja uma pasta acessivel pelo seu webserver, caso contrario (obvio) não conseguirão acessar o relatorio.

    O arquivo do script está em anexo, é isso espero que gostem, até mais.
    TheHawk,

    Parabéns pelas alterações, está bem mais otimizado!



  3. ate hoje nao consegui fazer funcionar, alguem pode me ajudar ?






Tópicos Similares

  1. Respostas: 3
    Último Post: 01-08-2017, 21:08
  2. Respostas: 1
    Último Post: 27-03-2011, 22:19
  3. Script Web Pronto Para Monitorar Sinal
    Por Kandango no fórum Redes
    Respostas: 27
    Último Post: 20-08-2008, 08:47
  4. Respostas: 11
    Último Post: 07-05-2008, 10:45
  5. Script para inclusão de clientes em servidor fedora 5
    Por fenix_se no fórum Linguagens de Programação
    Respostas: 0
    Último Post: 20-11-2006, 19:43

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L