+ Responder ao Tópico



  1. #1

    Padrão Como Liberar Banda Apenas nos Fins de Semana

    Olá Pessoal,
    Sou novo aqui no forum e estou precisando muito de uma informação. Uso um servidor mikrotik e faço o controle de banda dos clientes. Já criei scripts para liberar a banda das 22:00 h às 8:00 h do dia seguinte e funciona perfeitamente. Agora gostaria de criar uma regra/script para liberar a banda nos sabados e domingos até as 16:00 h, ou seja, libera sexta feira as 22:00 e volta a limitar a partir das 16:00 do sabado...
    Resumindo, quero liberar a banda nos sabados e domingos durante uma parte do dia.
    Me ajudem ai pessoal, pois nao encontrei nenhum script relacionado neste caso especifico.
    Ficarei muito grato. Desde já agradeço a todos !!

  2. #2
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Citação Postado originalmente por ROBERTO123 Ver Post
    Olá Pessoal,
    Sou novo aqui no forum e estou precisando muito de uma informação. Uso um servidor mikrotik e faço o controle de banda dos clientes. Já criei scripts para liberar a banda das 22:00 h às 8:00 h do dia seguinte e funciona perfeitamente. Agora gostaria de criar uma regra/script para liberar a banda nos sabados e domingos até as 16:00 h, ou seja, libera sexta feira as 22:00 e volta a limitar a partir das 16:00 do sabado...
    Resumindo, quero liberar a banda nos sabados e domingos durante uma parte do dia.
    Me ajudem ai pessoal, pois nao encontrei nenhum script relacionado neste caso especifico.
    Ficarei muito grato. Desde já agradeço a todos !!
    Tem jeito de vc me passar as regras que vc usa pra liberar por horario??

    Aki quero liberar a banda das meia noite ate as 6 da manha...

    falow forte abraço



  3. #3

    Padrão

    Aqui vai o script para banda total liberada de 00:00 ás 6:00, todos os dias. Executando-a automaticamente. Você ajusta ela de acordo com suas necessidades:

    SCRIPTS DE LIBERAÇÃO DE BANDA (habilita e desabilita):

    / system script

    add name="queue_disable" source="/queue simple { disable \[find \
    name=LIBERA_TUDO\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
    add name="queue_enable" source="/queue simple { enable \[find \
    name=LIBERA_TUDO\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password

    AGENDAMENTO:

    / system scheduler

    add name="enable" on-event=queue_enable start-date=jan/21/2006 \
    start-time=00:00:01 interval=1d comment="" disabled=no
    add name="disable" on-event=queue_disable start-date=jan/21/2006 \
    start-time=06:00:01 interval=1d comment="HABILITA E DESABILITA TODA A \
    BANDA" disabled=no

    REGRA DE LIBERAÇÃO DA BANDA:

    / queue simple
    add name="LIBERA_TUDO" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 \
    interface=all parent=none direction=both priority=8 \
    queue=default-small/default-small limit-at=0/0 max-limit=6000000/6000000 \
    total-queue=default-small disabled=yes

    Resumindo:

    1 regra são os scripts para ligar e desligar a regra de liberação de banda.

    2 regra são os agenda mentos. Liga ás 00:00 e desliga ás 06:00, todos os dias.

    3 regra é o quanto de banda vai ser liberado. No exemplo acima são 6MB de up e down para todo mundo.



    Att, Roberto

  4. #4

    Padrão

    Gostei dessa regra tua ai,ela funciona em hotspot?



    Citação Postado originalmente por ROBERTO123 Ver Post
    Olá Pessoal,
    Sou novo aqui no forum e estou precisando muito de uma informação. Uso um servidor mikrotik e faço o controle de banda dos clientes. Já criei scripts para liberar a banda das 22:00 h às 8:00 h do dia seguinte e funciona perfeitamente. Agora gostaria de criar uma regra/script para liberar a banda nos sabados e domingos até as 16:00 h, ou seja, libera sexta feira as 22:00 e volta a limitar a partir das 16:00 do sabado...
    Resumindo, quero liberar a banda nos sabados e domingos durante uma parte do dia.
    Me ajudem ai pessoal, pois nao encontrei nenhum script relacionado neste caso especifico.
    Ficarei muito grato. Desde já agradeço a todos !!



  5. #5

    Padrão

    Citação Postado originalmente por gulinhaster Ver Post
    Gostei dessa regra tua ai,ela funciona em hotspot?
    Para fazer isto no hotspot tens que chamar a regra usando a aba scripts do profile dos usuários

  6. #6

    Padrão

    Teria cmo vc me dizer como faz isso?


    Citação Postado originalmente por Mr. RG Ver Post
    Para fazer isto no hotspot tens que chamar a regra usando a aba scripts do profile dos usuários



  7. #7

    Padrão

    Citação Postado originalmente por gulinhaster Ver Post
    Teria cmo vc me dizer como faz isso?
    No profile do usuário tem a aba script.

    Ex:

    Você criar os scripts no sub-menu: /system script
    e colocar o nome de des-banda para desativar o controle.

    Na aba scripts do profile users tem duas opções: uma para quando ele logar (se bem me lembro, onlogin) e outro para quando deslogar.

    Quando ele logar ele irá chamar o script des-banda e quando ele deslogar, você poderá colocar o qualquer script.

    No script é que vai está as verificações de data e tudo mais.

  8. #8

    Padrão

    Valeu pela sua atenção mas estou apenas começando,ainda não sei como fazer isso ai não,é muito dificil?
    Tem algum tutorial de como fazer?
    Citação Postado originalmente por Mr. RG Ver Post
    No profile do usuário tem a aba script.

    Ex:

    Você criar os scripts no sub-menu: /system script
    e colocar o nome de des-banda para desativar o controle.

    Na aba scripts do profile users tem duas opções: uma para quando ele logar (se bem me lembro, onlogin) e outro para quando deslogar.

    Quando ele logar ele irá chamar o script des-banda e quando ele deslogar, você poderá colocar o qualquer script.

    No script é que vai está as verificações de data e tudo mais.



  9. #9

    Padrão

    Não é dificil, com algumas horas de leitura você conseguirá fazer isto aí.

    Aqui no under-linux.org tem alguns tópicos que o ajudarão e tem vários materiais no 4share.com. Só fazer a busca.

  10. #10

    Padrão

    Olá gulinhaster,

    Sou novo aqui no forum e apesar disso sou iniciante. Pra falar a verdade ainda nao sei para que serve o hotspot. Essa regra que postei encontrei aqui no forum.
    Agora estou precisando mesmo de liberar a banda nos fins de semana e ainda nao sei criar uma regra para isso. Neste caso peço a ajuda de voces para me ajudarem neste assunto.

    Ficarei muito agardecido por uma resposta e no que eu puder ajudar alguem estou a disposicao. Tenho poucas regras no meu MK mas já dá pra começar com um servidor. Obrigado !!



  11. #11

    Padrão

    Olha só amigo,
    Para liberar apenas nos fins de semana, você terá que fazer 2 schedulers (1 desativa e 1 ativa) com intervalo de 7 dias. Desses 2 schedulers, 1 irá chamar o script na sexta às 12 horas e o outro na segunda às 7 horas.

  12. #12

    Padrão

    Achei essa script que nosso amigo Catvbrasil fez,se eu colocar ela no meu hotspot funcionará,sendo que no caso eu poderia alterar somente a velocidade,data e horários?
    Mais uma coisa no caso ai ele derrubara todos que estiverem conectados no user profile que eu especifiquei ai ou ele somente alterará a velocidade?


    SCRIPTS DE LIBERAÇÃO DE BANDA (habilita e desabilita):

    / system script

    add name="libera_banda1" source="/ip hotspot user profile set 3 rate-limit="64k/128k" \
    policy=ftp,reboot,read,write,policy ,test,winbox,pa ssword
    add name="libera_banda2" source="/ip hotspot user profile set 4 rate-limit="32k/64k" \
    policy=ftp,reboot,read,write,policy ,test,winbox,pa ssword
    add name="desliga_banda1" source="/ip hotspot user profile set 3 rate-limit="48k/96k" \
    policy=ftp,reboot,read,write,policy ,test,winbox,pa ssword
    add name="desliga_banda2" source="/ip hotspot user profile set 4 rate-limit="32k/64k" \
    policy=ftp,reboot,read,write,policy ,test,winbox,pa ssword




    AGENDAMENTO:

    / system scheduler

    add name="enable" on-event=libera_banda1 start-date=jan/21/2006 \
    start-time=22:00:01 interval=1d comment="" disabled=no
    add name="disable" on-event=desliga_banda1 start-date=jan/21/2006 \
    start-time=08:00:01 interval=1d comment="HABILITA E DESABILITA A \
    BANDA1" disabled=no
    add name="enable" on-event=libera_banda2 start-date=jan/21/2006 \
    start-time=22:00:01 interval=1d comment="" disabled=no
    add name="disable" on-event=desliga_banda2 start-date=jan/21/2006 \
    start-time=08:00:01 interval=1d comment="HABILITA E DESABILITA A \
    BANDA2" disabled=no



  13. #13

    Padrão

    e funciona normal??? pois to precisando tambem.

    Citação Postado originalmente por Mr. RG Ver Post
    Para fazer isto no hotspot tens que chamar a regra usando a aba scripts do profile dos usuários

  14. #14

    Padrão

    Citação Postado originalmente por correarct Ver Post
    e funciona normal??? pois to precisando tambem.
    Funciona sim. Você pode também fazer os scripts e os schedulers.