+ Responder ao Tópico



  1. #1

    Padrão "Solução" para ping alto.

    Olá.
    Vou postar aqui a experiência que estou tendo com o MK há um ano e meio e deixar as conclusões que cheguei após muito quebrar a cabeça e quase desistir de usá-lo.

    Por mais de um ano o meu sistema passava por lentidão em horários não específicos (pings em torno de 3000ms), fiz tudo o que foi possível em questão a equipamento, troca de antenas, troca de RB´s, configurações colhidas aqui no fórum, ou seja, inúmeros testes e muito dinheiro.

    O que acontecia e acredito que aconteça com a maioria das pessoas que não estão tendo uma boa "convivência" com MK é o fato de que ele nos dá inúmeras opções de controles wireless, ou seja, ele "faz" o que configuramos, correto? Portanto é impossível que uma rede com níveis de sinal altos (aqui não aceito usuários acima de -75) e ack tb alto seja uma rede rápida (pings baixos), e não é problema com o MK ou a RB, ele está trabalhando para o que foi configurado, ele não faz "milagre".

    A solução aqui foi muito simples mas trabalhosa, configurei o MK simplismente para aceitar "usuários" com sinal perfeito, ack "aceitável", e lógico correria para corrigir os clientes que não se enquadravam. Infelizmente perdi alguns clientes pois em alguns lugares específicos não havia como ter um bom sinal e nesses casos o melhor é conversar e tentar alguma solução mesmo que seja indicando um concorrente, pois os outros pagam para obter qualidade.

    Quero deixar claro que esse foi o meu caso, mas que acabou com todos os problemas da rede, hj tenho cerca de 150 usuários simultâneos em três RB´s e ping em torno de 3ms em qualquer momento, sem falar que o telefone quase não toca mais.

    Espero ajudar aos tantos que estão passando por isso.
    Obrigado.

  2. #2

    Padrão

    Fiz isso aqui tb, ack somente abaixo de 50, sinal somente acima de -75, ainda tenho uns clientes com sinal ruim mas eu vou corrigir quando colocar a nova torre.

    Um problema grave que tenho aqui é interferencia, meus radios ficam na mesma torre que do concorrente, ele é um coitado unica coisa que sabe é usar amplificador, tenho que ficar procurando canal pra ver qual tá "melhor", além de ter adotado filtro de ruídos (se não tivesse colocado eu tinha muita dor de cabeça).

    Nestes momentos de grande interferencia, a latência oscila muito com grande perca de pacotes.



  3. #3

    Padrão

    O sinal nao manda quase nada .. se vc tiver um cliente com 79 snr e o troughput acima dos 2 mega pode ativar o que mata o cartao e clientes conectados abaixo de 1 mega sendo sinal forte ou fraco ..
    Eu tinha clientes a 100 metros do pop e estava com 400 k de troughput , fiz um apanhado geral e hoje tenho trafego de 2,5 mega em um cartao com 100 online e mais de 150 cadastrado em 1 so.
    O lance de interferencia seria usar setoriais boas e horizontais.

  4. #4

    Padrão

    Desculpem a ignorancia, mais só consigo ver estes resultados usando routerboard ou com placa wireless no pc né? se eu usar o MK em um pc e joga ele em um AP, não consigo ter estes resultados? ou teria? aonde consigo ver o ACK e o troughput dos clientes ?


    Obrigado



  5. #5

    Padrão

    voce deve ta ficando doido ? sinal nao manda quase nada ? huauhahuauhhua

    sinal ruim = retransmissão = CRC = queda no troughput !!!

    o ACK eh uma "feature" dos cartoes atheros... e outros fabricantes... eh um meio de temporizar os pacotes fazendo com que se tenha o maximo de troughput. ... ja os cartoes prism usam outro tipo de controle...


    aqui procuro manter menor sinal proximo de -65 ..

    Citação Postado originalmente por fernandolv Ver Post
    O sinal nao manda quase nada .. se vc tiver um cliente com 79 snr e o troughput acima dos 2 mega pode ativar o que mata o cartao e clientes conectados abaixo de 1 mega sendo sinal forte ou fraco ..
    Eu tinha clientes a 100 metros do pop e estava com 400 k de troughput , fiz um apanhado geral e hoje tenho trafego de 2,5 mega em um cartao com 100 online e mais de 150 cadastrado em 1 so.
    O lance de interferencia seria usar setoriais boas e horizontais.

  6. #6

    Padrão Scripts, quais?

    Quais os Scrpts, vc tem usado para fazer isso automaticamente?

    Tem como postar aqui?

    Obrigado



  7. #7

    Padrão

    Citação Postado originalmente por lurialonso Ver Post
    Olá.
    Vou postar aqui a experiência que estou tendo com o MK há um ano e meio e deixar as conclusões que cheguei após muito quebrar a cabeça e quase desistir de usá-lo.

    Por mais de um ano o meu sistema passava por lentidão em horários não específicos (pings em torno de 3000ms), fiz tudo o que foi possível em questão a equipamento, troca de antenas, troca de RB´s, configurações colhidas aqui no fórum, ou seja, inúmeros testes e muito dinheiro.

    O que acontecia e acredito que aconteça com a maioria das pessoas que não estão tendo uma boa "convivência" com MK é o fato de que ele nos dá inúmeras opções de controles wireless, ou seja, ele "faz" o que configuramos, correto? Portanto é impossível que uma rede com níveis de sinal altos (aqui não aceito usuários acima de -75) e ack tb alto seja uma rede rápida (pings baixos), e não é problema com o MK ou a RB, ele está trabalhando para o que foi configurado, ele não faz "milagre".

    A solução aqui foi muito simples mas trabalhosa, configurei o MK simplismente para aceitar "usuários" com sinal perfeito, ack "aceitável", e lógico correria para corrigir os clientes que não se enquadravam. Infelizmente perdi alguns clientes pois em alguns lugares específicos não havia como ter um bom sinal e nesses casos o melhor é conversar e tentar alguma solução mesmo que seja indicando um concorrente, pois os outros pagam para obter qualidade.

    Quero deixar claro que esse foi o meu caso, mas que acabou com todos os problemas da rede, hj tenho cerca de 150 usuários simultâneos em três RB´s e ping em torno de 3ms em qualquer momento, sem falar que o telefone quase não toca mais.


    Espero ajudar aos tantos que estão passando por isso.
    Obrigado.
    Amigo valeu as dicas, pois estou tendo esses problemas tambem pra falar a verdade estava chegando a conclusão que o mikrotic não funcionava muito bem pois a dor de cabeça foi grande, mas com a sua dica vou rever meus problemas, outra coisa como vc faz pra não aceitar a conexão de cliente ruim, ou seja com o sinal ruim??


    Valeu a dica!

    Muito obrigado pela atenção!


    Um forte abraçooo!!!

  8. #8

    Padrão "Não aceitar"

    É só vc setar o ack para o número desejado (lembre-se que cada rede "funciona" de uma forma), que o MK não permite a navegação se o usuário estiver acima desse número, prefiro assim pois se eu setar para o cliente só conectar por exemplo com -70 e ele estiver acima o Mk vai ficar "barrando", e talvés provoque lentidão.



  9. #9
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão

    Amigo, copia esse script exatamente como está, so altere os campos que coloquei em vermelho, ou seja, vc vai criar um script para cada wlan (wlan1, wlan2 ou o nome que vc da para suas wlans) que vc tem e ele só vai atuar nos clientes que estiverem com ACK acima de 60 ou o valor que vc determinar.

    Obs: Já testei e funciona normalmente nas seguintes versões: 2.9.27, 2.9.48, 2.9.51, 3.10, 3.11, 3.12, e 3.13

    # Defina abaixo o valor mínimo de ACK
    :global ack 60;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 1;
    # Defina abaixo 1 para reiniciar a Interface quando um cliente estiver acima do valor mínimo e 0 para não fazer nada
    # Obs.: Ative apenas no último dos casos, pois derruba todos clientes enlaçados na Interface
    :global intdis 0;
    # Defina abaixo a Interface
    :global interf "wlan1";
    #-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info ("Listando Clientes com ACK acima de " . $ack . " us:");
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :log info ("COMENTARIO: " . [/interface wireless access-list get $cliente comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    /interface wireless access-list enable $cliente;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info ("Nenhum Cliente com ACK acima de " . $ack . " us encontrado.");
    } else {
    :if ($intdis = 1) do={
    /interface wireless disable $interf;
    /interface wireless enable $interf;
    };
    };



    Citação Postado originalmente por geovane Ver Post
    Quais os Scrpts, vc tem usado para fazer isso automaticamente?

    Tem como postar aqui?

    Obrigado

  10. #10

    Padrão

    E sobre os clientes trafegarem abaixo de 11mbps, eu aqui procuro travar todos no MK e no radio do cliente em 11 mpbs. Se nos teste ficar ruim nao instalo, procuro manter a rede todas aos máximo em 11.



  11. #11

    Padrão

    Citação Postado originalmente por magal Ver Post
    Amigo, copia esse script exatamente como está, so altere os campos que coloquei em vermelho, ou seja, vc vai criar um script para cada wlan (wlan1, wlan2 ou o nome que vc da para suas wlans) que vc tem e ele só vai atuar nos clientes que estiverem com ACK acima de 60 ou o valor que vc determinar.

    Obs: Já testei e funciona normalmente nas seguintes versões: 2.9.27, 2.9.48, 2.9.51, 3.10, 3.11, 3.12, e 3.13

    # Defina abaixo o valor mínimo de ACK
    :global ack 60;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 1;
    # Defina abaixo 1 para reiniciar a Interface quando um cliente estiver acima do valor mínimo e 0 para não fazer nada
    # Obs.: Ative apenas no último dos casos, pois derruba todos clientes enlaçados na Interface
    :global intdis 0;
    # Defina abaixo a Interface
    :global interf "wlan1";
    #-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info ("Listando Clientes com ACK acima de " . $ack . " us:");
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :log info ("COMENTARIO: " . [/interface wireless access-list get $cliente comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    /interface wireless access-list enable $cliente;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info ("Nenhum Cliente com ACK acima de " . $ack . " us encontrado.");
    } else {
    :if ($intdis = 1) do={
    /interface wireless disable $interf;
    /interface wireless enable $interf;
    };
    };




    Mto bom mesmo! Parabéns pelo dica!

  12. #12

    Padrão

    Citação Postado originalmente por magal Ver Post
    Amigo, copia esse script exatamente como está, so altere os campos que coloquei em vermelho, ou seja, vc vai criar um script para cada wlan (wlan1, wlan2 ou o nome que vc da para suas wlans) que vc tem e ele só vai atuar nos clientes que estiverem com ACK acima de 60 ou o valor que vc determinar.

    Obs: Já testei e funciona normalmente nas seguintes versões: 2.9.27, 2.9.48, 2.9.51, 3.10, 3.11, 3.12, e 3.13

    # Defina abaixo o valor mínimo de ACK
    :global ack 60;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 1;
    # Defina abaixo 1 para reiniciar a Interface quando um cliente estiver acima do valor mínimo e 0 para não fazer nada
    # Obs.: Ative apenas no último dos casos, pois derruba todos clientes enlaçados na Interface
    :global intdis 0;
    # Defina abaixo a Interface
    :global interf "wlan1";
    #-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info ("Listando Clientes com ACK acima de " . $ack . " us:");
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :log info ("COMENTARIO: " . [/interface wireless access-list get $cliente comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    /interface wireless access-list enable $cliente;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info ("Nenhum Cliente com ACK acima de " . $ack . " us encontrado.");
    } else {
    :if ($intdis = 1) do={
    /interface wireless disable $interf;
    /interface wireless enable $interf;
    };
    };
    Amigo,
    Só não entendi direito como esse script funciona... desculpa se a pergunta for meio boboa.. mas oq ue ele faz exatamente, bloqueio os clientes com ack acima sem interferir nos outros conectados ou reinicia a interface com frequencia atrapalhando quem está conectado com ack baixo?

    Obrigado!
    Abs



  13. #13
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão

    So atua nos clientes com ACK acima do que você determinou e não derruba o restante.

    Se colocar global intdis= 1 ai derruba a interface.

  14. #14

    Padrão

    Citação Postado originalmente por magal Ver Post
    So atua nos clientes com ACK acima do que você determinou e não derruba o restante.

    Se colocar global intdis= 1 ai derruba a interface.

    Amigo,
    Vou colocar esse seu scripr em prática, mas ainda tenho duas dúvidas:
    -qual a diferença entre rodar esse script e setar o ack manuamente?
    - basta rodá-lo uma vez no terminal ou tenho que agendar para que ele rode várias vezes durante o dia?

    Mais uma vez muito obrigado!
    Abs



  15. #15

    Padrão

    Rodei o scrpt no terminal, mas acho que não resolveu pq tem clientes bem acima do ack global que eu setei...
    Não fiz alguma coisa direito...rs