+ Responder ao Tópico

  1. #106
    Não Registrado
    Citação Postado originalmente por keniocesar Ver Post
    Qdo minha versao era 2.x tbm funcionava legal, agora eu uso a 3.x passa ai o seu script


    #int-DDNS.Info
    /tool dns-update name=seu host criado no changeip address=127.0.0.255 key-name=seu usuário key="sua senha"

    em usuário e senha são os seus dados do changeip, ou DDNS. Lembrando que na versão 2x eu uso o script do Magrock, e este na versão 3x. Ambos estão rodando legalzinho

    QQ dúvidas estamos ai Keniocesar

  2. Keniocesar.

    Para a versão 3x eu uso esse script aqui, ta funcionando blza
    segue:

    #int-DDNS.Info
    /tool dns-update name=seu host criado address=127.0.0.255 key-name=seu usuário DDNS key="sua senha"

    QQ dúvida poste ai



  3. Citação Postado originalmente por bennthiago Ver Post
    Keniocesar.

    Para a versão 3x eu uso esse script aqui, ta funcionando blza
    segue:

    #int-DDNS.Info
    /tool dns-update name=seu host criado address=127.0.0.255 key-name=seu usuário DDNS key="sua senha"

    QQ dúvida poste ai
    tabem posso usa na versao 2.9.27 se sim ,, como..

  4. Citação Postado originalmente por magrock Ver Post
    E o seguinte, rodando pelo forum encontrei dois scripts postados neste topico aqui:
    http://under-linux.org/forums/mikrot...no-mk-3-x.html
    e os companheiros postaram dois scripts o qual são estes aqui:
    Código:
    # Define User Variables
    :global ddnsuser "usuario"
    :global ddnspass "senha"
    :global ddnshost "host.changeip.org"
    # Define Global Variables
    :global ddnsip
    :global ddnslastip
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
    :global ddnsinterface
    :global ddnssystem ("mt-" . [/system package get system version] )
    # Define Local Variables
    :local int
    # Loop thru interfaces and look for ones containing
    # default gateways without routing-marks
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={ 
      :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
         :global ddnsinterface [/ip route get $int interface]
      } 
    }
    # Grab the current IP address on that interface.
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
    # Did we get an IP address to compare?
    :if ([ :typeof $ddnsip ] = nil ) do={
       :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={
      :if ($ddnsip != $ddnslastip) do={
        :log info "DDNS: Sending UPDATE!"
        :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
        :global ddnslastip $ddnsip
      } else={ 
        :log info "DDNS: No update required."
      }
    }
    # End of script
    e este:
    Código:
    #int-DDNS.Info
    /tool dns-update name=usuario.ddns.info address=127.0.0.255 key-name=usuario key="senha"
    vejam ae e informem se funcionou, o primeiro script o nosso amigo Minelli Afirmou que o script funciona no MK3.x tranquilamente, e o segundo script tivemos 2 afirmações uma do amigo NeyDourado e InfinityWifi,o qual disseram que funciona tanto no 2.x quanto no 3.x, não esqueçam de agradece-los pelas soluções. A União faz a força e o Açucar !!
    http://under-linux.org/forums/mikrot...no-mk-3-x.html


    Valeu pela ajuda brother!!! O script funcinou!!!
    Valeu!!!

  5. Valeu pela ajuda!!!






Tags para este Tópico

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L