+ Responder ao Tópico

  1. amigo minha RB450g com balance PCC nao funciona o script DDNS .
    segue minhas regras abaixo.
    Código :
    # Define User Variables
    :global ddnsuser "dimensao.ddnsxxxx"
    :global ddnspass "conselho"
    :global ddnshost "dimensao.ddnsxxxxx"
     
    # Define Global Variables
    :global ddnsip
    :global ddnslastip
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
    :global ddnsinterface
    :global ddnssystem ("mt-" . [/system package get system version] )
    # Define Local Variables
    :local int
    # Loop thru interfaces and look for ones containing
    # default gateways without routing-marks
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={ 
      :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
         :global ddnsinterface [/ip route get $int interface]
      } 
    }
    # Grab the current IP address on that interface.
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
    # Did we get an IP address to compare?
    :if ([ :typeof $ddnsip ] = nil ) do={
       :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={
      :if ($ddnsip != $ddnslastip) do={
        :log info "DDNS: Sending UPDATE!"
        :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
        :global ddnslastip $ddnsip
      } else={ 
        :log info "DDNS: No update required."
      }
    }
    # End of script


    por favor mim ajudem peciso muito estou deixando um printe em anexo.
    Anexo 9906
    Última edição por osmano807; 20-05-2010 às 09:31.


  2.    Publicidade


  3. Bom dia a todos.
    Meu script não funciona de jeito nenhum, abaixo a minha configuração.
    Mikrotik versão 4.9 (pc)
    4 Adsl com IP fixo.
    modem em bridge.
    Clientes acessam determinada adsl devido a marcação de pacotes.
    não uso proxy.
    as 4 adsl estão mascaradas.

    Resumindo, meu script nem executa, não tenho nem como saber onde está o erro.

    usei o script aqui do site e também tentei o que está no site do mikrotik mesmo, nenhum deles executa.
    Se alguem tiver uma idéia do que pode ser agradeço.

    Abraço a todos.

  4. Fala aí amigão! ( ISOLIVEIRA ) Obrigado pela sua resposta, mas o redirecionamento com o NAT ñ funcionou, vc teria outra solução ou poderia postar essas regras para mim. Valeu!!!
    Última edição por shinobi; 20-05-2010 às 16:22.

  5. Muito obrigado estava procurando este tutorial em português já faz algum tempo...
    Vou aplicar em meu server e retorno com o resultado.

  6. Muito boa a iniciativa, show de bola.

    Parabéns!!!




Tags para este Tópico

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L