+ Responder ao Tópico

  1. Galera, efetuei toda a configuração e quando termino a configuração efetuo o texte e da certo, mas qnd reinicio o servidor ai não funciona mais, meu eu não possuo link dedicado e sendo assim meu ip não é fixo.
    Como posso fazer para resolver esse problema, pois o ip não é atualizado no changeip.com
    :global ddns-host "*****"
    :global ddns-interface "Aqui n tenho certeza de qual nome,"

    Sera o nome que eu atribui a minha interface que sai para internet ou o nome da interface que faz autenticação com o provedor de internet?
    Grato.

    Clique na imagem para uma versão maior

Nome:	         ddnsconf.jpg
Visualizações:	86
Tamanho: 	49,8 KB
ID:      	19213


  2.    Publicidade


  3. Olha so, acho que aqui fica melhor o script
    Relembrando que não posuo ip fixo, e no changeip ele não esta atualizando automatico, sempre que vou la e refaço o procedimento consigo conectar normalmente... so que reiniciei o servidor ou entao alterei o ip ai ja era n conecta mais

    :log info "DDNS: Begin"
    :global ddns-user "flavio***"
    :global ddns-pass "********"
    :global ddns-host "nevesti.ddns.***" aqui o end fornecido pela changeip
    :global ddns-interface "Link" ja a interface de conexao com a internet e nada...

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

  4. vc esta se esquecendo do schedule para programar para atualizar
    vá em system script e de esse comando
    /system scheduler
    add comment="" disabled=no interval=8m10s name=schedule1 on-event=\
    "/system script run nome do seu script" policy=read start-date=jan/01/1970 start-time=\
    00:00:00
    se te ajudei clique na estrelinha hehehe
    Citação Postado originalmente por flavioneves Ver Post
    Olha so, acho que aqui fica melhor o script
    Relembrando que não posuo ip fixo, e no changeip ele não esta atualizando automatico, sempre que vou la e refaço o procedimento consigo conectar normalmente... so que reiniciei o servidor ou entao alterei o ip ai ja era n conecta mais

    :log info "DDNS: Begin"
    :global ddns-user "flavio***"
    :global ddns-pass "********"
    :global ddns-host "nevesti.ddns.***" aqui o end fornecido pela changeip
    :global ddns-interface "Link" ja a interface de conexao com a internet e nada...

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

  5. olha aconsrho vc resetar seu modem e refazer o processo auqalquer coisa me add no msn djjeantechno@hotmail.com
    Citação Postado originalmente por claudinhohw Ver Post
    Fala ai galera to desde segunda-feira tentando fazer esse acesso remoto e nada já fiz inúmeras tentativas alias fiz todas e não deu certo ainda meu ultimo script foi este aki
    # Set needed variables
    :local username "claudinhohw"
    :local password "********"
    :local hostname "claudinhohw.ddns.info"
    :global systemname [/system identity get name]

    :if ($systemname = "Site1" ) do= {
    :set hostname "yourdomain1.dyndns.org"
    }
    :if ($systemname = "Site2" ) do= {
    :set hostname "yourdomain2.dyndns.org"
    }
    :if ($systemname = "Site3" ) do= {
    :set hostname "yourdomain3.dyndns.org"
    }

    :global dyndnsForce
    :global previousIP

    # print some debug info
    :log info ("UpdateDynDNS: username = $username")
    :log info ("UpdateDynDNS: password = $password")
    :log info ("UpdateDynDNS: hostname = $hostname")
    :log info ("UpdateDynDNS: previousIP = $previousIP")

    # get the current IP address from the internet (in case of double-nat)
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]

    # parse the current IP result
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "</body>" -1]
    :local currentIP [ick $result $startLoc $endLoc]
    :log info "UpdateDynDNS: currentIP = $currentIP"

    # Remove the # on next line to force an update every single time - useful for debugging, but you could end up getting blacklisted by DynDNS!
    #:set dyndnsForce true

    # Determine if dyndns update is needed
    # more dyndns updater request details available at DynDNS.com - Support -- Developers' Connection -- Update Specifications: Perform Update
    :if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
    :set dyndnsForce false
    :set previousIP $currentIP
    /tool fetch user=$username password=$password mode=http address="members.dyndns.org" src- path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
    :local result [/file get dyndns.txt contents]
    :log info ("UpdateDynDNS: Dyndns update needed")
    :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
    ut ("Dyndns Update Result: ".$result)
    } else={
    :log info ("UpdateDynDNS: No dyndns update needed")
    }
    Meu MK é V.3.25, já alterei até o modem mais não consegui nada ainda gostaria da ajuda de vcs meu modem e um Dlink 500b ADSL 2+, roteado tenho internet de 8mb nele....
    obs: eu estou na mesma rede que estou testando o acesso remoto tem alguma coisa a ver?
    Segue a imagem de como esta os erros...
    http://thumbnails32.imagebam.com/926...a692604968.jpg http://thumbnails31.imagebam.com/926...c792604974.jpg http://thumbnails28.imagebam.com/926...6392604985.jpg http://thumbnails32.imagebam.com/926...c392604996.jpg

    desde já agradeço ajuda de todos

  6. djjeantechno

    O problema não é a execução do script e sim na atualização do ip junto ao change ip..
    A execução via scheduler eu consegui normalmente, tem que deixar as caixas de dialogo policy marcadas, exceto a do password e a reset...

    Agora o problema é na atualização do ip junto ao site....




Tags para este Tópico

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L