+ Responder ao Tópico



  1. Galera, efetuei toda a configuração e quando termino a configuração efetuo o texte e da certo, mas qnd reinicio o servidor ai não funciona mais, meu eu não possuo link dedicado e sendo assim meu ip não é fixo.
    Como posso fazer para resolver esse problema, pois o ip não é atualizado no changeip.com
    :global ddns-host "*****"
    :global ddns-interface "Aqui n tenho certeza de qual nome,"

    Sera o nome que eu atribui a minha interface que sai para internet ou o nome da interface que faz autenticação com o provedor de internet?
    Grato.

    Clique na imagem para uma versão maior

Nome:	         ddnsconf.jpg
Visualizações:	90
Tamanho: 	49,8 KB
ID:      	19213

  2. Olha so, acho que aqui fica melhor o script
    Relembrando que não posuo ip fixo, e no changeip ele não esta atualizando automatico, sempre que vou la e refaço o procedimento consigo conectar normalmente... so que reiniciei o servidor ou entao alterei o ip ai ja era n conecta mais

    :log info "DDNS: Begin"
    :global ddns-user "flavio***"
    :global ddns-pass "********"
    :global ddns-host "nevesti.ddns.***" aqui o end fornecido pela changeip
    :global ddns-interface "Link" ja a interface de conexao com a internet e nada...

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"



  3. vc esta se esquecendo do schedule para programar para atualizar
    vá em system script e de esse comando
    /system scheduler
    add comment="" disabled=no interval=8m10s name=schedule1 on-event=\
    "/system script run nome do seu script" policy=read start-date=jan/01/1970 start-time=\
    00:00:00
    se te ajudei clique na estrelinha hehehe
    Citação Postado originalmente por flavioneves Ver Post
    Olha so, acho que aqui fica melhor o script
    Relembrando que não posuo ip fixo, e no changeip ele não esta atualizando automatico, sempre que vou la e refaço o procedimento consigo conectar normalmente... so que reiniciei o servidor ou entao alterei o ip ai ja era n conecta mais

    :log info "DDNS: Begin"
    :global ddns-user "flavio***"
    :global ddns-pass "********"
    :global ddns-host "nevesti.ddns.***" aqui o end fornecido pela changeip
    :global ddns-interface "Link" ja a interface de conexao com a internet e nada...

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

  4. olha aconsrho vc resetar seu modem e refazer o processo auqalquer coisa me add no msn djjeantechno@hotmail.com
    Citação Postado originalmente por claudinhohw Ver Post
    Fala ai galera to desde segunda-feira tentando fazer esse acesso remoto e nada já fiz inúmeras tentativas alias fiz todas e não deu certo ainda meu ultimo script foi este aki
    # Set needed variables
    :local username "claudinhohw"
    :local password "********"
    :local hostname "claudinhohw.ddns.info"
    :global systemname [/system identity get name]

    :if ($systemname = "Site1" ) do= {
    :set hostname "yourdomain1.dyndns.org"
    }
    :if ($systemname = "Site2" ) do= {
    :set hostname "yourdomain2.dyndns.org"
    }
    :if ($systemname = "Site3" ) do= {
    :set hostname "yourdomain3.dyndns.org"
    }

    :global dyndnsForce
    :global previousIP

    # print some debug info
    :log info ("UpdateDynDNS: username = $username")
    :log info ("UpdateDynDNS: password = $password")
    :log info ("UpdateDynDNS: hostname = $hostname")
    :log info ("UpdateDynDNS: previousIP = $previousIP")

    # get the current IP address from the internet (in case of double-nat)
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]

    # parse the current IP result
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "</body>" -1]
    :local currentIP [ick $result $startLoc $endLoc]
    :log info "UpdateDynDNS: currentIP = $currentIP"

    # Remove the # on next line to force an update every single time - useful for debugging, but you could end up getting blacklisted by DynDNS!
    #:set dyndnsForce true

    # Determine if dyndns update is needed
    # more dyndns updater request details available at DynDNS.com - Support -- Developers' Connection -- Update Specifications: Perform Update
    :if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
    :set dyndnsForce false
    :set previousIP $currentIP
    /tool fetch user=$username password=$password mode=http address="members.dyndns.org" src- path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
    :local result [/file get dyndns.txt contents]
    :log info ("UpdateDynDNS: Dyndns update needed")
    :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
    ut ("Dyndns Update Result: ".$result)
    } else={
    :log info ("UpdateDynDNS: No dyndns update needed")
    }
    Meu MK é V.3.25, já alterei até o modem mais não consegui nada ainda gostaria da ajuda de vcs meu modem e um Dlink 500b ADSL 2+, roteado tenho internet de 8mb nele....
    obs: eu estou na mesma rede que estou testando o acesso remoto tem alguma coisa a ver?
    Segue a imagem de como esta os erros...
    http://thumbnails32.imagebam.com/926...a692604968.jpg http://thumbnails31.imagebam.com/926...c792604974.jpg http://thumbnails28.imagebam.com/926...6392604985.jpg http://thumbnails32.imagebam.com/926...c392604996.jpg

    desde já agradeço ajuda de todos



  5. djjeantechno

    O problema não é a execução do script e sim na atualização do ip junto ao change ip..
    A execução via scheduler eu consegui normalmente, tem que deixar as caixas de dialogo policy marcadas, exceto a do password e a reset...

    Agora o problema é na atualização do ip junto ao site....

  6. Bom topico mas tem um problema toda vez que seu roteador desligar vc vai ter que atualizr no site do ipchanger



  7. Estou tentando desenvolvar uma foma de ele auto localizar o ip fornecido pela operadora

  8. Obrigado, Muito simples e objetivo, Vlw Pela iniciativa.



  9. Pessoal, também estou penando pra conseguir acesso usando ip dinâmico com modem roteado (3com 812 officce conect). Por isso gostaria da ajuda de você;

    usei varios scripts e não cnsegui nada...ja devo ter cadastro em todos os dns e não obtive resultado.
    Uso o ddns.com.br da winco e obtenho atualização de ip normalmente, inclusive consigo estabeler conexão remota e acessa meu modem(812) pelo ddns.

    Meu MK é versão 5.0 e por ultimo coloquei o seguinte script:
    #int-DDNS.Info
    /tool dns-update name=usuario.ddns.com.br address=127.0.0.255 key-name=infottecnica key="*********"

    Bom depois disso quando rodo o script ele da a msg "DNS update succesfull", ou seja, o ip foi atualizado pelo script, porém ao tentar conecta remotamente pelo winbox ele não acessa e diz que não foi possivel acessar o indice, porém, resolve o dns e me da meu ip junto com a msg.
    Alguem pode me dizer como acessar a RB utilizando esse modem?

  10. ola amigo - vi que o post aqui inicial foi bem postado e tá funcionando BEM para muitos, exceto pra vc, ok.
    não sei dizer se vai resolver o seu caso -eu uso o DLINK DSL500B (BRIDGE)
    LAN dele ip: 192.168.254.254 (mude para o ip de acesso do seu moden) -
    ENTRA NO Dynamic DNS >> WWW.DDNS.US > How-To (direciona para changeip) E CRIA sua conta ATIVA E FAZ TUDO BELEZINHA, OK - depois CLIKA EM FREE DNS - ADICONA O SEU DOMÍNIO, OK.

    no script do meu MK está assim: tool dns-update name=meudominiocriado.ddns.us address=192.168.254.254 key-name=meuusuário key="minhasenha"

    marca o script e manda RUN, ok.

    ja no sheduller está assim na janela:
    -name = DDNS
    -start date = Jan/01/1970
    -start time = 00:00:00
    -interval = 00:15:00
    -NO EVENT = ddns

    manda aplly e OK

    NÃO PRECISA MEXER NADA NO SEU MODEN.

    AGORA DIGITA O SEU DOMINIO CRIADO TIPO : seudominio.ddns.us no WINBOX e entra com sua senha normal do servidor. se funcionou - blz.
    boa sorte.

    E OBRIGADO PELA INICIATIVA DO NOSSO AMIGO ACIMA QUE POSTOU AQUI ESTE MATERIAL TÃO BOM.



  11. eu adicionei o scipt, pelo mk aparentemente esta tudo ok. sendo q quando faço os testes o winbox nao entra. foi no change ip pra conferir e observei que o change ip nao estava atualizando o IP. ou seja, permaneceu com o mesmo ip do dia que fiz a conta. aparentemente no mk esta tudo certo. o tempo roda. deu tudo ok. o que pode ser isso?

  12. Bom dia, depois de um grande esforco e pesquisa srrsrs brincadeira muito simples a solucao do amigo... apenas adicionei isso aqui em script: #int-DDNS.Info
    /tool dns-update name=usuario.ddns.info address=127.0.0.255 key-name=usuario key="senha"
    editei colocando meu dominio usuario e senha.... pronto ficou show ateh agora nao deu defeito... estou usando mk 4.17



  13. também estou usando esse há uns 7meses e não tenho problema algum uso o mk 4.11

  14. Citação Postado originalmente por peritinaicos Ver Post
    Bom dia, depois de um grande esforco e pesquisa srrsrs brincadeira muito simples a solucao do amigo... apenas adicionei isso aqui em script: #int-DDNS.Info
    /tool dns-update name=usuario.ddns.info address=127.0.0.255 key-name=usuario key="senha"
    editei colocando meu dominio usuario e senha.... pronto ficou show ateh agora nao deu defeito... estou usando mk 4.17
    Acabei de testar na rb750 com mk 5.2 também rodou normalmente... excelente soluçao... vlw

  15. Citação Postado originalmente por peritinaicos Ver Post
    Bom dia, depois de um grande esforco e pesquisa srrsrs brincadeira muito simples a solucao do amigo... apenas adicionei isso aqui em script: #int-DDNS.Info
    /tool dns-update name=usuario.ddns.info address=127.0.0.255 key-name=usuario key="senha"
    editei colocando meu dominio usuario e senha.... pronto ficou show ateh agora nao deu defeito... estou usando mk 4.17
    Muito obrigado pela solução. Funcionou comigo: Modem da gvt roteado e mikrotik 5.1. Agora ele atualiza no site mesmo com o mesmo ip. Valeu!

  16. loucura ate agora 90% funcionando maisesta dandoesta mensagem no terminal

    echo: ddns,error Authentication Failure

    o resto foi , ja revisei senha login interface , tentei colocar no 4.11 mais nem roda , so no servidor de teste.

  17. Amigo! Já tentou com um domínio "xxxxx.ddns.us"? Eu tenho aqui e funciona em todas as versões normalmente.
    em SCRIPTS tá assim:
    Name: ddns
    Policy: Só não está marcado = "snif" e "sensitive"
    SOURCE:
    tool dns-update name=nomeusuário.ddns.us address=IPdoseumoden key-name=nomeusuário key="senhaddns"

    Em SHEDULER, está: name=DDNS
    On Event: "ddns"
    Policy:
    marque as opções = "read", "write" e "test"

    Qualquer coisa, diz se rodou legal.
    abraço.

  18. Pessoal como faço para acessar minha RB que está rodando um load balance com 2 adsl em bridge e 1link dedicado? quando coloco este script com apenas 1 dos links funciona com 2 ou 3 nao funciona.

  19. Citação Postado originalmente por peritinaicos Ver Post
    Pessoal como faço para acessar minha RB que está rodando um load balance com 2 adsl em bridge e 1link dedicado? quando coloco este script com apenas 1 dos links funciona com 2 ou 3 nao funciona.
    amigo se da certo com 2 e não dá certo com 3 e que tem algo errado...

    tenta esse script
    /tool dns-update name=nick.ddns.info address=127.0.0.255 key-name=claudinhohw key="senha"

    só mudar o que esta de vermelho

  20. Bom dia amigo, obrigado pela ajuda, o detalhe é assim como está entrando nessa rb750 3link adsl e dedicado o script não está rodando ele até atualiza no changeip.com mais não tenho acesso a ela externamente... Outra coisa que estou pensando aqui como faço para acessar um outro MK que está depois dessa rb que está fazendo o loadbalance.. vlw






Tópicos Similares

  1. Respostas: 225
    Último Post: 17-09-2013, 10:13
  2. Acesso remoto ao mikrotik
    Por Aredeprovedor no fórum Redes
    Respostas: 5
    Último Post: 21-05-2012, 08:54
  3. Acesso remoto ao mikrotik - solucao
    Por Raniel no fórum Redes
    Respostas: 43
    Último Post: 09-09-2008, 12:08
  4. Acesso remoto ao mikrotik - avançado
    Por Raniel no fórum Redes
    Respostas: 9
    Último Post: 25-07-2008, 10:09
  5. Porta para acesso remoto ao Apache
    Por debora no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-09-2002, 16:49

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L